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In this section: 

Typographical Conventions ............................................................................... 6 
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Typographical Conventions 

Before you start using this guide, it is important to understand the documentation 
conventions used in it.  

The following kinds of formatting in the text identify special information. 

Formatting convention Type of Information Example 

Special Bold Items you must select, 
such as menu options, 
command buttons, or 
items in a list. 

Go to the System tab. 

 Titles of chapters, 
sections, and subsections. 

Read the Basic Administration 
chapter. 

Italics Used to emphasize the 
importance of a point, to 
introduce a term or to 
designate a command line 
placeholder, which is to be 
replaced with a real name 
or value. 

The system supports the so 
called wildcard character search. 

Monospace  The names of commands, 
files, and directories. 

The license file is located in the 
http://docs/common/licen

ses  directory. 

Preface 
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Formatting convention Type of Information Example 

Preformatted  On-screen computer 
output in your command-
line sessions; source code 
in XML, C++, or other 
programming languages. 

# ls ïal /files  

total 14470  

Preformatted Bold  What you type, contrasted 
with on-screen computer 
output. 

# cd /root/rpms/php  

CAPITALS Names of keys on the 
keyboard. 

SHIFT, CTRL, ALT 

KEY+KEY Key combinations for 
which the user must press 
and hold down one key 
and then press another. 

CTRL+P, ALT+F4 

 
 

Feedback 

If you have found an error in this guide, or if you have suggestions or ideas on how to 
improve this guide, please send your feedback using the online form at 
http://www.parallels.com/en/support/usersdoc/. Please include in your report the guide's title, 
chapter and section titles, and the fragment of text in which you have found an error. 

 

http://www.parallels.com/en/support/usersdoc/


 

  
 

This chapter is intended for hosting service customers who previously used Parallels 
Plesk Panel version 9 and earlier. It describes the most important changes in the Panel 
and addresses possible issues that the users might encounter after their accounts and 
sites are moved to Parallels Plesk Panel 11 during the Panel upgrade. 

The most important concepts you should know  

Á Domain is replaced by subscription. 

The concept of a domain has been replaced with a concept of a subscription - a 
hosting unit able to run multiple sites (domains and subdomains) over given 
resources and services. Multi-domain hosting within one subscription is limited to 
one IP address. Customers who need to host sites on different IP addresses are 
advised to obtain additional subscriptions. 

Á Resources of a client are now resources of a subscription. 

Customers no longer need to redistribute their resources across domains or 
subscription: Each subscription is allocated a fixed set of resources according to a 
hosting plan. 

Á SSL certificates are typically shared among all domains of a subscription. 

All sites in a subscription typically share the same SSL certificate. Customers who 
want to protect all sites in a subscription should consider purchasing a multi-domain 
(a wildcard) SSL certificate. It is also possible to have per-domain certificates in 
case Panel supports SNI. 

Peculiarities of SiteBuilder upgrade  

Á Panel 11 ships with Web Presence Builder (former SiteBuilder), but you can use 
SiteBuilder 4.5 as well. 

Parallels Web Presence Builder is a Panel component that allows fast and efficient 
creation of websites. When Plesk with SiteBuilder is upgraded to Parallels Plesk 
Panel 11, the SiteBuilder component is not actually upgraded. Instead, the new 
Web Presence Builder is installed on the server, and SiteBuilder 4.5 remains 
operable; however, operations on websites created in SiteBuilder 4.5 are limited to 
editing and publishing. 

Á Transfer of websites from SiteBuilder 4.5 to Web Presence Builder is supported, 
with limitations. 

Web Presence Builder allows websites created in SiteBuilder 4.5 to be imported. 
However, this feature has certain limitations: some elements may be missing or 
corrupted in the imported website. We advise you to compare it with the original 
version and add the missing content manually. 

See the section Importing Sites from SiteBuilder 4.5 (on page 152) for more details on 
importing SiteBuilder 4.5 sites to Web Presence Builder. 
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Changes in storing secure content  

Á httpdocs is the only allowed directory for storing web content accessed over secure 
SSL. 

The option to use a separate directory for storing web content that should be 
accessed over secure SSL connections is no longer available. All web content is 

now stored in a single directory - httpdocs . 

The httpsdocs  directory may remain in the webspace after upgrading to Parallels 

Plesk Panel 11, however, we recommend that you place all content in the 

httpdocs  directory when uploading files to the webspace over FTP. 

If you used the option to keep SSL-protected and all other content in separate 

directories, and had APS-packaged applications installed in the httpsdocs  

directory of a website, then after upgrade, the Panel will switch on the compatibility 

mode for that site. This will make the apps previously installed into httpsdocs  

directory accessible to the Internet users, but the apps will not be manageable 

through the Panel, and you will not be able to install new apps to the httpsdocs  

directory. 

In such a case, if you have the necessary technical skills, you can do the following: 

1. Back up all content from the httpsdocs  directory and save it to another 

location. Do not move the files to httpdocs  yet. 

2. Back up databases used by applications installed in httpsdocs  directory. You 

can do this with the help of the mysqldump  utility. 

3. Remove applications from the httpsdocs  directory. 

4. Switch off the compatibility mode through the Panel (at Websites & Domains tab > 
domain name). 

5. Reinstall the required applications. 

6. Upload the data you backed up on the step 1 to the httpdocs  directory. 

7. Restore the applications' databases by importing them to the MySQL database 
server. 

If you are an inexperienced user, we recommend that you leave the previously 

installed applications and uploaded content in the httpsdocs  directory, and host 

new applications on other websites. If you need to install apps on the site operating 

in compatibility mode, you can install them to the httpdocs  (http://) location on 

that site. 



 

  
 

According to the latest studies, the Internet has become the most popular source of 
information in the world, leaving far behind all traditional media such as TV or 
newspapers. Nowadays, the first thing people do when trying to find services is to 
searching for them on the web. Thus, a proper web presence is vital for every 
business. There are a number of ways you can present your company on the Web. A 
web presence may be as simple as a contacts page, or as complex as a large 
company website with access to an ERP system. In both cases, you should perform 
the same steps to get your business online. 

Before proceeding any further, you will need to take the following two essential steps: 

Á Purchase a customer account from a hosting provider. 
Your customer account provides access to the services that are vital for a web 
presence - Internet connectivity, disk space to store your website content, and so 
on. For more information about customer accounts in Panel, refer to the chapter 
Customer Account Administration (on page 36). 

Á Register a domain name. 
This is the name people will use to access your site from their browsers. For 

example, www.example.com .  

These two elements - an account for web hosting management and a domain name 
make up your website. 

In this chapter, we will explain how to create your first website, fill it with content, create 
mailboxes for users of the site, and, finally, view the site visits statistics. 

Advanced Hosting Features  

Once you are comfortable with basic Panel capabilities, try out some advanced hosting 
features: Expand website functionality by installing web applications (on page 98), 
secure your sites with SSL certificates (on page 106), employ databases (on page 
214), and much more. Note that hosting providers can turn off some of the advanced 
features to make your Control Panel look simple and user friendly. We have used the 
(Advanced) prefix to designate the sections about features that may be turned off. If you 
require one of the advanced options, contact your hosting provider. 

In this chapter: 

Set Up Your First Website ................................................................................. 11 
Set Up Mail Accounts ........................................................................................ 16 
View Site Visit Statistics .................................................................................... 35 
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Set Up Your First Website 

Now that you have a customer account and a domain name, the first thing you will want to do 
is create a website. The information about the possible ways to do it is provided in the 
section 1. Create Your Site (on page 11) 

When your site is ready, you may want to take a look at the result in your browser. Learn 
how to do it in the section 2. Preview your Site (on page 14). 

Even a perfectly designed site will not be effective if no one knows about it. When all the 
design work is done, you need to submit your site to popular search engines. The 
corresponding instruction is located in the section 3. Submit Your Sites to Search Engines (on 
page 15). 

In this section: 

1. Create Your Site ............................................................................................ 11 
2. Preview Your Site .......................................................................................... 14 
3. Submit Your Sites to Search Engines ............................................................ 15 
 
 

1. Create Your Site 

There are three general ways to create a website: 

Á Employ a web design studio to create a site for you, and then you will just maintain its 
content.  

Á Create a site by yourself using Web Presence Builder - the powerful tool that allows you 
to create professional-looking websites in a few mouse clicks. Learn more in the section 
Web Presence Builder (on page 12). 

Á Create your website in a third-party Content Management System - an editor that allows 
you to easily create and edit website content such as pages, scripts, applications, and so 
on. To learn more about creating sites in third-party content management systems, see 
the section Content Management Systems (on page 12). 

If you have purchased a ready-made site or created it by yourself, you should upload the site 
content to your account to make the site visible on the web. There are two ways to upload 
content: 

Á Using FTP. Learn more in the section Uploading Content Using FTP (on page 14).   

Á Using an integrated <filemng>. Learn more in the section Uploading Content with <filemng> 
(on page 14). 

In this section: 

Web Presence Builder ...................................................................................... 12 
Content Management Systems ......................................................................... 12 
Uploading Content ............................................................................................ 13 
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Web Presence Builder 

Web Presence Builder is a tool that enables users with no knowledge of HTML markup or 
graphic design skills to create professional-looking sites. This tool provides a simple visual 
editor and a huge set of templates for different websites. The editor allows you to create web 
pages, add content of different types (text, images, video, scripts), and edit website settings 
such as website name, keywords, icons, and so on. 

To create websites in Web Presence Builder, ensure that your hosting subscription includes 
this option. If it does not, choose another way or upgrade your subscription. 

ü To create a website with Web Presence Builder: 

1. Go to either the Home tab or the Websites & Domains tab, and click the link 
Launch Web Presence Builder. 

2. Select a topic that best suits your website. 

3. Edit the website: 

a. Structure: add more pages, remove the predefined pages that you do 
not need. 

b. Content: change the predefined content to your own, add text, 
images, videos, scripts, and other required elements. 

c. Design: change the layout and color scheme. 

4. Publish the website. 

Find more information about creating websites with Web Presence Builder in the section 
Building Websites with Web Presence Builder. 

Content Management Systems 

Content Management Systems (or CMS) are applications that provide a graphical user 
interface for adding and editing website content: pages, scripts, files, multimedia content, and 
so on.  

Before you can create a website in a third-party CMS, you should install the CMS on your 
hosting account. Note that you can install the CMS only if your hosting subscription allows it. 

ü To create a website using a CMS: 

1. Go to the Applications tab.  

2. Find the CMS you need in the list of available applications, and install it as 
described in the section Using Website Applications (on page 98). 

3. Create your website in the CMS. For information about creating websites 
with your CMS, refer to the relevant documentation. 
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Uploading Content 

If you already have a website created by yourself or a web design studio, just upload the 
website files and folders to your provider's server. You can do this in one of the following 
ways: 

Á Using FTP. This way is better when several people manage a website's content because 
it does not require access to your customer account. You can just create FTP users for 
them. Learn more about this method in the section Uploading Content Using FTP (on page 
14). 

Á Using Control Panel File Manager. This way is more convenient since it uses the Control 
Panel GUI and provides a set of useful features, for example, a visual HTML editor and a 
file permissions manager. Find more information on the features of content manager in 
the section Uploading Content with File Manager (on page 14). 

In this section: 

Uploading Content Using FTP........................................................................... 14 
Uploading Content with File Manager ............................................................... 14 
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Uploading Content Using FTP 

ü To publish a website using FTP: 

1. Connect to your webspace on the server with an FTP client program, using 
your FTP account username and password. 

You can change your username and password in the Panel at the Websites & Domains tab 
> Web Hosting Settings. 

The FTP address should be ftp://your-domain-name.com, where your-domain-name.com 
is your site's Internet address. 

Enable the passive mode if you are behind a firewall. 

2. Upload the files and directories of your site to the httpdocs  directory. If you 

use CGI scripts, place them in the cgi - bin  directory. 

3. Close your FTP session. 

You can also set up additional FTP accounts if you need to collaborate on website content 
with other users. For more information, see the section Adding FTP Accounts (on page 192). 

Uploading Content with File Manager 

To upload a website from your computer to Panel server with File Manager, open the Files 
tab of Control Panel and drag the website folder to the central area of this tab. You can also 
upload your website as a compressed ZIP file and then extract the contents using the 
archiver integrated in File Manager.  

With File Manager, you can also do the following: 

Á Edit HTML files in the visual editor. 

Á Preview website pages. 

Á Edit files in the text editor. 

Á Manage the files' access permissions. 

Learn more about uploading and editing website files and folders with File Manager in the 
section Managing Website Content (on page 90). 
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2. Preview Your Site 

After you uploaded website files to the webspace, you can check how your site will look in a 
web browser, even before the information about the new site has spread in the Domain 
Name System. 

ü To preview a site:  

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. In the list of domain names at the bottom of the screen, locate the website 

that you want to preview and click the corresponding icon . 

You site will open in a new browser window. 

Note:  For sites created with Web Presence Builder, protected access to site pages can work 
incorrectly in Preview mode. 

Sometimes, you may need to show your site to someone when your domain name is not 
registered yet. There are several ways to do it without giving a person access to your 
customer account. Learn more in the section Previewing Websites (on page 97).  

3. Submit Your Sites to Search Engines 

To gain more visitors and drive traffic to your site after you publish it on the Internet, you 
need to submit it to search engines. Before the site submission, you can improve the site 
ranking in search results by the following content optimizations: 

Á Include in the text contained in your web pages the frequently searched keyword 
phrases, which are relevant to the topic of your site. For example, mention your product 
or a topic of your interest several times in the text on a web page. 

Á Add relevant keywords to the <title>  and <meta>  tags. Some search engines look for 

keywords and descriptions in meta tags placed within web pages, and present these 
keywords in search results. 

For example, if you are selling hosting automation software, then you can include the 
following tags in HTML pages of your website:  

<HEAD> 

<TITLE>Ordering hosting automation software  

</TITLE>  

<META name="keywords" content="order,hosting,software">  

<META name="description" content="Ordering Hosting Automation Software">  

</HEAD> 

Separate the keywords with a comma without white spaces. 
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After you optimize the website and publish it to your customer account, submit it to search 
engines, such as Google, Yahoo, Bing, and other engines that you know to be popular in 
your country.  

Á To submit a site to Google, visit http://www.google.com/addurl/. 

Á To submit a site to Yahoo, visit https://siteexplorer.search.yahoo.com/submit. 

Á To submit a site to Bing, visit https://ssl.bing.com/webmaster/SubmitSitePage.aspx. 

 
 

Set Up Mail Accounts 

Once your website is ready, you can start creating mail accounts. You can choose, for 
example, to create mail accounts for all users within your organization. Note that the number 
and size of mailboxes is limited by your hosting plan. 

In this section: 

1. Create Mail Account ...................................................................................... 17 
2. Access Your Mailbox ..................................................................................... 18 
 
 

http://www.google.com/addurl/
https://siteexplorer.search.yahoo.com/submit
https://ssl.bing.com/webmaster/SubmitSitePage.aspx
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1. Create Mail Account 

ü To create an e-mail address: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Click the Mail tab. 

3. Click Create E-mail Address. 

4. Type the left part of the e-mail address before the @ sign, and, if you have 
several domain names on your account, select the domain name under 
which the e-mail address will be created. 

5. Leave the Mailbox checkbox selected. 

Clearing this checkbox makes sense only if you want to use this address as a mail 
forwarder, which will forward all incoming mail to another address. 

6. Specify the mailbox size or use the default size defined by the provider's 
policy or your service plan. 

7. Specify a password consisting of five or more Latin characters. 

8. Click OK. 
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2. Access Your Mailbox 

There are two ways to access a mailbox for sending and receiving e-mail messages: 

Á Set up and use an e-mail client program on your computer. Typically, in such programs 
you should specify the following settings: 

Á Username. In this field, specify your full e-mail address. For example, 
johndoe@example.com. 

Á Password. Most likely, the password to your e-mail account. 

Á Mail server protocol. This property defines whether you want to keep copies of 
messages on the server or not.  To keep the copies on the server, select the IMAP 
option. If you do not want to keep them on the server, select POP3. Selecting IMAP will 
also allow you to train the SpamAssassin spam filter on e-mail messages you receive, 
if SpamAssassin is enabled on the server. 

Á Incoming mail server (POP3/IMAP). Type your domain name. For example, 
example.com. The POP3 port is 110. The IMAP port is 143. 

Á Outgoing mail server (SMTP). Type your domain name. For example, example.com. 
The SMTP port is 25. This server requires authentication. 

To get detailed instructions on configuring popular e-mail clients to work with your 
mailbox, see subsections of this section. 

Á Use a web browser to connect to the webmail interface. Webmail interface is provided by 
Horde IMP Webmail software, which is installed by default. You can either use the default 
Horde IMP Webmail, or install Atmail Webmail Lite software. 

 

Note: If you cannot access your mailbox following the instructions in this section, this might 
be caused by mail server settings. Contact your hosting provider to resolve the issue. 

 

In this section: 

Access from Webmail ........................................................................................ 19 
Access from Microsoft Office Outlook ................................................................ 19 
Access from Microsoft Outlook Express ............................................................ 23 
Access from Mozilla Thunderbird ...................................................................... 27 
Access from Apple Mail ..................................................................................... 30 
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Access from Webmail 

ü To access your mailbox through webmail, do any of the following: 

Á In a Web browser, visit the URL webmail.example.com , where example.com  is the 

Internet address of your website. When prompted, specify your full e-mail address as the 

username (for example, mail@example.com ), and specify the password that you use 

for logging in to the Panel. 

Á When logged in to the Panel, click the Mail tab, and in the list of e-mail addresses, click 

an icon  corresponding to the e-mail address you need. 

 
 

Access from Microsoft Office Outlook 

ü To set up Microsoft Office Outlook 2010: 

1. Open Microsoft Office Outlook. 

2. Go to File > Info > Add Account. 

3. Select the checkbox Manually configure server settings or additional server types. 
Click Next. 
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4. Select the Internet E-mail option and click Next. 
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5. Specify the following: 

Á Your name. 

Á Your e-mail address. 

Á Account type. If you want to keep copies of messages on the server, select the IMAP 
option. If you do not want to keep any messages on the server, select the POP3 
option. Selecting IMAP will also allow you to train the SpamAssassin spam filter on e-
mail messages you receive, if SpamAssassin is enabled on the server. 

Á Incoming mail server. Type your domain name. For example, example.com. 

Á Outgoing mail server (SMTP). Type your domain name. For example, example.com. 

Á User Name. Specify your full e-mail address. Example: johndoe@example.com. 

Á Password. Most likely, this password coincides with the password you use for logging 
in to Panel. 

Á Require logon using Secure Password Authentication (SPA). Leave this option cleared. 
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6. Click More Settings, open the Outgoing Server tab and check My outgoing server 
(SMTP) requires authentication. 

 

7. Click Next. 

8. Click Finish. 
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Access from Microsoft Outlook Express 

The instructions provided in this section were verified against Microsoft Outlook Express 6. 
They might not work with earlier or later versions of Microsoft Outlook Express. 

ü To set up Microsoft Outlook Express: 

1. Open Microsoft Outlook Express. 

2. Go to Tools > Accounts. 

3. Click the Add button and select the Mail item. 

4. Enter your name as you want it to appear in any messages you send, and 
click Next. 
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5. Type your e-mail address, and click Next. 

 



 

 Quick Start with Parallels Panel 25 

 

6. Specify the following settings: 

Á Protocol of your incoming mail server. 

If you want to keep copies of messages on the server, select the IMAP option. If you 
do not want to keep any messages on the server, select the POP3 option. Selecting 
IMAP will also allow you to train the SpamAssassin spam filter on e-mail messages 
you receive, if SpamAssassin is enabled on the server. 

Á Incoming mail server. Specify your website's Internet address. 

Á Outgoing mail server. Specify your website's Internet address. 
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7. Click Next. 

8. Specify the following: 

Á Your account name. Type your e-mail address in the Account name box. 

Á Your password. Most likely, this password coincides with the password you use for 
logging in to the Panel. 

Á Remember password checkbox. Leave it selected if you do not want to be prompted to 
enter password each time your e-mail program connects to the mail server to check 
for new mail, and click Next. 

 

9. To complete setting up your e-mail program, click Finish. 
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Access from Mozilla Thunderbird 

The instructions provided in this section were verified against Mozilla Thunderbird 12. They 
might not work with earlier or later versions of Mozilla Thunderbird. 

ü To set up Mozilla Thunderbird: 

1. Open Mozilla Thunderbird. 

2. Go to Tools > Account Settings > Account Actions > Add Mail Account. 

3. Specify the following: 

Á Your name, as you want it to appear in any messages you send. 

Á Your e-mail address and password. 
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4. Click Continue. 

5. If Thunderbird fails to find the settings automatically, specify the following: 

Á Account type. If you want to keep copies of messages on the server, select the IMAP 
option. If you do not want to keep any messages on the server, select the POP3 
option. Selecting IMAP will also allow you to train the SpamAssassin spam filter on e-
mail messages you receive, if SpamAssassin is enabled on the server. 
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6. Click Create Account. 

 

If you set up a mail account manually, please use the following typical combinations of 
connection security and authentication method settings. If the settings do not work for you, 
ask your hosting provider about the correct combination. 

On Linux: 

Á Connection security: STARTTLS 

Á Authentication method: Encrypted password 

 

On Windows, IMAP: 

Á Connection security: None 

Á Authentication method: Encrypted password 

 

On Windows, POP3: 

Á Connection security: None 

Á Authentication method: Password, transmitted insecurely 

Other parameters that you may need when configuring your account manually: 

Á POP3 port: 110 

Á IMAP port: 143 

Á SMTP port: 25  

Á Username. Your full e-mail address. For example: johndoe@example.com. 

Á Incoming server address (POP3/IMAP). Specify your website's Internet address. Example: 
example.com 

Á Outgoing server address. Specify your website's Internet address. Example: example.com 

 
 



 

30 Quick Start with Parallels Panel 

 

Access from Apple Mail 

The instructions provided in this section were verified against Apple Mail 3.6 (Leopard). They 
might not work with earlier or later versions of Apple Mail. 

ü To set up Apple Mail: 

1. Run Apple Mail. 

If you run it for the first time and do not have any mail accounts configured in it, skip the 
next step: Apple Mail will take you directly to creating one. 

2. Open the Adding Mail Account wizard: 

a. Click Mail > Preferences.... 

b. Select the Accounts tab. 

c. Click the + button at the bottom left corner. 

3. Enter the account information: 

Á Your full name 

Á Your full e-mail address 

Á The password you use to log in to the Panel.  

 



 

 Quick Start with Parallels Panel 31 

 

4. Click Continue. 

5. Fill in the following incoming mail server information: 

Á Account Type: select whether you want to use IMAP or POP protocol. 

We recommend selecting IMAP if you use SpamAssassin as a spam filtering solution: 
IMAP account is a requirement for SpamAssassin learning which messages are spam 
and which are not. 

Á Incoming Mail Server: type in the name of domain which serves your mail (which follows 
the @ sign in your e-mail address). 

Á User Name: enter your full e-mail address.  

Á Password: leave it auto-completed (Apple Mail takes it from the previous step). 
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6. Click Continue. 

7. (Optional) Specify the incoming mail security options: 

a. Select the Use Secure Sockets Layer (SSL) checkbox. 

b. Select the authentication method. 

Keep the default method if you are not sure which to select. 

Apple Mail displays this setup screen only if a mail server bundled with Parallels Small 
Business Panel supports SSL for the selected account type (POP or IMAP). 
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8. Click Continue. 

9. Fill in the following outgoing mail server information: 

Á Outgoing Mail Server: type in the name of domain which serves your mail (which follows 
the @ sign in your e-mail address). 

Á Use only this server: selected. 

Á Use Authentication: selected. 

Á User Name: enter your full e-mail address.  

Á Password: leave it auto-completed (Apple Mail takes it from the previous step). 
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10. Click Continue. 

Apple Mail displays overall description of the mail account that is going to be created. 

11. Select the Take account online checkbox and click Create. 
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View Site Visit Statistics 

Finally, when your site works fine and search engines return it in search results, it is the best 
time to evaluate site efficiency by viewing the visits statistics. 

ü To find out how many people visited a site, from what countries, and what 
pages of the site they viewed: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Web Statistics. 

The site visitor statistics will show in a new browser window. 

3. To view statistics for web pages viewed from the SSL-secured area of your 
site, select SSL Web Statistics in the menu. 

4. To view statistics for files downloaded over the file transfer protocol (FTP), 
select FTP Statistics in the menu. 

Alternately, you can view the visits statistics for a site by visiting the following URL: 
https://your-domain.com/plesk-stat/webstat. When prompted for username and password, 
specify your FTP account username and password. 

You have successfully completed the quick start part of the guide. Feel free to read about 
other features that are available to you in the Control Panel. 



 

  
 

As described in the section Quick Start with Parallels Panel (on page 10), the first step in 
establishing your company's web presence is signing up to the services provided by a 
hosting company (hosting provider). After you subscribe to a hosting plan, a customer 
account in Panel is created to enable you to log in to Panel and use the hosting 
services and resources like mailboxes, disk space, and bandwidth. 

Customer Account and Multiple Subscriptions  

Panel allows you to subscribe to as many hosting plans as you need. For example, if 
you do not want your main site to share hosting resources with a company's branch 
site you can subscribe to another hosting plan under the same customer account. In 
other words, a customer account is a personalized access to all your subscriptions (see 
the picture below). 
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Another reason for using multiple subscriptions is that subscription is limited to only 
one IPv4 and one IPv6 address. Thus, all domains within a subscription share the 
same IP address (v4 or v6). If you need to host sites on different IP addresses, you 
should additionally order the same plan for as many IP addresses as you need. This 
can be useful, for example, if you want to secure connections to each of your sites with 
a separate SSL certificate. For information on how to purchase an additional 
subscription, refer to the section Ordering More Resources (on page 50). 

If you have multiple subscriptions under a single customer account, you can easily 
switch among them from the Account tab. To be more specific, the Account tab provides 
access to operations that apply to all your subscriptions. All other tabs (like Mail, Users, 
or Domains & Websites) are, on the contrary,  subscription-wide. This means that to 
change mail settings on a particular subscription, you should first switch to it before 
clicking Mail.  

Adding Resources to a Subscription  

Purchasing a new subscription for extending hosting resources is not always 
necessary. You can always improve just one of your subscriptions. For example, add 
extra disk space or SSL support. This can be done by switching to another hosting plan 
or by purchasing hosting plan add-ons. Learn more in the section Ordering More 
Resources (on page 50). 

Managing Customer Account  

In Panel, you can perform a number of administrative operations on your customer 
account:   

Á Change an account password and personal information. Learn more in the section 
Changing Your Password and Contact Information (on page 39). 

Á View the list of services and resources provided by subscription on the Account tab. 
For detailed information about all subscription features, refer to the section Viewing 
Subscription Summary (on page 40). 

Á Make payments to renew your subscription. Learn more in the section Managing 
Account Balance and Invoices (on page 47). 

Á View statistics on your account: For example, disk space or traffic usage. Learn 
more in the section Viewing Statistics (on page 52). 

  

Allow Other Users to Access Your Account  

If the number of hosting maintenance operations is too large to be handled by one 
person, you can delegate some of them to other people. For this purpose, you can 
create auxiliary user accounts grouped by means of user roles. For example, you can 
create a group that is allowed to only upload content to websites. Users in this group 
will not be able to perform any operations except for managing website content. For 
more information about auxiliary users, refer to the section (Advanced) Managing Auxiliary 
User Accounts (on page 54). 



 

38 Customer Account Administration 

 

In this chapter: 

Changing Your Password and Contact Information ........................................... 39 
Viewing Subscription Summary ......................................................................... 40 
Managing Account Balance and Invoices .......................................................... 47 
Ordering More Resources ................................................................................. 50 
Viewing Statistics .............................................................................................. 52 
(Advanced) Managing Auxiliary User Accounts ................................................. 54 
 

 



 

 Customer Account Administration 39 

 

Changing Your Password and Contact 
Information 

ü To change your password for access to Control Panel: 

1. Click a link with your name at the top of the screen. 

2. Type a new password, and click OK. 

ü To change a username or password that you use for connecting to your 
webspace: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen. 

2. Click the Websites & Domains tab. 

3. Click Web Hosting Settings. 

4. Type the new username or password, and click OK. 

ü To change your contact information: 

1. Click a link with your name at the top of the screen. 

2. Click the Contact Details tab. 

3. Update your contact information and click OK. 
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Viewing Subscription Summary 

When you subscribe to hosting services, a user account is created in the Panel to allow you 
to manage your websites and mailboxes on your own. 

You can view the following information about your account: 

Á Current subscriptions to service plans. 

You can be subscribed to a number of service plans at once, and, therefore, can have 
several subscriptions associated with your account. If a billing system is connected to the 
Panel, then you can also purchase additional subscriptions, upgrade or downgrade them, 
and pay your invoices.   

Á Allocated and consumed resources. 

Á Hosting features available for your websites. 

Á Operations you can perform in your Panel. 

Á Account balance, unpaid invoices, and monthly fee for your hosting package. 

ü To view the information about your account and your current subscriptions: 

1. Click the Account tab. 

A list of your current subscriptions is shown. 

2. If the billing system is integrated with the Panel, then the following 
information is shown: 

Á Account credit balance. This is how much money is available in your billing account. 

Á Due invoices balance. This is how much money you owe to your provider. Here, you can 
pay all invoices at once by clicking Pay All Outstanding Invoices, or pay one of invoices 
by clicking a Pay Now link in the list titled Latest Outstanding Invoices. You can also view 
all invoices by clicking the link Show all invoices, or print an invoice by clicking an 
invoice number and then clicking Print. 

Á Latest to-do items. This shows reminders from the system about the actions you need to 
take. 

Á List of all your subscriptions. You can use links in the list to perform the following 
operations: 

Á View subscription properties by clicking a link with subscription name. 

Á Select a subscription that you want to manage through the Control Panel by 
clicking the corresponding link Switch to Subscription. 

Á Order an SSL certificate for a site by clicking Request SSL Certificate. This operation 
is described in the section Ordering SSL Certificates. 

Á View properties of already ordered SSL certificates by clicking Show Certificate Info. 

Á View or change domain information, contact information, and DNS settings 
specified at a registrar's site, by clicking Show Domain Info. These operations are 
described in the section Registrar's DNS Settings in Panel (on page 77). 
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3. To view detailed information about resource allotments, available hosting 
options, and permissions for operations, click a subscription's name. 

4. Do any of the following: 

Á To view a list of allocated and consumed resources, click the Resources tab.  

Á To view a list of hosting features available for your account, click the Hosting Options 
tab. 

Á To view a list of operations that you can perform in your Hosting Panel, click the 
Permissions tab. 

Á  

 

In this section: 

Allocated and Consumed Resources ................................................................. 42 
Hosting Features Available for Your Websites ................................................... 44 
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Allocated and Consumed Resources 

If you are subscribed to a number of service plans at once, then you have several 
subscriptions. For each subscription, the following types of allocated resources are listed in 
the Panel at the Account tab > subscription name > Resources tab: 

Á Disk space. This is the total amount of disk space allocated to your account with 
subscription. This amount includes all data related to your websites, e-mail accounts, 
applications, backups, and log files. 

Á Traffic. This is the total amount of data in megabytes that can be transferred monthly from 
all your websites. 

Á Domains. This is the number of websites that can have separate second-level domain 
names, such as, for example, example.com. 

For information about setting up websites, refer to the sections Set Up Your First Website 
(on page 11) and Adding Domains (on page 63). 

Á Subdomains. This is the number of additional websites that can have third-level domain 
names, such as, for example, news.example.com. 

For information about setting up subdomains, refer to the section Adding Subdomains (on 
page 65). 

Á Domain aliases. This is the number of additional domain names that can be set up to point 
to one of your sites. For example, example.fr and example.de can both point to 
example.com. 

For information about setting up domain aliases, refer to the section Adding Domain Aliases 
(on page 67). 

Á Mailboxes. This is the number of mailboxes that can be created under all your websites. 

For information about creating mailboxes, refer to the chapter Mail (on page 196). 

Á Mailbox size. This is the amount of disk space that can be occupied by a mailbox. 

Á Total mailboxes quota. This is the total amount of disk space that can be used by all 
mailboxes under all your domains. This option is available only on Windows-based 
customer accounts. 

Á Mailing lists. This is the total number of mailing lists that can be set up under all your 
websites. Note that there are mailing lists and mail groups, which serve the same 
purpose, but are slightly different in functionality. Mailing lists support archiving and pre-
moderation of messages, while mail groups can only be used for sending one message to 
a number of recipients at once. 

For information about setting up and using mailing lists, refer to the section Using Mailing 
Lists (on page 206). 

Á Additional FTP accounts. This is the number of FTP accounts that can be set up for 
accessing the webspace, in addition to the main FTP account that was created when your 
subscription was activated. 

For information about setting up FTP accounts, refer to the sections Changing FTP Access 
Credentials (on page 191) and Adding FTP Accounts (on page 192).  

Á Databases (Linux). This is the number of databases that can be hosted for all your 
websites. Databases are a standard means of organizing data storage that allows 
dynamic websites, web applications, and their users to store, search, and retrieve 
information. 
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For information about working with databases, refer to the chapter (Advanced) Using 
Databases (on page 214). 

Á MySQL databases and Microsoft SQL Server databases (Windows). This is the maximum 
number of MySQL and Microsoft SQL Server databases respectively that can be created 
on the Panel database servers and used by the subscription's websites. 

Á MySQL databases quota and Microsoft SQL databases quota (Windows). This is the maximum 
amount of disk space (in megabytes) that the subscription's MySQL and Microsoft SQL 
Server databases respectively can occupy. 

Á Java applications. This is the number of Java applications packaged in WAR format that 
you can install on your sites. 

Á Sites published with Web Presence Builder. This is the number of sites that you can create 
and publish using Web Presence Builder, if Web Presence Builder option is included in 
your hosting package. 

Á Mobile sites.This is the total number of websites that you can host with the UNITY Mobile 
online service, which optimizes sites for viewing on mobile devices. 

Á Web users. This is the number of user accounts that you can create for hosting web pages 
for other users under your domains. 

Á FrontPage accounts. This is the number of Microsoft FrontPage user accounts that you can 
create for collaboration on site content using FrontPage. This option is available only for 
Windows-based customer accounts. 

Á Shared SSL links. This is the number of websites that you can secure with an SSL 
certificate shared by your provider. This option is available only for Windows-based 
customer accounts. 

Á ODBC DSN connections. This is the number of connections to external databases that you 
can create for web applications running on your customer account. This option is 
available only for Windows-based customer accounts. 

Á ColdFusion DSN connections. This is the number of connections to external databases that 
you can create for web applications written in Adobe ColdFusion, which are running on 
your customer account. This option is available only for Windows-based customer 
accounts. 
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Hosting Features Available for Your Websites 

Depending on your service plan, the following hosting features may be available for your 
websites (listed at the Account tab > subscription name > Hosting Options tab): 

Á SSL support. This allows you to secure connections to websites with SSL encryption. 

For information about securing sites with SSL, refer to the section Securing Connections 
with SSL Certificates (on page 106). 

Á Web statistics. This allows you to view website visits statistics presented in diagrams and 
charts. 

For information about viewing website visits statistics, refer to the section Viewing Statistics 
(on page 52). 

Á Custom error documents. This allows you to create custom HTML pages and configure web 

server to show them instead of typical error messages, such as 404 Not Found.  

For information about setting up custom error documents, refer to the section Setting Up 
Custom Error Pages (on page 116).   

Á Support for programming and scripting languages, such as PHP, CGI, Perl, Python, Microsoft 
ASP, ASP.NET, Adobe ColdFusion, SSI.  

Á Microsoft FrontPage support and Microsoft FrontPage over SSL support. These allow you to use 
Microsoft FrontPage to create and edit website content. These options are available only 
for Windows-based customer accounts. 

Á Remote Microsoft FrontPage authoring (Windows). This allows you to use Microsoft 
FrontPage to create and edit website content directly on the server. This option is 
available only for Windows-based customer accounts. 

Á Dedicated IIS application pool (Windows). This provides isolation and improved stability for 
web applications working on sites. 

Á Additional write/modify permissions (Windows). This option allows the web applications to 

use a file-based database (like Jet) located in the root of httpdocs  folder. 

Á Allow web users to use scripts. This allows scripting at web pages available at URLs like 
http://example.com/~<username>/<webpage>, where <username> refers to a web user. 
Web users are individuals who do not need their own domain names. This service is 
popular with educational institutions that host non-commercial personal pages of their 
students and staff. 

  

The following is a list of permissions for operations that you can perform in your Panel 
(shown at the Account tab > subscription name > Permissions tab): 

Á DNS zone management. Manage resource records in the DNS zones of websites. DNS 
stands for Domain Name System. It is a service that enables web browsers to locate 
websites by domain names. 

For information about configuring DNS settings for your websites, refer to the section 
(Advanced) Configuring DNS for a Domain (on page 70). 

Á Hosting settings management. Manage web hosting settings, such as support for scripting 
languages. 
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Á PHP safe mode management. This option is available only for Linux-based customer 
accounts. It allows you to switch PHP safe mode on or off for websites. Safe mode is a 
security restriction that does not allow scripts written in PHP to perform potentially 
dangerous operations on the server. You might need to switch off the safe mode for PHP 
if you use some web applications written in PHP and if they do not function properly. 

Á Management of access to the server over SSH and Management of access to the server over Remote 
Desktop. Securely upload web content to the server through Secure Shell (Linux) or a 
Remote Desktop connection (Windows).  

Á Anonymous FTP management. Set up a folder on the server which should be accessible to 
the Internet users over FTP protocol. This folder can have an address like, for example, 
ftp://downloads.example.com. This feature is called anonymous FTP because the users 
will not need to specify a username and password to browse, download, or upload files. 

For information about setting up FTP folder with unrestricted access, refer to the section 
Setting Up Anonymous FTP Access (on page 194). 

Á Scheduler management. Schedule execution of programs or scripts in the server's operating 
system. 

For information about scheduling tasks, refer to the chapter Scheduling Tasks (on page 
207). 

Á Spam filter management. Set custom settings for protection from unsolicited commercial e-
mail, also known as spam. 

For information about setting up spam filtering, refer to the section Protecting Mailboxes 
from Spam. 

Á Antivirus management. Set custom settings for protection from viruses and other malicious 
software that spreads itself through e-mail. 

For information about setting up virus protection, refer to the section Protecting Mailboxes 
from Viruses. 

Á Data backup and restoration using the server repository. Use the backup and restore functions 
of the Panel to back up and restore websites, mail accounts, settings, and keep your 
backup files on the server. 

For information about backing up and restoring data, refer to the chapter (Advanced) Back 
Up and Restore Data (on page 221).  

Á Data backup and restoration using a personal FTP repository. Use the backup and restore 
functions of the Panel to back up and restore websites, mail accounts, settings, and save 
your backup files to an FTP folder on another server. 

For information about backing up and restoring data, refer to the chapter (Advanced) Back 
Up and Restore Data (on page 221).  

Á Web statistics management. Set custom preferences for visitor statistics reports. 

For information about configuring and viewing website visitor statistics, refer to the 
section Viewing Statistics (on page 52).  

Á Log rotation management. Set custom preferences for recycling (rotation) of web server 
logs. Web server records information about connections to your sites and errors occurred 
on attempts to retrieve missing files. You can use these log files for website debugging 
purposes. 

For information about working with web server access logs, refer to the section Log Files 
(on page 53). 

Á Access to Application Catalog. View and install applications on websites. For information 
about applications, refer to the section Employing Website Applications (on page 98). 
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Á Setup of potentially insecure web scripting options that override provider's policy. This allows you 
to override the hosting security policy, if it is applied by the provider. 

Á Domain creation. Set up and manage new websites. 

For information about setting up websites, refer to the sections Set Up Your First Website 
(on page 11) and Adding Domains (on page 63). 

Á Subdomains management. Set up and manage new websites with addresses like 
forum.example.com. 

For information about setting up subdomains, refer to the section Adding Subdomains (on 
page 65).  

Á Domain aliases management. Set up and manage additional domain names for a site. 

For information about setting up domain aliases, refer to the chapter Adding Domain Aliases 
(on page 67). 

Á Additional FTP accounts management. Set up and manage additional FTP accounts. To 
enable collaboration on website content, you can set up FTP accounts for other users 
and specify which directories of the site should be accessible to them. 

For information about setting up FTP accounts, refer to the section Adding FTP Accounts 
(on page 192).  

Á Java applications management. Install and manage Java applications distributed in WAR 
archives and obtained separately from third-party vendors or application developers. 

For information about installing Java applications, refer to the section Installing Java 
Applications.  

Á Mailing lists management. Set up and manage mailing lists. 

For information about setting up and using mailing lists, refer to the section Using Mailing 
Lists (on page 206). 

Á Hosting performance settings management. Limit the bandwidth and number of connections to 
websites. 

For information about restricting bandwidth usage for sites, refer to the section Limiting 
Bandwidth and Number of Connections to Websites (on page 125). 

Á IIS application pool management. Set custom preferences for IIS application pool (available 
only on Windows-based customer accounts). 

For information about setting up IIS application pool, refer to the section Setting Up IIS 
Application Pool (Windows) (on page 143). 

Á Additional write/modify permissions management. Set additional write/modify permissions for 
websites that use file-based databases (available only on Windows-based customer 
accounts). 

Á Shared SSL management. Secure connections to your sites with SSL protection by using an 
SSL certificate shared by your provider. 

For more information, refer to the section Using Shared SSL Certificates (Windows) (on page 
110). 

Á Hard disk quota assignment. Adjust hard quotas on disk space if that is supported by your 
customer account. 

Á Database server selection. Select a database server for creating databases, if multiple 
database servers are available. 
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Managing Account Balance and Invoices 

The operations described below are available if your Control Panel is integrated with a billing 
system. 

ü To view your account balance and pay for hosting services: 

1. Click the Account tab. 

2. The following information is shown: 

Á Account credit balance. This is how much money is available in your account. 

Á (Optional) Usage charge. If your subscription allows consuming hosting resources 
over the plan limit, this number shows how much money you should pay for these 
resources in addition to your subscription price. To view the detailed information about 
how much resources you used over limits, click the link See details below the charge 
amount. To learn how the system calculates usage charges, see the section 
Calculating Usage Charges (on page 49). 

Á Due invoices balance. This is how much money you owe to your provider. Here, you 
can pay all invoices at once by clicking Pay All Outstanding Invoices, or pay one of 
invoices by clicking a Pay Now link in the list titled Latest Outstanding Invoices. 

Á Latest to-do items. This shows reminders from the system about actions you need to 
take. 

Á (Optional) Affiliate programs. Your provider may let you earn money for promoting 
their plans. To start earning, you should join their affiliate programs. Here you can find 
the link to join affiliate programs or the info about your money you earn if you already 
joined the programs. To learn how to get profit from affiliate programs, see the section 
Earning Credits for Promoting Provider's Plans (on page 49).  

Á List of all your subscriptions. You can use links in the list to perform the following 
operations: 

Á To view subscription properties, click a link with subscription name. 

Á To select a subscription that you want to manage through the Control Panel, click 
the corresponding link Switch to Subscription. 

Á To order an SSL certificate for a site, click Order a Certificate. For more information 
about this operation, see the section Ordering SSL Certificates. 

Á To view properties of already ordered SSL certificates, click Show Certificate Info. 

Á To view or change domain information, contact information, and DNS settings 
specified at a registrar's site, click Show Domain Info. For more information about 
these operations, see the section Registrar's DNS Settings in Panel (on page 77). 
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ü To choose a payment method that you would like to use for paying for 
services: 

1. Go to the Account tab > Billing Accounts. 

A record about the payment method that you used for purchasing the services for the first 
time is shown. 

2. Do any of the following: 

Á To view or change settings for a billing account, click the corresponding link in the 
Billing account name column, specify the information about your bank card or account, 
and select the subscriptions that should be paid by it. Click OK. 

Á To add a new billing account, click Add New Billing Account, select the payment method, 
click Next, specify the required information about your bank card or account, and 
select the subscriptions that should be paid by it. Click OK. 

Á To remove a billing account, click the corresponding Remove link. 

 

In this section: 
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Calculating Usage Charges 

If the pay-as-you-go web hosting is allowed for a plan, Business Manager calculates usage 
charges - total costs of hosting resources overage - for the plan's subscribers basing on 
resource usage statistics that Business Manager collects from the connected Panels on a 
daily basis. No matter what billing mode and billing cycles you use, this happen on the first 
day of each month: The system finds the average daily overage of each resource except 
traffic and multiplies it by the month length and the monthly usage price of this resource. 

Traffic  

The traffic usage charge is calculated in the following way: Business Manager counts the 
total traffic overage for a month and multiplies it by the monthly traffic usage price. Say, if 
subscribers download 10 GB of files during a month while the plan limit is 5 GB, then the 
traffic overage is 5 GB. Assuming that the traffic usage price is $1 for a 1 GB, such 
subscribers will pay (10 GB - 5 GB) * $1 = $5 traffic usage fee. 

Other Resou rces  

For calculation usage charges for other resources, Business Manager uses the average daily 
usage values. For example, if a customer uses 500 MB of disk space over the subscription 
quota for 15 days and then uses extra 700 MB for other 15 days, the average overage will be 
(500 * 15 + 700 * 15)/30 = 600 MB. If the disk space usage price is $1 for 1 GB, then the 
customer will pay $0.6 for disk space overage this month. 

Calculating Usage with Add -ons  

If a customer purchases additional resources in the middle of a month, then the system 
subtracts the resource amount provided by the add-on from the daily resource usage of each 
day starting from the add-on purchasing day. 

For example, if a customer uses 500 MB of disk space over the plan limit for a whole month 
and purchases the add-on that provides an additional 1 GB of disk space on the 7th day of 
the month, then the usage charge will include the payment for only 7 days of 500 MB of disk 
space overage. 

Earning Credits for Promoting Provider's Plans 

Panel lets you earn money for promoting your provider's service plans. Particularly, you can 
get a certain commission for each order placed in the provider's online stores by people who 
signed up using your referral link.  

Participants of affiliate programs (affiliates) distribute links to their provider's online stores. 
Each link is unique, so the system defines who brought a new customer and adds the 
commission to the link owner's affiliate balance. This commission is defined by the terms of 
the affiliate program and may vary depending on an online store. Affiliates can use money 
they earn only after the provider pays these money to their account credit balance. Normally, 
the provider pays out affiliates' commissions when they exceed the affiliate program's 
payment threshold. However, affiliates can ask the provider to pay out their commission 
before their balances exceed the threshold or, alternatively, delay payments and generate 
more credits. 



 

50 Customer Account Administration 

 

Becoming an Affiliate  

To start earning money, click the link Become an Affiliate on the Account tab. Once became an 
affiliate, you will get the access to the list of the provider's affiliate programs and your affiliate 
links. To see the programs list and your links, click the Affiliate Programs list on the Account 
tab. 

Trackin g Your Earnings  

To see your current affiliate balance, go to the Account tab and find the balance in the Affiliate 
Programs group. If you want to see detailed information about your earnings, click the link 
Revenue from Referrals. 

Example  

For example, your provider offers you an affiliate program with 10% commission rate and 
$20 payment threshold. You share your affiliate link with your friends, and three of them 
subscribe to a web hosting plan which costs $50. The total commission that you get to your 
affiliate balance is $50 * 3 * 10% = $15. This amount is less than the program's payment 
threshold, so to receive credits, you should bring more customers to the online store with 
your link. When you do this and your balance exceeds the payment threshold which is $20, 
the provider will add this balance to your credits. When you receive them, you can use them 
to pay for your subscriptions or subscribe to new services in the provider's online stores. 

Participating in Multiple Programs  

Your hosting provider may have multiple online stores with different currencies. If the 
provider offers affiliate programs for stores with different currencies, you will receive separate 
commissions in the corresponding currencies. For example, if you distribute links to stores 
with USD and EUR currencies, your affiliate balance contains two separate affiliate balances, 
one for each currency. Your provider pays out the commissions separately as well. For 
example, your affiliate balance is USD 50 and EUR 40 and the payment thresholds of the 
corresponding programs are USD 40 and EUR 45, your provider will pay out USD 50 to your 
credits and your affiliate balances will be USD 0 and EUR 40.  

Ordering More Resources 

The operations described below are available if your Control Panel is integrated with a billing 
system. 

ü To add more resources to your subscription or upgrade to another service 
plan: 

1. Click the Account tab. 

2. In the list of subscriptions, locate the subscription that you want to upgrade 
to another service plan, and click a link with the currently used plan's name. 

3. Click Upgrade. 
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If there is no Upgrade link, then it means that you cannot upgrade to another hosting plan 
from your Control Panel, and you need to contact your provider. 

4. Do any of the following: 

Á To add resources to your subscription without upgrading to another plan, select the 
options you would like to add and click Adjust Add-ons. 

Á To upgrade to another service plan, click Order Upgrade. 

ü To reduce the amounts of resources or downgrade to another service plan: 

1. Click the Account tab. 

2. In the list of subscriptions, locate the subscription that you want to 
downgrade to another service plan, and click a link with the currently used 
plan's name. 

3. Click Downgrade. 

If there is no Downgrade link, then it means that you cannot downgrade to another hosting 
plan from your Control Panel, and you need to contact your provider. 

4. Do any of the following: 

Á To reduce the amounts of allocated resources without downgrading to another plan, 
select the options you would like to reduce and click Adjust Add-ons. 

Á To downgrade to another service plan, click Order Downgrade. 

ü To subscribe to a hosting plan in addition to your main plan: 

1. Go to the Account tab and click the Add Subscription link. 

2. Select the hosting plan to which you want to subscribe, and click Buy Now. 
Follow the instructions on the screen to complete the order. 
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Viewing Statistics 

ü To view the reports on disk space and traffic usage by your account: 

1. If you have several subscriptions associated with your account, in the 
Subscription menu at the top of the screen, select the required subscription.     

2. Click the Statistics tab. 

The following information is presented in charts: 

Á Disk space used by websites, mail accounts, databases, and other files located in 
your webspace. 

Á Traffic used by FTP, web, and mail services during the current month. 

FTP field shows the information about the total size of files transferred to and from the 
webspace over the file transfer protocol. 

HTTP field shows the information about the total amount of data transferred from all of 
your websites over HTTP protocol, that is, retrieved by web browsers. 

POP3/IMAP field shows the total amount of data received by all mail accounts under 
your domains. 

SMTP field shows the total amount of data sent by all mail accounts under your 
domains. 

3. Do any of the following: 

Á To view a report on the amount of data transferred to and from your sites over FTP, 
click FTP Statistics. 

Á To view a report on the amount of data transferred to and from your FTP directory, 
which is accessed without authorization, click Anonymous FTP statistics. 

Á To view a report on the amount of traffic used by services during a certain month, click 
Data Transfer Statistics, and select the required month from the menu. 

 

In this section: 

Log Files ........................................................................................................... 53 
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Log Files 

All connections to the web server and requests for files that were not found on the server are 
registered in log files. These log files are analyzed by the statistics programs running on the 
server, which then present graphical reports on demand. You may want to download these 
log files to your computer for processing by third-party statistics programs, or view their 
contents for web server debugging purposes. 

ü To prevent these log files from growing too large, you should enable automatic 
cleanup and recycling of log files: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Logs (in the Advanced Operations group) > Log 
Rotation. 

3. Click Switch On. If you see only the Switch Off button there, this means that log 
recycling is already switched on. 

4. Specify when to recycle log files and how many copies of each log file to 
store on the server. Also specify whether they should be compressed and 
sent to an e-mail address after processing. 

5. Click OK. 

ü To view the contents of a log file or download it to your computer: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Logs (in the Advanced Operations group). A list 
of log files opens. 

3. Do any of the following: 

Á To view all entries in a log file, click the log file name. If you want to view only a few 
last lines from the log file, type the number of lines into the input box under the Settings 
group, and then click the log file name. 

Á To download a file to your computer, click the corresponding icon .  

Á To remove a processed log file from the server, select the corresponding checkbox 
and click Remove. Confirm removal and click OK. 
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ü To download log files to your computer via FTP: 

1. Connect to the Panel server via FTP and log in using access credentials of 
the subscription logs of which you want to download. 

2. Go to the /statistics/logs  directory and copy the log files to you 

computer. 
 

(Advanced) Managing Auxiliary User 
Accounts 

If you want to allow other users to access the Panel for managing websites and installed 
applications, or to use e-mail services under your domains, then you need to create user 
accounts for them. 

Auxilia ry Users and User Roles  

Auxiliary user accounts are created based on user roles. The roles include privileges to 
access certain areas of the Panel and perform operations in the Panel. There are several 
predefined user roles, namely: Accountant, Application User, Owner, and Webmaster. You 
can review and modify the Accountant, Application User, and Webmaster roles to suit your 
needs, or you can create your own custom roles. For more information on user roles and 
user account creation, refer to the sections User Roles (on page 55) and Auxiliary User Accounts 
(on page 57) correspondingly. 

After auxiliary user accounts are created, the users will be able to log in to their accounts in 
Panel and use shortcuts in their Panels to access their mailboxes and work with applications. 
In addition, you can extend the list of links available to your auxiliary users with your custom 
links. These can be links to corporate resources, sites on the web, and so on. Learn more in 
Custom Links (on page 59).  

Auxiliary Users and Multiple Subscriptions  

Since Panel 10.4, if your customer account includes more than one subscription, you can 
allow auxiliary users to access only a specified subscription. If the Access to subscriptions 
property of a user account is set to a certain subscription, the user will always log in to this 
subscription and will not be able to switch to other subscriptions. 

In this section: 

User Roles ........................................................................................................ 55 
Auxiliary User Accounts ..................................................................................... 57 
Custom Links .................................................................................................... 59 
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User Roles 

ü To create a user role: 

1. Go to the Users tab > User Roles tab > Create User Role. 

2. Specify the following: 

Á User role name. 

Á Access to Panel services. Grant the required permissions for operations to the user: 

Á Manage users and roles. Add, modify, and remove user accounts and roles. Note that 
even if this permission is not granted to a user, the user will be able to browse 
contact information of other users after logging in to the Panel. 

Á Create and manage sites. Set up, modify, remove domain names and subdomains, 
host websites and change web hosting settings. 

Á Configure log rotation. Manage settings for recycling of web server access and error 
log files. View, download, and remove log files. 

Á Configure anonymous FTP service. Set up a directory accessible to all Internet users 
over FTP without authorization. 

Á Create and manage scheduled tasks. Schedule execution of scripts or programs on 
your customer account. 

Á Configure spam filter. Set up spam protection for mailboxes. 

Á Configure antivirus. Set up virus protection for mailboxes. 

Á Create and manage databases. Add, modify, and remove databases stored on your 
customer account. 

Á Configure and perform data backup and restoration. Back up and restore data related to 
your customer account, websites, and mailboxes under your domains. 

Á View statistics. View reports on disk space and traffic usage by your websites, and 
website visits. 

Á Install and manage applications. Install applications on websites and manage them. 

Á Design sites in Web Presence Builder. Create websites using Web Presence Builder. 

Á Upload and manage files. Manage files and directories located in the webspace by 
using the Panel's file manager. 

Á Create and manage additional FTP accounts. Set up additional FTP accounts for other 
users. 

Á Manage DNS settings. Manage DNS settings for domains. 

Á Install and manage Java applications. Install on websites third-party Java applications.  

Á Create and manage mail accounts. Create, modify, and remove e-mail accounts. 

Á Create and manage mailing lists. Create, modify, and remove mailing lists. 

Á Access to apps. Select the applications that the user should be able to access and use. 
All web applications installed on the server are listed in this area. 
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For more information about installing applications and providing access to users, refer 
to the section Granting Auxiliary Users Access to Apps (on page 100). 

3. Click OK. 

ü To modify user role properties: 

1. Go to the Users tab > User Roles tab. 

2. Click a link with the role name that you want to change. 

3. Change the role properties as required and click OK.  

ü To remove a user role: 

1. Go to the Users tab > User Roles tab. 

2. Select a checkbox corresponding to the role you want to remove and click 
Remove. Note that it is impossible to remove the Owner role and other roles 
that are assigned to one or more users. 

3. Click Yes to confirm the removal. 
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Auxiliary User Accounts 

ü To create a user account: 

1. Go to the Users tab > Create User Account. 

2. Specify the following: 

Á Contact name. 

Á E-mail address. The e-mail address will be used as a username for logging in to the 
Panel. 

Á To create a new e-mail address for the user, select the option Create an e-mail 
address under your account,    

type the desired left part of the address which goes before the @ sign, and, if you 
have a number of domains on your account,  select the domain name under which 
the e-mail address should be created. 

Á To associate with this user account an external e-mail address, select the option 
Use an external e-mail address, and specify an existing external e-mail address. 

Á User role. Select the required user role from the menu. 

Á Access to subscriptions. Allow a user to access only a specified subscription. The All 
value grants them access to all subscriptions within your customer account. 

Á Password. Type the password for access to the Panel. 

3. Leave the User is active checkbox selected. Otherwise, the user will not be 
able to access the Panel and use applications on your customer account. 

4. Click OK. 

5. Now, if you want to add contact information for the user, click a link with the 
user's name, and then click the Contact Details tab, and specify the user's 
contact information. 

6. Click OK. 

Now you can notify the user about creation of his or her account and ability to access the 
Panel. Provide the user with the address to open in his or her browser, the username (which 
is the user's e-mail address), and the password that you specified in the account settings. 

ü To change user account properties: 

1. Click the Users tab. 

2. Click a link with the user's name. 

3. Make the required changes and click OK. 
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ü To suspend or activate a user account: 

1. Click the Users tab. 

2. Click a link with the user's name. 

3. Do any of the following: 

Á To suspend a user account, clear the User is active checkbox. The user will no longer 
be able to log in to the Panel and access applications. 

Á To activate a user account, select the User is active checkbox. 

4. Click OK. 

ü To remove a user account: 

1. Click the Users tab. 

2. Select a checkbox corresponding to the user account you want to remove, 
and click Remove. Note that you cannot remove your own account. 

3. Click Yes to confirm the removal. 
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Custom Links 

You can add custom hyperlinks to the Panel and make them visible for your users. The links 
may lead to web resources, such as your corporate site, or to a web application that can 
process online requests and accept additional information about the users who click these 
links. 

You can specify what information about users should be passed: 

Á Subscription ID. 

Á Primary domain name associated with a subscription. 

Á FTP account username and password. 

Á Customer's account ID, name, e-mail, and company name. 

You can place the links in the following locations of the Control Panel, and decide who 
should be able to see them: 

Á On the Home page in the Control Panel, visible only to you. This is achieved by selecting 
the Customer's Home page option in the link properties. 

Á On the Home page in the Control Panel, visible to you and your users who are allowed to 
log in to the Control Panel. This is achieved by selecting the Common access option in the 
link properties. 

Á On the Websites & Domains tab in the Control Panel, visible to you and your users who are 
allowed to log in to the Control Panel. This is achieved by selecting the Websites & Domains 
page of Subscription option in the link properties. 

ü To add a custom hyperlink to the Control Panel: 

1. Go to the Account tab > Additional Services, and click Add Link to Service. 

2. Specify the following settings: 

Á Type the text that will show on your button in the Button label box. 

Á Choose the location for your button. 

Á Specify the priority of the button. Your custom buttons will be arranged in the Panel in 
accordance with the priority you define: the lower the number, the higher the priority. 
Buttons are placed in the left-to-right order. 

Á To use an image for a button background, type the path to its location or click Browse 
to browse for the desired file. It is recommended that you use a 16x16 pixels GIF or 
JPEG image for a button to be placed in the navigation pane, and 32x32 pixels GIF or 
JPEG image for buttons placed in the main frame or desktop. 

Á Type the hyperlink of your choice to be attached to the button into the URL box. 

Á Using the checkboxes, specify whether you want the customer information and other 
data to be transferred within the URL. These data can be used for processing by 
external web applications. 

Á In the Tooltip text input field, type in the help tip that will be displayed when the users 
place the mouse pointer over the button. 
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Á Select the Open URL in Parallels Panel checkbox if you want the destination URL to be 
opened in the main frame of the Panel, otherwise, leave this checkbox cleared to 
open the URL in a separate browser window or tab. 

Á If you want to make this button visible only to you, select the Show to me only checkbox. 

3. Click Finish to complete creation. 

ü To remove a hyperlink button from the Panel: 

1. Go to the Account tab > Additional Services. 

2. Select a checkbox corresponding to the link that you want to remove and 
click Remove. 

 

 



 

  
 

As described in the chapter Quick Start with Parallels Panel (on page 10), creating your 
web presence always starts with purchasing a domain name. The domain name (or 
simply, domain) is the name people use to access your site from their browsers, for 

example, www.example.com . The domain registration is carried out by authorized 

companies - domain name registrars. Hosting providers often carry out this function. 
For detailed information about how to manage domains in Panel, refer to the section 
Domains and DNS (on page 62). 

However, a domain is not a website. To make it accessible from the web and fill it with 
content, you should subscribe to hosting services (obtain a customer account). That is 
to supplement your domain with Internet connectivity, some disk space to store your 
content, mail services, and so on. Thus, a website is a domain with provided hosting 
services.  

Panel provides a full range of operations in regard to domains and websites: 

Á Adding and removing domains, subdomains, and aliases. 

Á Managing the content of your websites. 

Á Installing various web apps. 

Á Securing connections to your websites and much more. 

This chapter provides detailed information on all the possible operations on websites 
and domains in Panel. Note that some of these operations may be unavailable 
according to your hosting plan. 

In this chapter: 

Domains and DNS............................................................................................. 62 
Changing Hosting Settings ................................................................................ 80 
Suspending and Activating Websites ................................................................ 88 
Managing Website Content ............................................................................... 90 
(Advanced) Restricting Access to Content ........................................................ 95 
Previewing Websites ......................................................................................... 97 
Using Website Applications ............................................................................... 98 
(Advanced) Securing Your Websites ................................................................. 105 
(Advanced) Extended Website Management..................................................... 112 
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Domains and DNS 

As described above, a domain name is the name that people type in their browsers to 
access your website.  

A domain name is hierarchical and may consist of a number of parts called labels: 

Á The label furthest to the right is called the top-level domain. For example, com is 

the top-level domain of www.example.com . The number of top-level domains is 

limited and all of them are managed by separate international authorities. 

Á The second-level domain is the label that we mainly use to imply the purpose of our 

website. In www.example.com  it is the example part. The combination of the 

second-level and top-level domain names specifies the exact location of your 
website. 

Á Each label to the left is a subdomain of the domain to the right. For example, www 

is the subdomain of example.com . Subdomains can be convenient when you want 

to isolate some content from the main site, e.g. you can organize your personal 

blog on myblog.example.com . For information on how to add subdomains in 

Panel, refer to the section Adding Subdomains (on page 65). 

If you want to host more than one website under your subscription, you can register 
more domains and add them to your subscription. Registering new domains may be 
available to you in the Control Panel if your hosting provider allows this. For information 
on how to purchase and add domains in Panel, refer to the section Adding Domains (on 
page 63). 

In fact, domain names exist only for convenience; the real communication between 
browser and web servers uses IP addresses - the numerical host identifiers. For 

example, the real address of www.example.com  may be 192.0.2.12 (IPv4). To resolve 

domain names into IP addresses, web hosts use DNS technology. For more details 
about how DNS is implemented in Panel, refer to the section (Advanced) Configuring DNS 
for a Domain (on page 70).   

DNS allows several domains to be resolved into one IP address. Such additional 
names are called domain aliases. This is convenient when you have purchased several 
domains that you want to point to the same website. For information on how to add 
aliases to existing domains, refer to the section Adding Domain Aliases (on page 67).  

In this section: 

Adding Domains ................................................................................................ 63 
Adding Subdomains .......................................................................................... 65 
Adding Domain Aliases ..................................................................................... 67 
Adding Wildcard Subdomains (Linux) ................................................................ 69 
(Advanced) Configuring DNS for a Domain ....................................................... 70 
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Adding Domains 

If your hosting package includes more than one domain name (website), then you can 
easily add new domains to the server. Before you start adding a new domain that will 
use a second-level domain name, like example.com, be sure to register this domain 
name. If your hosting provider provides the domain name registration service, you can 
do this from the Control Panel as described below. Otherwise, you should register your 
domain name with another domain name registration authority. 

You can set up the following types of site configurations through Panel: 

Á Website addressed by a second-level domain name. The following services are available 
for websites: 

Á A unique Internet address (domain name), like example.com. 

Á Additional domain names (domain aliases). 

Á Subdomains - divisions of a site accessible by easy-to-remember addresses 
that are added to the main site, like mail.example.com. 

Á Separate FTP accounts for collaboration on the site content. For every FTP 
account, you can specify which directories can be accessed. 

Á Creating content using Web Presence Builder. 

Á Simplified deployment of applications, such as content management systems, 
photo galleries, shopping carts, blogging platforms, and many more.  

Á Secure data exchange implemented by SSL protocol. This requires that a site 
be hosted on a dedicated IP address, which is not shared among other users 
and sites. 

Á Mailboxes and mailing lists. 

Á Viewing statistics on site visits. 

Á Website or a division of a website addressed by a third-level domain name (subdomain). This 
is usually a division of an existing site. It has an Internet address comprising of 
three parts separated by dots. The following services are available for subdomains: 

Á Separate document root from the main site. Document root is a directory on the 
server where web pages of a site are stored. 

Á Access over FTP for content management. 

Á Creating content using Web Presence Builder. 

Á Simplified deployment of applications. 

Á Secure data exchange implemented by SSL protocol.  

Á Viewing statistics on site visits. 

ü  Adding More Domains 
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ü To host a new website with a second-level domain name: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab, click Add New Domain and follow on-
screen instructions. 

Note : If you select the recommended option, you should connect the DNS settings 
related and your domain name with the domain name at the registrar's side. To 
achieve this, enter the Panel name server IP address into the respective NS record 
of the registrar. The instruction on how to obtain the IP is as follows: go to Websites 
& Domains > DNS Settings, find the NS record, and then find the A record 
corresponding to the NS record value. 
For example, if your NS record is 
example.com. NS ns.example.com, 
find the A record with ns.example.com, say,  
ns.example.com. A 192.0.2.12 

The resulting value, 192.0.2.12, is the Panel name server IP you need. 

3. Click OK. 

The new domain name is now shown in the list at the bottom of the screen. 

4. If the operation of changing hosting settings is available for your 
account, then you can click the domain name of the new website to 
view or change the hosting settings, as described in the section 
Changing Hosting Settings (on page 80). 

You can now start creating your website with Web Presence Builder or upload your 
web content to the webspace of the new website, as described in the section Managing 
Website Content (on page 90). 

ü Registering Domains 

If your service provider offers the domain name registration service as well as web 
hosting, you can initiate a domain registration directly from Panel. To register a domain 
name, add it as described above and then click the link register it now beside the new 
domain name in the domains list on the Websites & Domains tab. This will redirect you to 
the provider's online store where you can complete the registration. 

After you register a domain name, it appears in the Registered domain names list on the 
Websites & Domains tab. To get information about a domain name registration, for 
example, the registration price and next renewal date, click the domain name in this 
list. 
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Removing Domains  

When you delete a domain from Panel, all data related to the corresponding site are 
deleted from the server. The first domain name (default domain) that was created for 
your account cannot be deleted; however, it can be renamed.  

ü To remove a domain: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. In the list of domain names, select the domains or subdomains that you 
want to remove and click Remove. 

4. Confirm removal and click OK. 

Note: Removing domain names from the Control Panel does not cancel the registration 
of these names. If you registered these domains name, you still can use them for your 
websites. 

Adding Subdomains 

If your hosting package includes subdomains, which are additional third-level domain 
names, then you can use them to: 

Á Organize logically the structure of your site. 

Á Host additional websites or parts of a website on the same server without the need 
to pay for registration of additional domain names. 

An example of using subdomains: 

You have a website your-product.com dedicated to promoting and selling your product. 
For publishing information related to customer service and online order tracking, you 
can organize the subdomain "orders" so that your users will be able to access this 
information directly by visiting the Internet address "orders.your-product.com".  

As subdomains have the same status with the additional domains, you can use the 
same set of tools and services for working with subdomains. For example, SSL 
protection, Web Presence Builder, web statistics, and so on. 

ü To set up a subdomain for a site division or a separate site: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. Click Add New Subdomain. 
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4. Specify the following: 

a. In the Subdomain name box, type the portion of address that will 
be added to the domain name of your main site. 

b. In the Document root box, type the desired location of the 
directory where all files and subdirectories of this site will be 
kept. You can use the default directory of the main site, called 
httpdocs, or specify another directory. 

5. Click OK. 

The new subdomain name is now shown in the list at the bottom of the screen. 

You can now upload your web content to the subdomains webspace (directory on the 
server), as described in the section Uploading Content over FTP. 

Wildcard Subdomains  

If you enter the asterisk (*) symbol as a subdomain name, Panel will create a so-called 
wildcard subdomain.When site visitors enter any subdomain name that is not 
registered in Panel, they will be redirected to this wildcard subdomain. You can create 
wildcard subdomains on any domain name level. For example, you can create the 
*.mystore.example.com subdomain. Learn more about wildcard subdomains in the 
section Adding Wildcard Subdomains (Linux) (on page 69). 
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Adding Domain Aliases 

If you have registered with a domain name registrar several domain names that you 
would like to point to the same website that you host on this server, you should set up 
domain aliases. 

ü To set up a domain alias: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription 
menu at the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab. 

3. Click Add New Domain Alias above the list of domain names. 

4. Type the desired domain alias name, for example alias.com.  

Domain aliases can comprise letters, digits and hyphens. Each part of the domain 
alias between dots should not be longer than 63 symbols. 

5. Select the Synchronize DNS zone with the primary domain checkbox if you want 
the domain alias to use the same DNS zone resource records as in 
primary domain. With this setting, any subsequent changes in resource 
records of the primary domain's zone will be applied to the DNS zone of 
this domain alias.    

6. Select the Mail service checkbox, if you want e-mail directed at the e-mail 
addresses under the domain alias to be redirected to the e-mail 
addresses under your original domain name. 

Example: You have an e-mail address mail@yourdomain.com. You have set up an 
alias for your domain name, for example, alias.com. If you want to receive mail to 
your mailbox mail@yourdomain.com when it is sent to mail@alias.com, select the 
Mail service checkbox. 

7. Select the Web service checkbox. Otherwise, the web server will not 
serve the web content to users coming to your site by typing the domain 
alias in their browsers. 

8. If you use hosting services based on a Linux platform, and you have 
Java applications installed on your site that you want to make 
accessible through the domain alias, select the Java web applications 

checkbox. 

9. Click OK. 

ü To change the properties of an alias: 

1. Go to the Websites & Domains tab. 

2. In the list of domain names, click the alias name you need. 
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3. Click Settings in the Tools group. 

4. Modify the domain alias properties as required and click OK. 

ü To modify resource records in the DNS zone of a domain alias: 

1. Go to the Websites & Domains tab. 

2. In the list of domain names, click the alias name you need. 

3. Click DNS. 

4. Add, edit or remove the resource records as required: 

Á To add a resource record to the zone, click Add New Record. Specify the required 
values and click OK to write the values to the zone. 

Á To modify a resource record, under the Host column, click a hyperlink 
corresponding to the record you need. 

Á To remove a record, select a checkbox corresponding to the record you wish to 
remove and click Remove. 

ü To remove an alias from a domain: 

1. Go to the Websites & Domains tab. 

2. Select a checkbox corresponding to the domain alias that you want to 
remove. 

3. Click Remove. 

4. Confirm removal and click OK. 
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Adding Wildcard Subdomains (Linux) 

Use wildcard subdomains to redirect visitors from non-existent subdomains to one of 
your websites, commonly, to your main website. The typical use cases of this feature 
are: 

Á Improve website organization and run marketing campaigns. 

For example, you do not have the vps-limited-offer subdomain but wish to forward 
users from limited-vps-offer.example.com to example.com. 

Á Help users reach your website even if they mistyped a subdomain name. 

It is a widespread mistake to mistype a website name if it has the leading www 
prefix (for example, typing ww.example.com). 

Á Finally, some website applications (WordPress) use wildcard subdomains to create 
dynamic subdomains for convenience and better user experience. 

Note : Traffic to existent subdomains will not be affected in any way if you add a 
wildcard subdomain. 

How to Add Wildcard Subdomains  

You can add one wildcard subdomain per each of domain names under a subscription. 
For this, go to the Websites & Domains tab and add a new subdomain which name is "*" 
to one of your domain names. Example: *.example.com. If you wish this subdomain to 
have a custom set of scripts or website content, specify a custom document root for 
this subdomain. 

Limitations of Wildcard Subdomains  

Wildcard subdomains act like typical subdomains with the following exceptions: 

Á Linux-only feature. Currently, wildcard subdomains are supported only on Panel for 
Linux. 

Á Renaming is not available. It is not possible to rename such subdomains. 

Á No DNS zone. This type of subdomains does not have own zone record in the 
Panel's DNS server. Instead, they have the A record that points to the IP address 
associated with a corresponding domain name. 

Á Installation of APS apps is not allowed. Panel users are unable to install APS apps 
to wildcard subdomains. 

Á No Web Presence Builder sites. Panel users are unable to edit and publish sites to 
these subdomains. 
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(Advanced) Configuring DNS for a Domain 

The Domain Name System (DNS) is a hierarchical naming system that translates 
understandable domain names into the numerical identifiers (IP addresses) associated 
with web hosts. Such translation is called resolving. When you add a domain name 
(using Websites & Domains > Add New Domain), you should choose the role of Panel in 
resolving your resources: It can directly process all translation requests, be a backup 
server, or pass the translation requests to a remote server. This role can be changed 
for existing domain names (Websites & Domains > click a domain name> DNS Settings). 
We discuss details about each of the roles and provide instructions how to assign them 
next in this section. 

DNS Name Resolving  

DNS is based on a hierarchical tree structure called the domain namespace. This 
global namespace contains all possible domain names and is divided into logical parts 
- domain zones (see the picture below). A domain zone is a part of the namespace that 
contains the addresses of particular domains. Addresses are stored in a file on a 
separate name server with authority for that zone. For example, when a browser tries 

to access www.example.com , it gets the site's IP address from a server with authority 

for the example.com  zone. For more information about how DNS works, refer to the 

respective documentation. You can find it in numerous sources on the Internet, for 
example, Microsoft TechNet. 
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When you purchase a domain, a registrar gives you access to the settings for the DNS 
zone responsible for your domain and its subdomains. You can either allow the 
registrar to manage the zone, or delegate the zone to Panel. The latter option gives 
you the ability to manage a zone directly from your customer account. For information 
about how to delegate your zone to the Panel, refer to the section Panel as a Master DNS 
Server (on page 72). 

If you are an advanced user and already have a DNS server that you want to give 
authority for your zone, you can set up Panel to be a slave (also called secondary) 
DNS server. In this case, Panel just stores a copy of your zone and you do not have 
the option to manage it from the Control Panel. The Panel DNS server will be used only 
if your primary name server becomes inaccessible or inoperable. For information about 
how to make Panel act as a secondary DNS server, refer to the section Panel as a Slave 
DNS Server (on page 77). 

If you decide not to use Panel as a DNS server, all zone management should be 
performed on a domain registrar's site. Some registrars provide support for remote 
DNS zone management. If your hosting provider uses this feature, you will still be able 
to modify the DNS zone from the Control Panel regardless of where your authoritative 
name server is located. For information about how to switch off the Panel's DNS server 
and manage your zone remotely, refer to the section Registrar's DNS Settings in Panel (on 
page 77). 

In this section: 

Panel as a Master DNS Server.......................................................................... 72 
Panel as a Slave DNS Server ........................................................................... 77 
Registrar's DNS Settings in Panel ..................................................................... 77 
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Panel as a Master DNS Server 

For each new domain name, the Panel automatically creates a DNS zone in 
accordance with the settings configured by your service provider. The domain names 
should work fine with the automatic configuration, however, if you need to perform 
custom modifications in the domain name zone, you can do that through your Panel. 

ü To view the resource records in a DNS zone of a domain: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to view. 

A screen will show all resource records for a given domain. 

ü To add a new resource record to the zone: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click Add Record. 

4. Select a resource record type, and specify the appropriate data: 

Á For an NS record, which specifies the domain name of a name server that is 
responsible for a DNS zone of a domain, you need to specify the domain name 
(or a subdomain), and then the corresponding name server's domain name. If 
you are defining an NS record for your main domain, then you should leave the 
domain name field empty. If you are defining a name server for a subdomain, 
then type the subdomain into the domain name field. After that, type the 
appropriate name server's domain name into the name server field. For example: 
ns1.mynameserver.com. 

Á For A and AAAA records, which associate IP addresses with domain names, 
you need to specify the domain name and IP address. If you are simply defining 
a record for your main domain, then you should leave the domain name field 
empty. If you are defining a record for a name server, then type ns1 or ns2 into 
the domain name field. Then specify the appropriate IP address with which to 
associate the domain name. 

Á For a CNAME record, which specifies which subdomains (or domain aliases that 
look like subdomains, for example, www) should be associated in the Domain 
Name System with the main domain address, you need to type the subdomain 
name or www alias, and then, the main domain name. 
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Á For an MX record, which specifies the host name of the preferred mail server for 
the given domain, you need to specify the mail domain (or subdomain), the 
domain name of the mail exchange server responsible for receiving e-mail, and 
the server's priority. For the main domain, you would simply leave the available 
field blank. Then type the domain name of your mail server. If you are running a 
remote mail server named 'mail.myhostname.com', then simply type 
'mail.myhostname.com' into the Mail exchange server field. After that, specify its 
priority: 0 is the highest and 50 is the lowest. 

Á For a PTR record, which is required for reverse DNS lookup (an IP address is 
translated to domain name), you need to enter the IP address/mask, and then 
type the appropriate domain name for this IP address to be translated to. 

Á For a TXT record, which is used for specifying arbitrary human-readable text, 
you can type an arbitrary text string, or an SPF record. 

Á For an SRV record, which is used for specifying location of services other than 
mail, you will need to enter the service name, protocol name, port number, and 
target host. You can also specify the priority of the target host, and relative 
weight (for records with the same priority) in the appropriate fields.  

   4. Click OK, and then click Update. 

ü To modify the properties of a resource record: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click the hyperlink in the Host column corresponding to the resource 
record you want to modify. 

4. Modify the record as required, click OK, and then click Update. 

In addition to the resource records described above, there is also a Start of Authority 
record. This record indicates that this DNS name server is responsible for the domain's 
DNS zone. It also contains settings that affect propagation of information about the 
DNS zone in the Domain Name System. 

ü To modify the entries in the Start of Authority (SOA) record for a domain: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click SOA Record. 
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4. Specify the required values: 

Á Refresh interval. This is how often the secondary name servers check with the 
master name server to see if any changes have been made to the domain's 
zone file. The Panel sets the default value of three hours. 

Á Retry interval. This is the time a secondary server waits before retrying a failed 
zone transfer. This time is typically less than the refresh interval. The Panel sets 
the default value of one hour. 

Á Expire interval. This is the time before a secondary server stops responding to 
queries, after a lapsed refresh interval where the zone was not refreshed or 
updated. The Panel sets the default value of one week. 

Á Minimum TTL. This is the time a secondary server should cache a negative 
response. The Panel sets the default value of three hours. 

Á Default TTL. This is the amount of time that other DNS servers should store the 
record in a cache. The Panel sets the default value of one day. 

5. Click OK, and then click Update. 

Usage of serial number format recommended by IETF and RIPE is mandatory for many 
domains registered in some high-level DNS zones, mostly European ones. If your 
domain is registered in one of these zones and your registrar refuses your SOA serial 
number, using serial number format recommended by IETF and RIPE should resolve 
this issue. 

The Panel-managed servers use UNIX timestamp syntax for configuring DNS zones. 
UNIX timestamp is the number of seconds since January 1, 1970 (Unix Epoch). The 
32-bit timestamp will overflow by July 8, 2038. 

RIPE recommends using YYYYMMDDNN format, where YYYY is year (four digits), MM 
is month (two digits), DD is day of month (two digits) and NN is version per day (two 
digits). The YYYYMMDDNN format will not overflow until the year 4294. 

ü To change the Start of Authority (SOA) serial number format to 
YYYYMMDDNN for a domain: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click SOA Record. 

4. Select the Use serial number format recommended by IETF and RIPE checkbox. 

Note:  See the sample of SOA serial number generated with the selected format. If 
the resulting number is less than the current zone number, the modification may 
cause temporary malfunction of DNS for this domain. Zone updates may be 
invisible to the Internet users for some time. 

5. Click OK, and then click Update.  
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ü To remove a resource record from the zone: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Select a checkbox corresponding to the record you want to remove. 

4. Click Remove. 

5. Confirm removal, click OK, and then click Update. 

ü To restore the original zone configuration in accordance with the default 
DNS template settings used on the server: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click Restore Defaults. 

4. In the IP address menu, select the IP address to be used for restoring the 
zone. 

5. Specify whether a www alias is required for the domain. 

6. Select the Confirm the restoration of the DNS zone checkbox, and click OK. 

ü To restore the default Start of Authority (SOA) serial number format (UNIX 
timestamp) for a domain: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click SOA Record. 

4. Clear the Use serial number format recommended by IETF and RIPE 
checkbox. 

Note:  See the sample of SOA serial number generated with the selected format. If 
the resulting number is less than the current zone number, the modification may 
cause temporary malfunction of DNS for this domain. Zone updates may be 
invisible to the Internet users for some time. 

5. Click OK, and then click Update. 

By default, transfer of DNS zones is allowed only for the name servers designated by 
NS records contained within each zone. If you are using a Windows-based account, 
then you can change zone transfer settings. 
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ü If your domain name registrar requires that you allow transfer for all zones 
you serve: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click Zone Transfers. A screen will show all hosts to which DNS zone 
transfers for all zones are allowed. 

4. Specify the registrar's IP or network address and click Add Network. 
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Panel as a Slave DNS Server 

If you host websites on your account and have a standalone DNS server acting as a 
primary (master) name server for your sites, you may want to set up the Panel's DNS 
server to function as a secondary (slave) name server. 

ü To make the Panel's DNS server act as a secondary name server: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click Switch DNS Service Mode. 

4. Click Add Record. 

5. Specify the IP address of the primary (master) DNS server.  

6. Click OK, and then click Update. 

7. Repeat steps from 2 to 6 for each website that needs to have a 
secondary name server on your server. 

ü To make the Panel's DNS server act as a primary back: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click Switch DNS Service Mode. 

The original resource records for the zone will be restored. 

Registrar's DNS Settings in Panel 

If you have external primary and secondary name servers that are authoritative for 
some of your websites, switch off the Panel's DNS service for each of these sites. 

ü To switch off the Panel's DNS service for a site served by external name 
servers: 

1. Go to the Websites & Domains tab > DNS Settings. 

2. If you have several domain names, select the domain name whose DNS 
settings you want to manage. 

3. Click Switch Off the DNS Service. 
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Turning the DNS service off for the zone will refresh the screen, so that only a list of 
name servers remains. Note that the listed name server records have no effect on 
the system. They are only presented on the screen as clickable links to give you a 
chance to validate the configuration of the zone maintained on the external 
authoritative name servers. 

4. If you want to validate the configuration of a zone maintained on 
authoritative name servers, do the following: 

a. Add to the list the entries pointing to the appropriate name 
servers that are authoritative for the zone: Click Add Record,  
specify a name server, click OK, and then click Update. 

b. Repeat the step a for each name server you would like to test. 
The records will appear in the list. 

c. Click the records that you have just created. 

The Panel will retrieve the zone file from remote name servers and will check the 
resource records to make sure that domain's resources are properly resolved. The 
results will be interpreted and displayed on the screen. 

If your Control Panel is integrated with a billing system, then the following operations 
on domains might be available from the Panel: 

Á Setting a password for access to domain management panel at a registrar's site. 

Á Locking and unlocking domain name for transferring to another provider. 

Á Changing domain registrant and other contact information. 

Á Changing DNS settings for domain zones served by a domain registrar. 

Á Configure automatic renewal of the domain account at the domain name 
registration company. 

ü To set a new password for access to your domain management control 
panel at a registrar's site: 

1. Go to the Account tab. 

2. Locate the domain name for which you want to change settings, and 
click the link Show Domain Info next to it. 

3. Click Change Domain Password. 

4. Type a new password and click OK. 

ü To lock or unlock domain name for transferring to another provider: 

1. Go to the Account tab. 

2. Locate the domain name for which you want to change settings, and 
click the link Show Domain Info next to it. 

3. Click Change Registrar Lock Setting. 

4. To allow domain name transfer, clear the Lock checkbox and click OK. 
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ü To change domain owner's contact, technical, administrative, or billing 
information: 

1. Go to the Account tab. 

2. Locate the domain name for which you want to change settings, and 
click the link Show Domain Info next to it. 

3. Click Edit Contact Info. 

4. Make the necessary changes and click OK. 

ü To change DNS settings for a domain: 

1. Go to the Account tab. 

2. Locate the domain name for which you want to change settings, and 
click the link Show Domain Info next to it. 

3. Click Edit DNS Settings. 

4. Specify the domain name servers that serve the DNS zone for your 
website and IP address of the server where the website is hosted. 

5. If the DNS zone of your website is served by your domain name 
registrar, then you can also specify other resource records that affect 
how your website's services are accessible over the Internet. 

6. To save your changes, click OK. 

ü To configure automatic renewal of the domain name: 

1. Go to the Account tab. 

2. Locate the domain name for which you want to change settings, and 
click the link Show Domain Info next to it. 

3. Click Automatic Domain Renewal. 

4. To allow auto renewal of the domain registration, select the Turn on auto 
renewal checkbox and click OK.  
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Changing Hosting Settings 

Panel allows you to manage a number of various hosting settings: 

Á Basic settings, like a domain name or hosting type. 

Á Security settings. To secure connections to your site with SSL certificates, you 
should activate the SSL support first. 

Á Scripting settings. You can specify what scripting languages your site will support. 
Learn more in the section Web Scripting Settings (on page 82). Moreover, Panel 
supports custom per-site (per-subdomain) configuration for the PHP and ASP.NET 
languages. To learn more about the adjustable settings, see the sections PHP 
Settings and ASP.NET Settings (Windows) (on page 86). 

ü If you want to review the hosting settings or select the hosting features 
and scripting languages that should be supported on your site: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription 
menu at the top of the screen, select the webspace where the website 
is hosted.     

2. Click the Websites & Domains tab. 

3. In the list of websites at the bottom of the screen, click the website 
address. 

4. Review or change the following hosting settings and options: 

Á Hosting type. The type of hosting configuration selected by default is website 
hosting, which means that the website is hosted on this server. You can also 
choose to redirect visitors to another website (this setup is also known as web 
forwarding); switch off web hosting service if you need to host only mailboxes 
and mailing lists under that domain; or suspend the website and all mailboxes 
and mailing lists hosted under the website's domain name. 

Á If you want to redirect visitors to another site, click the Change link, select the 
Forwarding option, type the destination site address, select the forwarding 
scheme, and click OK. 

Á If you want to switch off web service and use only e-mail services under that 
domain, click the Change link, select the No web hosting option, and click OK. 

Á If you want to suspend the website and all services associated with it, 
including mail, click the Suspend link. When you need to bring that domain or 
website back online, return to the Websites & Domains tab > domain name, and 
click the Activate link.    

Á Document root. The location of the directory where all files and subdirectories of 
the site will be kept. You can use the default directory called httpdocs or specify 
another directory.  
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Á Enable SSL support. Secure Sockets Layer encryption is generally used for 
protecting transfer of sensitive data during online transactions on e-commerce 
websites that run on dedicated IP addresses. SSL certificates that participate in 
the encryption process are usually applied to a single domain name on a single 
IP address, therefore, each site that needs SSL protection must be hosted on a 
dedicated IP address. An exception to this is subdomains, which you can 
protect with a wildcard certificate. Installing an SSL certificate on a web server 
that hosts several websites with different domain names on a single IP address 
is technically possible, however, it is not recommended: the encryption will be 
provided, but users will get warning messages on attempt to connect to the 
secure site. To allow SSL encryption for the website, select the Enable SSL 
support checkbox. 

Á Scripting languages. Specify which of the following programming and scripting 
languages should be supported by the web server: Active Server Pages (ASP), 
Microsoft ASP.NET,  Server Side Includes (SSI), PHP hypertext preprocessor 
(PHP), Common Gateway Interface (CGI), Fast Common Gateway Interface 
(FastCGI), Perl and Python. By default, PHP is configured to operate in safe 
mode, with functional restrictions that strengthen hosting security. To learn more 
about PHP safe mode, refer to http://php.net/features.safe-mode. 

Á Microsoft FrontPage settings. Microsoft FrontPage is a popular website authoring 
tool. To enable content creation and publishing  through Microsoft FrontPage, 
select the options Microsoft FrontPage support, Microsoft FrontPage over SSL support, 
and Remote FrontPage authoring allowed. 

Á Web statistics. Select the web statistics software that you want to use for viewing 
graphical reports and charts on website visitors. Also, select the corresponding 
checkbox if you want to be able to access the statistical reports by visiting the 
password-protected directory http://your-website/plesk-stat/webstat.  

Á Custom error documents. When visitors coming to a site request pages that the 
web server cannot find, the web server generates and displays a standard 
HTML page with an error message. If you want to create your own error pages 
and use them on the web server, select the Custom error documents checkbox. 

Á Additional write and modify permissions (available only for Windows hosting). This 
option is required if web applications on the site will be using a file-based 
database (like Jet) located in the root of httpdocs directory. Note that selecting 
this option will seriously compromise the website security. 

5. When finished with viewing or changing hosting settings, click OK. 

 

The Location of the cgi -bin Directory  

When creating a domain, you may see different possible locations of your cgi - bin  

directory (the CGI support checkbox). Let us discuss them on samples. 

A typical domain files organization in Panel 11 is as follows: 

Á /var/www/vhosts/webspace1.com/example1.com/  

Á /var/www/vhosts/webspace1.com/example2.com/  

Á /var/www/vhosts/webspace1.com/example3.com/  

Here example  domains are created under the webspace1.com webspace. 

http://php.net/features.safe-mode
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If you specify that the cgi-bin directory for a domain example3.com is the root directory 
of webspace, its absolute path will be 

/var/www/vhosts/webspace1.com/cgi - bin/  

If you specify that the directory is the document root of this domain, its absolute path 
will be 

/va r/www/vhosts/webspace1.com/example3.com/cgi - bin/  

If you specify old-style root of this domain (this option is available only after upgrading 
Panel from previous versions), the absolute path will be 

/var/www/vhosts/domain3.com/cgi - bin   

This option provides the compatibility with the obsoleted organization of domain files on 
the file system. 

In this section: 

Web Scripting Settings ...................................................................................... 82 
 
 

Web Scripting Settings 

For each website in your subscription you can specify which of the following 
programming and scripting languages should be supported by the web server: Active 
Server Pages (ASP), Microsoft ASP.NET,  Server Side Includes (SSI), PHP hypertext 
preprocessor (PHP), Common Gateway Interface (CGI), Fast Common Gateway 
Interface (FastCGI), Perl and Python. Since Panel 10.4, you are able to configure PHP 
settings individually for each website (or subdomain) in your subscription. This is 
possible only if your subscription have the corresponding permissions. To get the 
details about custom PHP configuration, refer to the section PHP Settings. 

In this section: 

PHP Settings ..................................................................................................... 83 
ASP.NET Settings (Windows) ........................................................................... 86 
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PHP Settings 

PHP is one of the most popular scripting languages for creating dynamic web pages. 
The majority of today's websites and web applications are based on PHP scripts. Thus, 
site administrators should clearly understand how they can control the execution of 
PHP scripts.  

There are two main aspects that completely define how PHP scripts will be executed 
for a certain website: The PHP handler type and values of PHP settings for the site. 
You can set up these parameters for a certain website by selecting the site from the list 
in Websites & Domains. 

PHP Handler  

When a visitor accesses a site based on PHP scripts, a web server interprets site 
scripts to generate a page that will be shown to the visitor. PHP handler calls PHP 
libraries needed for this interpretation. You can choose from a number of PHP 
handlers: ISAPI (Windows), Apache module (Linux), FastCGI, or CGI application. The 
decision on what PHP handler to choose should depend on a number of factors like 
security considerations, script execution speed, and memory consumption. 

Choose one of the following PHP handlers at the Websites & Domains > select a website 
> General tab > PHP support: 

 
 

Performance 
 

Memory 
Usage 

Security 
 

Apache 
module (Linux 
only) 

High. 

Runs as a part of the 
Apache web server. 

Low This handler (also known as mod_php) 
is the least secure option as all PHP 
scripts are executed on behalf of the 

apache  user. This means that all files 

created by PHP scripts of any plan 
subscriber have the same owner 

(apache ) and the same permission 

set. Thus, a user has a theoretical 
possibility to affect files of another user 
or some important system files. 

Note:  You can evade some 
security issues by turning the PHP 
safe_mode option on. It disables a 
number of PHP functions that bring 
potential security risk. Note that this 
may lead to inoperability of some 
web apps. The safe_mode option is 
considered to be obsolete and is 
deprecated in PHP 5.3. 
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ISAPI 
extension 
(Windows 
only, not 
supported 
since PHP 
5.3) 

High. 

Runs as a part of the 
IIS web server. 

Low The ISAPI extension can provide site 
isolation in case a dedicated IIS 
application pool is switched on for 
subscriptions. Site isolation means that 
sites of different customers run their 
scripts independently. Thus, an error in 
one PHP script does not affect the 
work of other scripts. In addition, PHP 
scripts run on behalf of a system user 
associated with a hosting account. 

Note:  The ISAPI extension handler 

is not supported since PHP 5.3. 

CGI 
application 

Low. 
Creates a new 
process for each 
request and closes it 
once the request is 
processed. 

Low The CGI handler provides PHP script 
execution on behalf of a system user 
associated with a hosting account. On 
Linux, this behavior is possible only 
when the suEXEC module of the 
Apache web server is on (default 
option). In other case, all PHP scripts 

are executed on behalf of the apache  

user. 

We recommend that you use the CGI 
application handler only as a fall-back. 

FastCGI 
application 

High (close to 
Apache module and 
ISAPI extension). 

Keeps the 
processes running to 
handle further 
incoming requests. 

High The FastCGI handler runs PHP scripts 
on behalf of a system user associated 
with a hosting account.  

Note:  Switching PHP from Apache module to FastCGI application may break functionality 
of existing PHP scripts. 

If you use Windows hosting, you can additionally choose a PHP version. Always use 
PHP 5.x except the cases when you need PHP 4.x to host some old PHP apps. 

PHP Settings  

PHP behavior is defined by a number of configuration settings. These settings specify 
various script execution aspects, like performance (for example, the amount of memory 
a script can use), security (for example, access to file system and services), and so on. 
You may adjust these settings for a number of reasons: 

Á Preventing a memory leak or server hang-up by poorly written scripts. 

Á Protecting data from malicious scripts. 

Á Meeting the requirements of a certain web app. 

Á Testing own scripts and other. 

All customizable PHP settings are located in the Control Panel, Websites & Domains > 
select a website >  PHP Settings tab. For convenience, all PHP settings are divided into 
three groups: 
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Á Performance settings.  
These settings define how scripts work with system resources. For example: Use 

the memory_limit  parameter to limit the amount of memory for a script  to prevent 

a memory leak. In addition, you can prevent scripts from tying up the server by 

limiting the maximum time scripts are allowed to run in max_execution_time . 

Á Common settings.  
This group contains other commonly used PHP settings. Generally, these are: 
Security settings (for example, the PHP safe mode toggle or the permission to 
register global variables), error reporting settings (for example, the directive to log 
errors), and others. 

Á Additional configuration directives.  
If you cannot find particular parameters among performance or common settings, 
add them to the Additional configuration directives field. All directives from that field will 
be included in the final PHP configuration. For example, if you want PHP to log 

errors to your own file, add the line: error_log=/tmp/my_file.log .  

You can set the value of each parameter in PHP Settings either by selecting a value from 
a preset, typing a custom value, or leaving the Default value. In the latter case, Panel 
uses the values defined by the server-wide php.ini file. For information about certain 
PHP settings, refer to the respective documentation. For example, 
http://php.net/manual/en/ini.list.php.  

It is possible to use three placeholders in parameter values:  

Á {DOCROOT} for the document root directory of a domain that gets custom PHP 

configuration. 

Á {WEBSPACEROOT} for the root directory of a subscription (webspace). 

Á {TMP}  for the directory which stores temporary files. 

Note: Custom PHP configuration of a website acts as a preset for all subdomains of 
this site. You can perform further per-subdomain PHP configuration in the same way as 
for the websites.  
 

http://php.net/manual/en/ini.list.php
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ASP.NET Settings (Windows) 

ü To configure ASP.NET Settings for a site: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription 
menu at the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > ASP.NET Settings (in the Advanced 
Operations group). 

3. Set up the strings that determine database connection data for 
ASP.NET applications that use databases. This option is available only 
for ASP.NET 2.0.x. 

When you open the ASP.NET configuration screen for the first time, sample 
connection parameters with common constructions are displayed. You can 
delete them and specify your own strings. 

Á To add a string, enter the required data into the Name and Connection Parameters 

input fields and click  next to them. 

Á To remove a string, click  next to it. 

4. Set up custom error messages that will be returned by ASP.NET 
applications in the Custom Error Settings field: 

Á To set the custom error messages mode, select an appropriate option from the 
Custom error mode menu: 

Á On - custom error messages are enabled. 

Á Off - custom error messages are disabled and detailed errors are to be 
shown. 

Á RemoteOnly - custom error messages are displayed only to remote clients, 
and ASP.NET errors are shown to the local host users. 

Á To add a new custom error message (which will be applied unless the Off mode 
was selected), enter the values in the Status Code and Redirect URL fields, and 

click . 

Á Status Code defines the HTTP status code resulting in redirection to the error 
page. 

Á Redirect URL defines the web address of the error page presenting 
information about the error to the client. 

Due to possible conflicts, you cannot add a new custom error message with an 
error code that already exists, but you can redefine the URL for the existing 
code. 

Á To remove a custom error message from the list, click  next to it. 

5. Configure compilation settings in the Compilation and Debugging field: 

Á To determine the programming language to be used as default in dynamic 
compilation files, choose an entry from Default web page language list. 
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Á To enable compiling retail binaries, leave the Switch on debugging checkbox 
empty. 

Á To enable compiling debug binaries, select the Switch on debugging checkbox. In 
this case, the source code fragments containing error will be shown in a 
diagnostic page message. 

Note.  When running applications in debug mode, a memory and/or performance 
overhead occurs. It is recommended to use debugging when testing an application 
and to disable it before deploying the application into production scenario. 

6. Configure encoding settings for ASP.NET applications in the Globalization 
Settings section: 

Á To set an adopted encoding of all incoming requests, enter an encoding value 
into the Request encoding field (default is utf-8). 

Á To set an adopted encoding of all responses, enter an encoding value into the 
Response encoding field (default is utf-8). 

Á To set an encoding which must be used by default for parsing of .aspx , .asmx , 

and .asax  files, enter an encoding value into the File encoding field (default is 

Windows-1252). 

Á To set a culture which must be used by default for processing incoming web 
requests, select an appropriate item from the Culture list. 

Á To set a culture which must be used by default when processing searches for a 
locale-dependent resource, select an appropriate item from the UI Culture list. 

7. Set a code access security trust level for ASP.NET applications in the 
Code Access Security field. 

CAS trust level is a security zone to which applications execution is assigned, 
defining what server resources the applications will have access to. 

Important:  When an assembly is assigned a trust level that is too low, it does not 
function correctly. For more information on the permissions levels see 
http://msdn.microsoft.com/library/en-
us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010. 

8. Enable the usage of the auxiliary scripts in the Script Library Settings field. 
Specifying the script library settings is necessary if the validation web 
controls are used on your web site. This option is available only for 
ASP.NET 1.1.x. 

Á If you need to use auxiliary scripts (specifically, scripts implementing objects for 
validating input data), provide the settings for .NET framework script library. To 
do so, enter the path beginning with the domain root directory preceded by the 
forward slash into the Path to Microsoft script library field, or click the folder icon 
next to the Path to Microsoft script library field and browse for the required location. 

Á To initiate the auto-installation of files containing the scripts to the specified 
location, select the Install checkbox. If the files already exist there, they will be 
rewritten. 

 

 

http://msdn.microsoft.com/library/en-us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010
http://msdn.microsoft.com/library/en-us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010
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9. Set client session parameters in the Session Settings field: 

Á To set up the default authentication mode for applications, select an appropriate 
item from the Authentication mode list. Windows authentication mode should be 
selected if any form of IIS authentication is used. 

Á To set up time that a session can remain idle, type the number of minutes into 
the Session timeout box. 

10. Click OK to apply all changes. 

 
 

Suspending and Activating Websites 

When a website is suspended, it becomes inaccessible over the Internet, and e-mail 
addresses under the site's domain name stop working. 

ü To suspend a website: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. Click the domain name of the site that you want to suspend. 

4. Click the Suspend link next to the Hosting type field. 

ü To activate a website: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. Click the domain name of the site that you want to activate. 

4. Click the Activate link next to the Hosting type field. 

 

In this section: 

Suspending Websites for Maintenance ............................................................. 89 
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Suspending Websites for Maintenance 

If you want to shut down a site for maintenance and let your visitors know that it is 
temporarily unavailable and will be back online later, switch on the site maintenance 
mode. When a site is in the maintenance mode, the "503 Service Unavailable" error 
document is shown to website visitors instead of the actual site pages.  

If your hosting plan provides the option to customize web server error documents (the 
"Custom error pages" option), then you can use File Manager to open and customize 
the error page: Instead of the "Service Temporarily Unavailable" message, you can 
write your own message like "The site is temporarily down for maintenance, it will be up 
soon." 

When maintenance work is finished, switch the maintenance mode off for the site to 
make it available to the visitors. 

ü To switch on the maintenance mode for a website: 

1. Go to the Websites & Domains tab. 

2. Click Website Maintenance Mode (in the Advanced Operations group). 

3. If you have several websites, locate the site you want to temporarily 
suspend, and click the corresponding Manage link. 

4. Select the Switch on the maintenance mode for website checkbox. 

5. Click OK. 

If the custom error documents option is switched on for the site, then you can edit the 
"503 Service Temporarily Unavailable" document to include your own text. For 
information about customizing error pages, refer to the section Setting Up Custom Error 
Pages (on page 116). 

ü To switch off the maintenance mode and put a site back online: 

1. Go to the Websites & Domains tab. 

2. In the list of your websites, locate the website you want to put back 
online. It should be accompanied by the Switched off for maintenance status 
indicator. 

3. Click the corresponding Change link. 

4. Clear the Switch on the maintenance mode for website checkbox. 

5. Click OK. 
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Managing Website Content 

To create your website and fill it with the content you need (text, images, videos, and 
so on), use one of the methods provided by the Panel: 

Á Using website creation and management tools. If you do not have a website yet, 
consider setting one up by yourself with a tool for creating, editing, and publishing 
websites. You can do this even if you do not possess the necessary web 
programming and design skills. The best tools of this sort are the following: 

Á Web Presence Builder - a website editor integrated with the Control Panel.  

Á Third-party Content Management Systems (CMS) - web applications for creating 
and editing websites.  

Á Uploading existing websites to your hosting account using one the following 
methods: 

Á FTP client program. You can obtain a free FTP client from the Internet, or, if you 
are using Windows, use Windows Explorer. This enables you to access your 
directory on the hosting server and manage your files. If you collaborate with 
other people when managing your website (say, programmers or designers), 
you can provide them with access to your directory using FTP to let them edit 
the website by themselves. 

Á File Manager. A tool for uploading and managing website files and directories 
through the Panel web interface.  

Note: if you have a website created in Microsoft FrontPage editor, refer to the section 
Working with Microsoft Frontpage Websites (Windows) (on page 126) for details on 
managing this site in Panel. 

Below you will find detailed descriptions of the ways to manage your content. 

Web Presence Builder  

Web Presence Builder is a great tool that enables users with no knowledge of HTML 
markup or graphic design skills to create professional-looking sites. Just pick a suitable 
page design and content template, add your text to the pages, and publish the site. 

You can create and publish websites using Web Presence Builder if your hosting 
subscription provides this option. If it does not, or if you have already created and 
published the allowed number of sites, you still can create a new website with Web 
Presence Builder and edit it. However, to publish this website, you will need to upgrade 
your hosting plan. 

To start creating a website using Web Presence Builder or edit an existing Web 
Presence Builder site, go to either the Home tab or the Websites & Domains tab, and click 
Launch Web Presence Builder. If you have several domain names or subdomains, click the 
corresponding link Edit in Web Presence Builder. Find more information on creating and 
editing websites in Web Presence Builder in the chapter Building Websites with Web 
Presence Builder (on page 147). 
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Third -Party Content Management Systems  

To create and maintain a website, you can use third-party Content Management 
Systems (CMS) - web applications that let you easily edit a website's structure and 
content with a graphical user interface. Examples of such systems are Drupal and 
Joomla. 

CMS are usually server applications, so to start using one of them you should install it 
on your hosting account. Hence, if you plan to use a CMS, ensure that your hosting 
subscription allows such applications to be installed. 

ü To create a website using a CMS: 

1. Go to the Applications tab.  

2. Find the CMS you need in the list of available applications, and install it 
as described in the section Employing Website Applications (on page 98). 

3. Create and edit your website in the CMS. For information on how to 
create websites with your CMS, refer to the relevant documentation. 

 

Uploading Using FTP  

If you already have all your website files and directories, consider uploading them to 
your hosting account using FTP. This is the quickest way for simple uploading of files 
when you do not need to edit or manage them on the server. 

ü To upload files using FTP: 

1. Connect to your site's domain name with an FTP client program using 
your FTP access credentials. Learn how to configure these credentials 
in the section Adding FTP Accounts (on page 192).  

2. Copy the website files and directories to your directory on the server.  

 

File Manager  

Another way to publish a website created outside the Panel is File Manager - a tool that 
provides a set of file management functions through the web interface. File Manager is 
available from the Websites & Domains tab of the Control Panel.  

To upload a website from your computer to Panel server with File Manager, go to the 
Website & Domains > File Manager page, click Add New Directory, and upload the directory 
containing your website to Panel. If your website is compressed to a ZIP file, you can 
upload this file by clicking Add New File and then extract it by clicking Extract Files. 
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If you want to edit pages of your website, you can do it in File Manager. It provides an 
HTML editor that allows visual editing of HTML pages (without needing to manually 

type HTML tags). To edit a file in the HTML editor, click the button  in the Tools 
column next to the file's name. 

You can also edit files in File Manager's text editor if you like. To open a file in the text 

editor, click the corresponding  button  in the Tools column. 

If you have files or web pages that you want to make inaccessible on the Internet, 
change these files' access permissions in File Manager. To edit access permissions for 
a file or a directory, click the corresponding link in the Permissions column. To learn how 
to review and edit the permissions, refer to the sections Setting File and Directory Access 
Permissions (on page 93). 

In this section: 

Setting File and Directory Access Permissions .................................................. 93 
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Setting File and Directory Access Permissions 

ü To review or change the permissions set for files and directories on Linux 
systems: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. Click File Manager. 

The permissions set for files and directories are shown in the Permissions column. 
They are represented as three sets of symbols, for example, 'rwx rwx r--'. The first 
set tells what the owner of the file or directory can do with it; the second tells what 
the user group, the file or directory belongs to, can do with the file or directory; the 
third set indicates what other users (the rest of the world, that is, Internet users 
visiting a site) can do with the file or directory. R means the permission to read the 
file or directory, W means the permission to write to the file or directory, and X 
means the permission to execute the file or look inside the directory. 

4. Locate the file or directory for which you want to modify permissions 
and click a hyperlink in the Permissions column. 

5. Modify the permissions as desired and click OK. 

  

ü To set access permissions for a file or directory on Windows systems: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription 
menu at the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > File Manager. 

3. Locate the file or directory for which you want to set access 

permissions, and click the corresponding icon . 

4. Do the following: 

Á To make the file or folder inherit permissions from a parent folder (if it does not), 
select the checkbox Allow inheritable permissions from the parent to propagate to this 
object and all child objects. Include these with entries explicitly defined here. 

Á To make the files and folders, which are contained in this folder, inherit the 
folder permissions you define, select the checkbox Replace permission entries on 
all child objects with entries shown here that apply to child objects. 

Á To change or remove permissions from a group or a user, click the required 
name in the Group or user names list. If the group or user is not listed in the Group 
or user names list, select the required user or group name from the menu located 

above the list and click : the user/group appears in the list. Select it. 
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To allow or deny permissions to a selected group/user, select the Allow or Deny 
checkboxes corresponding to permissions listed under Permissions for <user/group 
name>. If the checkboxes in the Allow or Deny columns are shown in grey, it 
means that the corresponding permissions are inherited from a parent folder. 

Á To deny the permissions, which are inherited from a parent object as allowed, 
select the required checkboxes under Deny. This will override inherited 
permissions for this file/folder. 

Á To allow the permissions, which are inherited from a parent object as denied, 
clear the Allow inheritable permissions from the parent to propagate to this object and all 
child objects. Include these with entries explicitly defined here checkbox: this removes 
the inherited permissions. Then select the required checkboxes under Allow and 
Deny. 

Á To remove access permissions from a group or user, select the required name 

in the Group or user names list and click the icon  next to it. 

5. If you need advanced fine-tuning of permissions, click the Advanced 
button, and do the following: 

Á To create a permission entry for a group or user, select the required name from 

the Group or user names list and click . 

Á To set or change file/folder permissions for a group or user, select the required 
name from the Group or user names list, select the required Allow and Deny 
checkboxes corresponding to permissions listed under Permissions for <user/group 
name>. 

Á To remove a permission entry for a group or user, select the required name from 

the Group or user names list and click . 

Á To make child objects of a folder inherit its permissions defined under 
Permissions for <user/group name>, select the Replace permission entries on all child 
objects with entries shown here that apply to child objects checkbox, and select 
checkboxes in the Apply to list which correspond to the objects that must inherit 
the permissions. 

6. Click OK. 
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(Advanced) Restricting Access to Content 

If you have directories in a site that only authorized users should see, restrict access to 
these directories with password protection. 

ü To protect a directory in your site with a password and to specify 
authorized users: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription 
menu at the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Password-protected Directories (in the 
Advanced Operations group). 

3. Click Add Protected Directory. 

4. In the Directory name box, specify the path to the directory that you want 
to protect with a password.   

This can be any directory existing in the site, for example: /private . If the 

directory that you would like to protect has not yet been created, specify the path 
and the directory name ï the Panel will create it for you. 

5. If you are using a Linux-based account, you can also protect your CGI 

scripts stored in the cgi - bin  directory. To do this, leave '/' in the 

Directory name box and select the cgi-bin checkbox. 

6. In the Title of the protected area box, type a resource description or a 
welcoming message that your users will see when they visit the 
protected area. 

7. Click OK. The directory you specified will be protected. 

8. To add authorized users, click Add New User. 

9. Specify the username and password that will be used for accessing the 
protected area. The password should be from 5 to 14 symbols in length. 
Click OK. 

ü To add an authorized user of a protected directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription 
menu at the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Password-protected Directories (in the 
Advanced Operations group). 

3. Click on the name of the directory you need. 

4. Click the Add New User icon. 
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5. Specify the username and password that will be used for accessing the 
protected area. The password should be from 5 to 14 symbols in length. 

6. Click OK. 

ü To change password for an authorized user of a protected directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription 
menu at the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Password-protected Directories (in the 
Advanced Operations group). 

3. Click on the name of the directory you need. A list of authorized users 
will open. 

4. Click on the userôs name. 

5. Specify the new password and re-type it for confirmation. 

6. Click OK. 

ü To revoke a permission to access the protected directory from a user: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription 
menu at the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Password-protected Directories (in the 
Advanced Operations group). 

3. Click on the name of the directory you need. A list of authorized users 
will open. 

4. Select a checkbox corresponding to the userôs name. 

5. Click Remove. Confirm the operation and click OK. 

ü To remove password protection and make the resource available to the 
public: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription 

menu at the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Password-protected Directories (in the 
Advanced Operations group). 

3. Select a checkbox corresponding to the name of the directory, from 
which you want to remove protection. 

4. Click Remove Protection. The protection will be removed and the contents 
of the directory will be accessible to the public without restrictions. 
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Previewing Websites 

After you purchase a domain, its registration can require some time. The reason for the 
delay is that name servers update their zone information periodically. Thus, until all 
name servers have received information about your zone, you will not be able to 
access your site by its domain name. Nevertheless, you can always access your site 
during domain name propagation using the button on the Websites & Domains tab. 

During domain name propagation other people can access your site too. For this 
purpose, Panel registers your website as a subdomain of one of the provider's sites. 
For example, if your website is my-domain.tld and a provider has configured the 
preview service on provider-domain.tld, you can access your site on my-
domain.tld.192-0-2-12.provider-domain.tld. Here 192-0-2-12 is the site's IP address 
where dots are replaced with dashes. 

Note: If you do not have the site preview button on the Websites & Domains page, 
contact your hosting provider. 
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Using Website Applications 

You can significantly increase your website functionality by using different web apps. 
Apps being installed on a website can perform a number of tasks. If you are an 
individual, you can, for example, present yourself with a blog or organize online storage 
of your media files. Companies can move part of their business online by using the e-
commerce or CRM web apps. All these apps are available for installation right from 
your Control Panel, the Applications tab. 

The list of available apps is governed by your hosting plan. For example, it might 
include only free apps or no apps at all. For more information on available apps, refer 
to your hosting provider. 

App Types  

There are two types of web apps: 

Á Apps that are installed directly on a website (say, the WordPress blogging platform 
or the Joomla! content management system). 

Á Apps installed on external servers and provided by third-parties. 

Regardless of the installation type, apps can be either free or commercial. Commercial 
apps require you to provide a license key to start working with them, and in the 
Applications tab they are accompanied by the Buy Now button instead of Install Now. If 
you decide to use commercial apps, read the Managing Commercial Apps Licenses section 
(on page 101) to familiarize yourself with acquiring and managing app licenses.  

App Installation and Maintenance  

The process of installation does not require any specific skills. You just fill in app 
settings (such as, administrator credentials), and Panel installs the app for you. Further 
app management is also facilitated as you can update or remove apps directly in 
Panel. Moreover, you can access some functions that apps reveal to the Control Panel 
(without the need to log in to an app). For example, you can add SugarCRM user 
account right from your Control Panel. Such app functionality is a service provided by 
the app. 

After you install an app, grant other auxiliary user accounts access to it if you want 
them to be able to use the app. To get started with managing apps, see the section 
Managing Apps.   

Access to Apps  

Make your apps available to certain auxiliary users by adjusting their permissions. 
Once you allow a user to access an app, a link to the app appears on their Home page. 
Note that you can control app access only for user groups, so you should either modify 
the permissions of an existing group or create a new one, and then assign users to it. 
For details on access to apps, refer to the section Granting Auxiliary Users Access to Apps 
(on page 100). 
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By default, the app administrator in Panel is a user with the Owner role. As well as 
accessing apps from the Home page, this user can also install and manage apps within 
a subscription. These administrative tools are found in the Applications tab which is 
available only to app administrators. You can grant access to these tools to other 
subscription users. For details on this operation, refer to the section Granting Auxiliary 
Users Access to Apps (on page 100). 

Apps and Auxiliary User Accounts  

Some apps let you create and manage user accounts directly in Panel. For example, 
the SugarCRM app allows you to add SugarCRM users without logging in to the app. 
All apps with such "account services" can associate their accounts with users of a 
Panel subscription (auxiliary users). To perform such an association, you should grant 
the auxiliary users access to that account service (in the same way as you grant 
access to apps). For details on account association, refer to the section Linking Apps 
and Auxiliary  (on page 100)User Accounts. 

You can install, configure, update, and remove apps right from the Control Panel. 

In this section: 

Configuring Apps ............................................................................................... 99 
Granting Auxiliary Users Access to Apps .......................................................... 100 
Linking Apps and Auxiliary User Accounts ........................................................ 100 
Updating Installed Apps .................................................................................... 101 
Managing Commercial Apps Licenses............................................................... 101 
 
 

Configuring Apps 

Generally, all apps allow the configuration of their main parameters directly in the 
Control Panel. You can access app settings by selecting the app from the list in 
Applications > Manage Installed Applications. After you select an app, you can configure the 
following: 

Á General settings. 
These are basic app settings (say, administrator password) that can be changed 
with Change Settings. 

Á Service settings. 
If an app provides a part of its functionality to Panel by means of services, you have 
the option to configure them. For example, the SugarCRM app allows the creation 
of user accounts and provides this ability as a service in the Control Panel. After 
you select this service in Provided services, you can view all app user accounts and 
create new ones. 
For some apps, you can associate the app accounts with auxiliary user accounts. 
Learn more about account association in the section Linking App and Auxiliary  (on 
page 100)User Accounts. 
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Granting Auxiliary Users Access to Apps 

By default, after you install an app, only users with the Owner role can access it. To 
allow other subscription users to access the app: 

Á Grant permission to access the app to a certain user group in Users > User Roles. 

Á Be sure to add users of your choice to the group. 

Once you allow users to access the app, a link to the app appears on their Home page. 

By default, the app administrator is a subscription user with the Owner role. As well as 
accessing the apps from the Home page, this user can also install and manage apps 
within a subscription. For these purposes, their interface has the additional Applications 
tab. You can provide the same administrative privileges to other subscription users by 
granting the Install and manage applications permission to their role in Users > User Roles. 
This gives users full administrative access to all apps within a subscription. As well as 
the administrator, the users with this permission can install, configure, update, and 
remove apps through the Applications tab in their Control Panel. 
 

Linking Apps and Auxiliary User Accounts 

Some apps let you create and manage user accounts without logging in to the app. If 
an app provides such an account service, you can link users of a Panel subscription 
with accounts in the app. To perform such an association: 

1. Organize the users into a certain group (Users > User Roles). 

2. Grant one of these group permissions: 

Á Public access. 
If granted, all users in the group will have access to the app through the link on 
the Home page. 

Á Personal access. 
If granted, the app will automatically create accounts for all users in the group. 
After that, the users' Home page will contain an additional link that allows logging 
in to a personal account in the app. Note that if you deny the Personal access 
permission, the app will automatically remove all accounts associated with this 
group. 
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Updating Installed Apps 

Basically, your service provider is in charge of app updates. If the update is available, 
your provider can get it for you, or you can do it, yourself. The last case is relevant if 
you want to review the changes available in the new version and decide whether to 
update the app or continue with the current version. The update link appears in 
Applications > Manage Installed Applications. 

Managing Commercial Apps Licenses 

If you decide to buy an application license in the Control Panel and click the 
corresponding button on the Applications tab, you will be forwarded to Storefront, the 
online store where you complete your order. Actually it is not only a store, it also 
includes its own web interface to help you perform various operations with the licenses 
you own. For example, from this web interface you can renew a license, cancel it, 
change your payment methods and so on. This section explains how to carry out these 
operations. 

Storefront Basics  

When you order a first license in Storefront, it creates an account for you. This account 
contains your personal and financial information; if you log in to Storefront under this 
account, you will be able to do various operations with your licenses.  

Each time you successfully check out in Storefront, a purchase order is generated. It is 
a document that lists the cart items you ordered. Storefront assigns different statuses 
to orders. These statuses explain the current state of your purchase - whether it is 
unpaid, canceled, or successfully delivered.  

Storefront and Panel share the service plans business model. In Storefront, each 
application is presented by a separate service plan, and when you order an application 
license you subscribe to one of the service plans. In other words, each license you 
purchase is shown as a subscription in the web interface. For instance, if you would 
like to view a license price, terms, or an expiration date, you should open the 
corresponding subscription. 

How to Get a License File or Key  

After you order a license and pay for it, Storefront sends you an e-mail with your 
license file or key. We recommend that you keep the information in a safe place 
because there is no way to request it again or view it from the web interface. If you did 
not receive the e-mail with a license file or key, contact us at 
https://support.parallels.com/.  

 

 

 

 

https://support.parallels.com/
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Available Operations  

The operations you can carry out in Storefront fall into three groups: 

Á Operations with your user account. These operations include viewing and modifying 
your personal information and preferences and changing the password to your user 
account. 

Á Operations with payments and payment methods. This group comprises operations 
with your credit cards, payments, and orders. 

Á Operations with subscriptions. Use them to acquire new licenses, obtain 
information about your existing licenses, and check the subscription renewal 
method for a particular subscription. 

Learn more about these operations in the subsections of this section. 

In this section: 

User Account ..................................................................................................... 103 
Payments and Payment Methods ...................................................................... 104 
Subscriptions ..................................................................................................... 105 
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User Account 

You can do the following operations with your user account. 

View and Change Your Account Information  

The system uses your account information to add your personal and financial details into 
invoices. If you see that you need to update your details, open the My Contact Info submenu 
on the Navigation menu and select Account Info.  
 

View and Change Your Personal Information  

Your personal information mostly duplicates the account information. It does not appear in 
financial documents, but some services use this information as technical contact details. For 
example, it is possible to order a domain name through Storefront, and if you do so, 
Storefront will send your personal information (as the technical contact) to a domain name 
registrar. 
To view user personal information, open the My Contact Info > Personal Info menu on the left 
panel. Here you can also edit your personal information and change password to your 
Storefront account. 
 

Configure e -mail notifications  

E-mail notifications are sent on different events to your account contact e-mail address. They 
fall into a number of categories. For example, subscription renewal and expiration, your 
credit card(s) expiration, etc. You can select messages format for every group of messages 
and decide whether to send certain messages or not. To configure messages types to 
receive, open My Contact Info > Notification Methods.  
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Payments and Payment Methods 

This section describes operations with payments and credit cards available to you in 
Storefront. 

Registering a Credit Card  

Before a credit card becomes available for making online payments, it is necessary to 
register it in Storefront. To register a credit card, open Billing Manager > My Financial Info > 
Payment Methods and click the appropriate button.  

Configuring Automatic Payments  

You can assign one of the registered credit cards to be used for paying orders automatically. 
In this case, you will not need to pay each order manually. If you assign a payment method 
to be used for automatic payments, the previous default one is unselected automatically. 
Thus, only one payment method can be used for automated payments. 

To turn on automatic payments from a card, go to Billing Manager > My Financial Info > Payment 
Methods, select the card  by clicking on its ID or Type, and, finally, enable automatic payments 
on the card properties screen. 

Making a Payment  

To add new payment, open the Billing Manager > New Payment link on the dashboard. The 
adding new payment wizard starts. The list of pending documents appears on the screen. If 
there are no pending documents, click Cancel to finish the wizard. Otherwise, walk through 
the wizard by providing the payment settings. 

Viewing Open Orders  

Your open orders are available in the Billing Manager > My Financial Info > Open Orders 
submenu. 
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Subscriptions 

Storefront offers you a powerful and comprehensive mechanism of subscriptions (licenses) 
management, allowing you to perform the following operations. 

Buying a Subscription  

If you want to purchase one more app license or another service offered by Storefront, there 
is no need for you to go to the Control Panel. The Storefront web interface provides all 
facilities for making the purchase. To start the subscription ordering wizard, open Billing 
Manager > Subscription Management and click Buy New Subscription.  

Renewi ng a Subscription Manually  

If you did not configure the auto renewal feature, your subscription will expire unless you do 
not renew it manually. The auto renewal setup instructions are given later in this section. To 
renew a subscription manually, open Billing Manager > Subscription Management > Renew 
Subscription and follow the wizard steps. 

Renewing Subscriptions Automatically  

Configuring a subscription for auto renewal helps renewing your subscriptions in time. To 
allow the auto renewal, open Billing Manager > Subscription Management > Renew Subscription, 
click a subscription for which you want to turn the option on, and click Turn On AutoRenew 
Option. Clear the option to cancel the auto renewal. 

Canceling a Subscription  

A subscription cancelation results in termination of the subscription services and money 
refund. To cancel a subscription, open Billing Manager > Subscription Management > Renew 
Subscription, click a subscription you want to cancel, and start the cancelation wizard by 
clicking Cancel Subscription. 

(Advanced) Securing Your Websites 

In this section: 

Securing Connections with SSL Certificates ...................................................... 106 
Protecting Sites from Hotlinking (Windows) ....................................................... 111 
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Securing Connections with SSL Certificates 

If your website transfers private data, for example, visitors' credit card numbers, we 
recommend that you use the SSL secure channel for this website. To set up such a channel, 
you should purchase an SSL certificate for your website. 

SSL certificates are used not only for establishing secure communication channels on the 
Internet but also for verifying a website's identity as well. When users visit your secure online 
store, they are notified that your website is really what it claims to be and that all sensitive 
data, such as credit card numbers, will be transferred over a secure channel.  

SSL certificates are issued by specific organizations - SSL certificate providers. However, 
some hosting providers allow customers to purchase SSL certificates directly from Panel.  

Purchasing SSL Certificates  

Depending on your hosting provider, you can have the following ways of purchasing SSL 
certificates: 

Á Order an SSL certificate from Panel. This way is available to you if your provider 
configures the corresponding Panel settings. The links for purchasing SSL certificates 
from Panel may let your purchase certificates either from your provider in their online 
store or from Parallels in the MyPlesk outlet. To learn how to order an SSL certificate 
through Panel, see the section Purchasing SSL Certificates through Panel (on page 107). 

Á Order an SSL certificate from the SSL certificate provider you like. In this case, you 
should create a certificate signing request (CSR) for your website in Panel and submit it 
to an SSL certificate provider. To learn how to create such request and purchase a 
certificate with it, refer to the section Generating Certificate Signing Requests (on page 108). 

 

Securing Websites  

After you obtain a certificate for your website, you should secure the connection to the 
website with the certificate. The section Securing Websites (on page 109) explains how to do 
this. 

 

Securing Websites with Shared SSL Ce rtificates  

On Windows systems, you may be able to secure your websites without purchasing your 
own SSL certificates. This feature is available to you if your hosting provider offers shared 
SSL certificates. The section Using Shared SSL Certificates (Windows) (on page 110) explains 
how to secure a website with a shared SSL certificate. 

In this section: 

Purchasing SSL Certificates Through Panel ...................................................... 107 
Generating Certificate Signing Requests ........................................................... 108 
Securing Websites ............................................................................................ 109 
Using Shared SSL Certificates (Windows)......................................................... 110 
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Purchasing SSL Certificates Through Panel 

The links for purchasing SSL certificates in Panel let you purchase either certificates from 
your provider if they offer their own certificates, or certificates from Parallels in the MyPlesk 
outlet. These links may also be unavailable to you if your provider decides so. 

ü To purchase an SSL certificate through Panel: 

1. Open the corresponding subscription in the Control Panel 

2. Go to the Websites & Domains > Secure Your Sites page. 

3. Click Add SSL Certificate. 

4. Specify the following certificate parameters: 

Á Certificate name. This will help you identify this certificate in the repository. 

Á Encryption level. Choose the encryption level of your SSL certificate. We recommend 
that you choose a value more than 1024 bit. 

Á Your location and organization name. The values you enter should not exceed the 
length of 64 symbols. 

Á The domain name for which you want to purchase an SSL certificate. This should be a 
fully qualified domain name. Example: your-domain.com. 

Á The website administrator's e-mail address. 

5. Make sure that all the provided information is correct and accurate, as it will 
be used to generate your private key. 

6. Click Buy SSL Certificate. 

7. Complete all steps of an SSL certificate purchase in the online store and you 
will receive your SSL certificate by e-mail.  
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Generating Certificate Signing Requests 

If your hosting provider does not allow purchasing SSL certificates through Panel, you can 
create a certificate signing request and submit it to an SSL certificate provider. The provider 
will generate an SSL certificate for your website basing on this request. 

ü To generate a certificate signing request: 

1. Open the corresponding subscription on the Control Panel 

2. Go to the Websites & Domains > Secure Your Sites page. 

3. Click Add SSL Certificate. 

4. Specify the following certificate parameters: 

Á Certificate name. This will help you identify this certificate in the repository. 

Á Encryption level. Choose the encryption level of your SSL certificate. We recommend 
that you choose a value more than 1024 bit. 

Á Your location and organization name. The values you enter should not exceed the 
length of 64 symbols. 

Á The domain name for which you want to purchase an SSL certificate. This should be a 
fully qualified domain name. Example: your-domain.com. 

Á The website administrator's e-mail address. 

5. Make sure that all the provided information is correct and accurate, as it will 
be used to generate your private key. 

6. Click Request. Panel will generate your private key and certificate signing 
request and add them to your certificates repository (Websites & Domains > 
Secure Your Sites). 

7. In the list of certificates, click the name of the certificate you need. 

8. Locate the CSR section on the page, and copy the text that starts with the line 
-----BEGIN CERTIFICATE REQUEST----- and ends with the line -----END CERTIFICATE 
REQUEST----- to the clipboard. 

9. Visit the website of the certification authority from which you want to 
purchase an SSL certificate, and follow the links on their site to start a 
certificate ordering procedure. When you are prompted to specify CSR text, 
paste the data from the clipboard into the online form and click Continue. The 
certification authority will create an SSL certificate in accordance with the 
information you supplied. 
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Securing Websites 

After you receive an SSL certificate for your website, secure the website with this certificate. 

ü To secure a website with an SSL certificate: 

1. Log in to the Control Panel and select the subscription that contains the 
website you want to secure in the Subscriptions menu at the top of the screen. 

2. Go to the SSL certificates repository of the selected subscription (Websites & 
Domains tab > Secure Your Sites). 

3. Upload the SSL certificate: Click Browse in the middle of the screen and 
navigate to the location of the saved certificate. Select it, and then click Send 
File. 

This will upload and install the certificate against the corresponding private key. 

4. To install the certificate on a site, return to the Websites & Domains tab, and 
click the domain name of the website that you want to secure. 

5. To switch on SSL protection, select the Enable SSL support checkbox. 

6. From the SSL certificate menu, select your SSL certificate and click OK. 
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Using Shared SSL Certificates (Windows) 

If your hosting service provider offers shared SSL for securing access to sites, then you can 
switch on SSL encryption without purchasing your own SSL certificate. 

ü To secure connections to a site by using an SSL certificate shared by your 
provider: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Shared SSL (in the Advanced Operations group). 

3. Select the domain name of the site that you want to secure. 

4. Select the Switch on shared SSL checkbox. 

5. Specify the virtual directory name in the corresponding input field. The virtual 
directory with the supplied name will be created under the domain whose 
SSL certificate is shared (called master SSL domain). This directory will be 
used for accessing your site through SSL. 

For example, let us suppose that you have a domain named mydomain.com, the master 
SSL domain is defined as master_ssl_domain.com, and the virtual directory name you 

supplied is my_virtual_dir . In this case, to access your site through SSL, you need to 

use the following address: https://master_ssl_domain.com/my_virtual_dir.  

Note:  You cannot use your domain name (for example, mydomain.com) to access your 

site via SSL if you are using shared SSL. 

6. Select the directory where protected content is located under your website. 
The documents within the specified directory will be accessible only through 
SSL. 

7. To make your domain accessible via SSL only, select the checkbox Make this 
website accessible only through secure connections. 

8. Click OK. 
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Protecting Sites from Hotlinking (Windows) 

Hotlinking (also called file leeching, remote linking, direct linking, bandwidth stealing or 
bandwidth banditism) is a term used for describing a situation when a web page of one 
domain owner is directly linking to images (or other multimedia files) on the web pages of 
another domain owner, usually using an <IMG> tag. If your domains are hotlinked, you may 
face the problem of excessive bandwidth usage.  

ü To protect a website from hotlinking:  

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 

the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Hotlink Protection (in the Advanced Operations 
group). 

3. Click Switch On to enable the protection from hotlinking.  

4. Specify the extensions of files that you want to protect from hotlinking (for 
example, jpg, bmp, and so on) in the Protected files extensions field. When 
listing several file extensions, separate them with white spaces. 

5. If you want to allow direct linking to your files from certain sites, type the 
website addresses into the Addresses of friendly websites field, and click Add. 

6. Click OK. 
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(Advanced) Extended Website Management 

Panel provides a number of operations on websites and domains for advanced users: 
Working with third-party applications and services, fine tuning of some system services, and 
much more. This section contains the detailed instructions on all these operations. 

In this section: 

Working with a Staging Site ............................................................................... 113 
Setting Up Mobile Sites ..................................................................................... 115 
Setting Up Custom Error Pages ........................................................................ 116 
Adding a Domain Forwarder .............................................................................. 118 
Using Google Services ...................................................................................... 121 
Hosting Personal Web Pages Under Your Domains .......................................... 123 
Limiting Bandwidth and Number of Connections to Websites ............................ 125 
Working with Microsoft Frontpage Websites (Windows) .................................... 126 
Using Virtual Directories (Windows) .................................................................. 131 
Setting Up IIS Application Pool (Windows) ........................................................ 143 
Web Publishing with Web Deploy (Windows) .................................................... 145 
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Working with a Staging Site 

If you have a production website and are planning major site changes, consider setting up a 
staging site ð a separate location on the server where you can conveniently update and test 
a copy of the site before putting it into production. 

We recommend that you work with a staging site in the following way: 

1. Decide where you want to host the development copy and prepare the development 
environment. You can choose to host it in the same webspace, in a separate webspace 
on the same server, or upload it to an FTP account on another server. 

If you choose the same webspace, then you first need to set up a new website by adding 
a domain or a subdomain. 

2. (Optional step.) If you set up your development environment under your account in the 
Panel and your production site has APS applications installed via the Panel (at the 
Applications tab), install the desired site applications in your development environment in 
the same subdirectory as you have on your production site. This step is optional; 
however, it will help you avoid changing manually database connection settings in the 
application scripts.  

3. Make a copy of the website and place it in the staging environment. 

4. Make copies of the databases used by the site and deploy them in the staging 
environment. 

5. Change database connection settings in the scripts to point at the databases in the 
staging environment. 

6. (Optional step.) Complete APS applications setup. Go to the Applications tab for your 
development site, locate the application in the list of installed applications, open its 
Settings screen and re-save the parameters. With this operation, the APS scripts should 
stop pointing at the production database and reconnect the application to the database 
copy. This step is needed if your production site has APS apps installed via the Panel 
and you performed Step 2 of the current instruction.  

7. Make the required changes to the site copy in the staging environment, and test them to 
make sure everything works as intended. 

8. Publish the updated site. This is done by pointing the document root of the production 
site to the staging site location. 

ü To set up a site for staging purposes: 

1. Go to the Websites & Domains tab. 

2. Click either Add New Domain or Add New Subdomain. 

We recommend that you use a subdomain for staging purposes. 

3. Proceed as described in Adding Domains (on page 63) or Adding Subdomains (on 
page 65). 

If you do not want your staging site to be accessible to the Internet users, do not register the 
newly added domain or subdomain name with a domain name registrar, or use an 

.htaccess  file (on Linux hosting) to restrict access to it. 
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ü To make a copy of website files: 

1. Go to the Websites & Domains tab. 

2. Click Website Copying (in the Advanced Operations group). 

3. If you have several websites, select the one you need and click Manage. 

4. To copy website files to the document root of an existing site: 

a. Select the option Website in the Panel. 

b. Select the destination site from the Site name menu. 

c. Specify what to do with the files that might already be present in the 
destination directory. 

5. To copy website files to an FTP account on this or another server:  

a. Select the option FTP storage. 

b. Specify the server's host name and credentials for connecting to the 
FTP account. 

c. In the FTP connection method field, leave the Active mode option selected. 
If the Panel fails to connect to the external FTP account, select the 
Passive mode option here. 

6. Click OK. 

If the site uses scripts that work with a database, copy the database to the staging 
environment: 

Á If the database is hosted on the same server managed by Panel 10, use the procedure 
below to copy it. 

Á If the database is hosted on a server which is not managed by Panel 10, use the 

mysqldump  utility to export the database, move the resulting data dump file to the 

staging environment and deploy it there. Modify the site's scripts in the staging 
environment so that they connect to the copied database. 

ü To make a copy of a database from the Panel-managed server: 

1. Go to the Websites & Domains tab > Databases > database name. 

2. Click Make a Copy. 

3. Specify the following: 

Á Destination database server. You can select the same Panel-managed database server, 
or a database server located elsewhere. For an external database server, specify the 
host name or IP address, and access credentials: the username and password of a 
database management system user authorized to create new databases and 
database tables. 

Á Destination database. You can choose to create a new database or copy the data to an 
existing database. 

Á Create a full copy. Leave this option selected to copy the database structure and all 
data. 
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4. Click OK. 

The copy of the database will be deployed on the destination server. 

5. Modify the site's scripts in the staging environment so that they connect to 
the copied database. 

When the site copy in the staging environment is updated and ready to go live, publish it as 
described in the following steps. 

ü To publish the updated site to the production environment: 

1. Go to the Websites & Domains tab. 

2. In the list of domain names, locate the address of your production site and 
click it. 

3. In the Document root box, specify the document root directory of the staging 
site. 

4. Click OK. 

This will make the updated site copy in the staging site location accessible to visitors of your 
production site address. 

Setting Up Mobile Sites 

Your service plan may include the option to create website copies optimized for viewing on 
mobile devices. The copies are hosted with external UNITY Mobile online service. 

Important : In Panel 10.4, if a customer ordered the Unity Express offering from the 
Applications tab, the system could confuse the offering with Unity One. If you faced this 
problem, we recommend that you remove the site created with Unity One and create the 
new one in order to get Unity Express. 

ü To create a copy of your website optimized for viewing on mobile devices, or 
set up a new mobile website: 

1. Go to Websites & Domains tab > Mobile Websites. 

2. Click the corresponding Create Mobile Site link. 

3. Specify an address for the mobile site. 

If your site is accessible, for example, by domain name example.com , you can type a 

prefix like mobile , and then the optimized copy of your website will be accessible by the 

address mobile.example.com .  

4. Click OK. 

5. Click Edit Site Content. A UNITY Mobile site opens in a new browser window or 
tab, and you are logged on under your account. 
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6. In the Import from the web section showing your main websiteôs domain name, 

click the button . 

7. Complete the website import wizard by following instructions presented on 
the screen.  

After the mobile site is created, you can add a link to it to your main site. 

You can now perform the following operations on the mobile site using links in Control Panel: 

Á Open site editor. 

Á Remove mobile site. 

 
 

Setting Up Custom Error Pages 

When visitors coming to a site request pages that the web server cannot find, the web server 
generates and displays a standard HTML page with an error message. You may want to 
create your own error pages and use them for your sites or individual virtual directories. The 
following error messages are the ones customized most often: 

Á 400 Bad File Request. Usually means the syntax used in the URL is incorrect (for 
example, uppercase letter should be lowercase letter; wrong punctuation marks). 

Á 401 Unauthorized. Server is looking for some encryption key from the client and is not 
getting it. Also, wrong password may have been entered. 

Á 403 Forbidden/Access denied. Similar to 401; a special permission is needed to access 
the site ï a password or username, if it is a registration issue. 

Á 404 Not Found. Server cannot find the requested file. File has either been moved or 
deleted, or the wrong URL or document name was entered. This is the most common 
error. 

Á 500 Internal Server Error. Could not retrieve the HTML document because of server 
configuration problems. 

Á 503 Service Temporarily Unavailable. The site is temporarily unavailable due to 
maintenance. 

 

In this section: 

Setting Up Custom Error Pages on Windows Servers ....................................... 117 
Setting Up Custom Error Pages on Linux Servers ............................................. 118 
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Setting Up Custom Error Pages on Windows Servers 

ü To configure the web server to show custom error pages for a site or a 
directory within a site: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Switch on support for custom error documents.  

a. Go to the Websites & Domains tab and in the list of domains, click the 
domain name you need.  

b. Select the Custom error documents checkbox. 

c. Click OK. 

3. Go to the Websites & Domains tab > Virtual Directories to see the list of error 
documents for the root web directory. Error documents located here are 
used for all web pages of the selected site. If you want to customize error 
pages for a specific virtual directory, navigate to that directory.  

4. Click Error Documents tab and click the required error document in the list. 

Á To use the default document provided by IIS for this error page, select Default in the 
Type menu. 

Á To use a custom HTML document already located in the error_docs  directory in the 

virtual host directory of the domain, select File in the Type menu and specify the file 
name in the Location field.  

Á To use a custom HTML document located in a directory other than error_docs on 

a domain, select URL in the Type menu and enter the path to your document in the 
Location field. The path should be relative to the virtual host root (that is, 

<vhosts> \ <domain> \ httpdocs ). 

For example, you have created a file forbidden_403_1.html  and saved it in the 

my_errors  directory located in the httpdocs . To use this file as an error document, 

you need to type the following path into the Location field: 

/my_errors/forbidden_403_1.html . 

Note:  You can use a connection over FTP or File Manager in the Panel to upload your 
custom error document to the server. By default, all error documents are stored in the 

/vhosts/your - domain.com/erro r_docs/  directory (located in C: \ InetPub  by 

default). 

5. Once the web server is restarted, it will start using your error documents.  
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Setting Up Custom Error Pages on Linux Servers 

ü To configure the web server to show custom error pages for a site: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Switch on support for custom error documents.  

a. Go to the Websites & Domains tab and in the list of domains, click the 
domain name you need.  

b. Select the Custom error documents checkbox. 

c. Click OK. 

3. Connect to your FTP account, and go to the error_docs  directory. 

4. Edit or replace the respective files. Be sure to preserve the correct file 
names: 

Á 400 Bad File Request - bad_request.html 

Á 401 Unauthorized - unauthorized.html 

Á 403 Forbidden/Access denied - forbidden.html 

Á 404 Not Found - not_found.html 

Á 405 Method Not Allowed - method_not_allowed.html 

Á 406 Not Acceptable - not_acceptable.html 

Á 407 Proxy Authentication Required - proxy_authentication_required.html 

Á 412 Precondition Failed - precondition_failed.html 

Á 414 Request-URI Too Long - request-uri_too_long.html 

Á 415 Unsupported Media Type - unsupported_media_type.html 

Á 500 Internal Server Error - internal_server_error.html 

Á 501 Not Implemented - not_implemented.html 

Á 502 Bad Gateway - bad_gateway.html 

Á 503 Service Temporarily Unavailable - maintenance.html 

The web server will start using your error documents in a few hours, after it is restarted. 
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Adding a Domain Forwarder 

You can set up a new domain name or reconfigure an existing domain name so that it will 
redirect visitors to another website.   

ü To add a new domain forwarder: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, select the required 
webspace in the Subscription menu at the top of the screen.    

2. Click the Websites & Domains tab. 

3. Click Add New Domain. 

4. Specify the following: 

a. In the Domain name box, type the domain name that you have 
registered with your service provider or a domain name registration 
company. 

b. Under DNS server configuration, select the option Keep master DNS zone on 
this server. 

c. Under Hosting type, select the Forwarding option. 

d. In the Destination address box, type the Internet address to which you 
want to redirect visitors. 

e. Under Forwarding type, select the preferred type of forwarding. With 
standard forwarding, a user is redirected to the site and the actual site's 
address is shown in the user's browser, so the user always knows 
that he or she is redirected to another address. With frame forwarding, 
a user is redirected to the site without knowing that the site actually 
resides at another location, therefore, frame forwarding should be 
preferred. 

5. Click OK. 

ü To reconfigure an existing domain and make it a domain forwarder: 

1. Go to Websites & Domains tab > domain name. 

2. Click the Change link next to the Hosting type field. 

3. Specify the following: 

a. Under Hosting type, select the Forwarding option. 

b. In the Destination address box, type the Internet address to which you 
want to redirect visitors. 
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c. Under Forwarding type, select the preferred type of forwarding. With 
standard forwarding, a user is redirected to the site and the actual site's 
address is shown in the user's browser, so the user always knows 
that he or she is redirected to another address. With frame forwarding, 
a user is redirected to the site without knowing that the site actually 
resides at another location, therefore, frame forwarding should be 
preferred. 

4. Click OK. 
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Using Google Services 

Using links in the Panel, you can generate code for inserting a custom Google search engine 
into your site, submit your website to Google through Webmaster Tools area, enroll in the 
AdSense program, embed YouTube videos, Google Translate service, or other Google 
products into your site. 

Google Custom Search is a search engine provided by Google. It adds search functions to 
your site and allows you to apply your website's look and feel to the search results page. It 
can be used for free on websites of individuals and non-profit organizations. Websites related 
to for-profit businesses can either use a Custom Search Engine that will show 
advertisements from Google, or purchase a subscription to Google Site Search service, 
which starts from $100 per year. To learn more about Google Site Search and current prices, 
visit http://www.google.com/sitesearch.   

Google Webmaster Tools allow webmasters to submit a website to Google and view search 
statistics. To learn more about Webmaster Tools, visit 
http://www.google.com/support/webmasters/?hl=en.  

Google AdSense allows webmasters to earn money for displaying targeted Google ads on 
their websites. To learn more about AdSense, visit 
https://www.google.com/adsense/login/en/. 

Google Web Elements allows webmasters to easily add their favorite Google products to 
websites. Embed content, such as news, maps, YouTube videos, and social conversations 
from Google Friend Connect to Web pages with simple cut-n-paste. To learn more about 
Google Web Elements, visit http://www.google.com/webelements/. 

Before you start using Google services, you need to confirm acceptance of Google Terms of 
Services, and then confirm ownership for your sites. 

ü To confirm acceptance of Google terms of service and then confirm ownership 
of your sites: 

1. Go to either the Home tab or the Websites & Domains tab, and click the Google 
Services for Websites link. 

2. Click the appropriate links in the Panel to open and read the Terms of 
Service documents. 

3. To confirm that you accept the Terms of Service, select the checkbox and 
click Confirm. 

Now you can do the following: 

Á Submit your site to Google and improve site visibility in search results by clicking Google 
Webmaster Tools. 

Á Add search functions to a site by clicking Add New Custom Search Engine. 

Á Enroll in the AdSense program by clicking Google AdSense. 

Á Embed Google products into your site by clicking Google Web Elements. 

http://www.google.com/sitesearch
http://www.google.com/support/webmasters/?hl=en
https://www.google.com/adsense/login/en/
http://www.google.com/webelements/
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ü To submit a site to Google: 

1. Go to either the Home tab or the Websites & Domains tab, and click the Google 
Services for Websites link. 

2. Click Google Webmaster Tools. 

The Google Webmaster Tools area opens in a new browser window or tab. 

3. Create a Sitemap and submit it to Google by following instructions at 
http://www.google.com/support/webmasters/bin/answer.py?hl=en&answer=1
56184.  

ü To add a custom search engine to a site: 

1. Go to either the Home tab or the Websites & Domains tab, and click the Google 
Services for Websites link. 

2. Click Custom Site Search. 

3. Click Add New Custom Search Engine. 

4. Type a search engine name and select the website you need. 

5. Select the checkbox to confirm your acceptance of Terms of Service, and 
click OK. 

The record corresponding to the new search engine is added to the Panel. 

6. Click the corresponding Get Code link, copy the generated code to the 
clipboard and paste it into the source code of your website pages. 

The other links in the list of Custom Search Engines will help you perform the following 
operations: 

Á Make Money. Connect your Custom Search Engine to a Google AdSense account. You 
make money when users click on an ad they see in your search results. If you have more 
than one Custom Search engine, all of your search engines will automatically be 
associated with the same AdSense account. 

Á Manage. Manage your Custom Search Engines. 

Á Look and Feel. Adjust the appearance of search box and search results page. 

Á Upgrade. Upgrade a Custom Search Engine to ads-free Google Site Search. 

Á Statistics. Review site search reports. 

Á Delete. Delete a Custom Search Engine. 

ü To participate in the Google AdSense program: 

1. Go to either the Home tab or the Websites & Domains tab, and click the Google 
Services for Websites link. 

2. Click Google AdSense. 

 

 

http://www.google.com/support/webmasters/bin/answer.py?hl=en&answer=156184
http://www.google.com/support/webmasters/bin/answer.py?hl=en&answer=156184
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3. Click Google AdSense account. 

4. Fill in all the required fields to create a new AdSense account, or select an 
existing account, and click OK. 

A confirmation e-mail with further instructions will be sent to your e-mail address. 

Hosting Personal Web Pages Under Your Domains 

You can host on your web server personal web pages for users who do not need their own 
domain names. These pages usually have web addresses like http://your-
domain.com/~username. 

ü To accommodate a personal web page under your domain and set up an FTP 
account for publishing: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Web Users (in the Advanced Operations group). 

3. Click Settings. 

4. If you want to allow execution of scripts embedded in personal web pages, 
select the Allow web users to use scripts checkbox. 

5. Click OK. 

The settings you have defined at the step 4 are common for all personal web pages you 
might host on your account. Therefore, you will not need to perform the steps from 3 to 5 
next time you set up a new web user account. 

6. Click Add New Web User. 

7. Specify a username and a password that will be used for accessing the 
webspace through FTP and publishing the web pages.  

You can use only lower-case alphanumeric, hyphen and underscore symbols in the 
username. The username should begin with an alphabet character. It cannot contain 
white spaces. The password cannot contain quotation marks, white space, username, 
and should be between 5 and 14 characters in length.   

8. If you want to limit the amount of disk space that can be occupied by the web 
page content, type the desired value in megabytes into the Hard disk quota 

box. 

When the specified limit is exceeded, the web page owner will not be able to add files to 
his or her webspace. 

9. Specify the programming languages that should be supported for the web 
page.  

For example, if the web page is written in PHP, select the PHP support checkbox. 
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10. If you use a Windows-based hosting account and this personal web page's 
applications need to use a file-based database (like Jet) located in the root 

of httpdocs  directory, select the Additional write/modify permissions option. Note 

that selecting this option might seriously compromise the website security. 

11. Click OK. 

Now you can tell your user the FTP account credentials, so that he or she can publish their 
web page. 

ü To change FTP password for a web page owner: 

1. Go to the Websites & Domains tab > Web Users. 

2. Click the user name you need. 

3. Type the new password into the New password and Confirm password boxes. 

4. Click OK. 

ü To allocate more disk space to the web page owner: 

1. Go to the Websites & Domains tab > Web Users. 

2. Click the user name you need. 

3. Type the amount of disk space in megabytes into the Hard disk quota box. 

4. Click OK. 

ü To remove a web page ownerôs account together with their web page: 

1. Go to the Websites & Domains tab > Web Users. 

2. Select a checkbox corresponding to the user account you want to remove 
and click Remove. 

3. Confirm removal and click OK. 
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Limiting Bandwidth and Number of Connections to 
Websites 

To avoid excessive usage of bandwidth, and protect your site from Denial Of Service attacks, 
you can limit bandwidth usage for a site and number of simultaneous connections. 

ü To limit bandwidth usage and number of connections to a site: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Bandwidth Limiting (in the Advanced Operations 
group). 

3. Select the Switch on bandwidth limiting checkbox. 

4. In the Maximum bandwidth usage (KB/S) box, specify the maximum speed, 
measured in kilobytes per second, that a website can share among all its 
connections. 

5. Select the Switch on connections limiting checkbox. 

6. In the Connections limited to box, specify the maximum number of simultaneous 
connections to the site. 

7. Click OK. 
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Working with Microsoft Frontpage Websites (Windows) 

Microsoft FrontPage deals with two kinds of websites: disk-based and server-based. In short, 
a disk-based site is a FrontPage website you create on your local hard disk and then later 
publish to the server. A server-based site is one you create and work with directly on the 
server, without the extra step of publishing. This section provides you with instructions on 
publishing only disk-based websites. 

You can publish disk-based websites either through FTP or HTTP. If your hosting server is 
running FrontPage Server Extensions, you would publish your site over HTTP. For example: 
http://your-domain.com/MyWebSite. If your hosting server supports FTP, you would publish 
to an FTP location. For example: ftp://ftp.your-domain.com/myFolder. 

After publishing, you can manage your site through FrontPage Server Extensions.  

ü To access FrontPage Server Extensions management interface: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Click the Websites & Domains tab. 

3. In the Advanced Operations group, click FrontPage.  

4. Do either of the following: 

Á To manage a site over HTTP connection, click Frontpage Webadmin. 

Á To manage a site over a secure SSL connection, if SSL support is enabled for the 
site, click Frontpage SSL Webadmin. 

5. Type your FrontPage administratorôs username and password, and click OK. 

For instructions on using FrontPage server extensions, see online help (Frontpage Webadmin > 
Help) or visit Microsoft website. 

The following FrontPage settings are changeable through the Panel: 

Á The use of Microsoft FrontPage IIS Index Server for building the full-text index of your 
website. 

Á SMTP mail server and sender's e-mail address. These options are applicable if you 
use FrontPage forms that submit information from your site by e-mail. By default, 
SMTP server specified in the domain's DNS zone is used for sending mail. If no 
SMTP server is specified in the zone, then FrontPage uses the mail service running 
on the server where the domain (site) is hosted. 

ü To change any of these settings: 

1. Go to the Websites & Domains tab > FrontPage > Settings. 

2. Make the required changes and click OK. 
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In this section: 

Publishing FrontPage Websites ......................................................................... 128 
Adding FrontPage Accounts .............................................................................. 130 
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Publishing FrontPage Websites 

ü To publish files through FTP: 

1. Open your FrontPage program. 

2. Open a FrontPage website: open File menu and select the Open Site item. 

3. Go to Remote Web site view: click the Web Site tab, and then the Remote Web Site 
button at the bottom of the window. 

4. Set up your Remote Web Site Properties: 

Á Click the Remote Web Site Properties button in the upper-right corner of the window. 

Á Select FTP as the remote Web server. 

Á In the Remote Web site location box, type your host name (for example, ftp://ftp.your-
domain.com) 

Á In the FTP directory box, type your FTP directory if your hosting company provided one. 
Leave it blank if they did not specify one. 

Á Select the Use Passive FTP check box if your computer or network is protected by a 
firewall.  

5. Click OK to connect to the remote site.  

The Remote Web site view will show files that you have in your local and remote sites. 

6. Click the Publish Web site button in the lower-right corner of the window.  

ü To publish files through HTTP on a server that supports FrontPage Server 
Extensions: 

1. Open your FrontPage program. 

2. Open a FrontPage website: open File menu and select the Open Site item. 

3. Go to Remote Web site view: click the Web Site tab, and then the Remote Web Site 
button at the bottom of the window. 

4. Click the Remote Web Site Properties button in the upper-right corner of the 
window. 

5. On the Remote Web Site tab, under Remote Web server type, click FrontPage or 
SharePoint Services. 

6. In the Remote Web site location box, type the Internet address, including the 
protocol, of the remote website that you want to publish folders and files to, 
for example, http://www.your-domain.com, or click Browse to locate the site. 
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7. Do any of the following:  

Á To use Secure Sockets Layer (SSL) for establishing a secure communications 
channel to prevent the interception of critical information, click Encryption connection 
required (SSL). To use SSL connections on your web server, the server must be 
configured with a security certificate from a recognized certificate authority. If the 
server does not support SSL, clear this check box. Otherwise, you will not be able to 
publish folders and files to the remote website. 

Á To remove specific types of code from web pages as they are being published, on the 
Optimize HTML tab, select the options you want. 

Á To change the default options for publishing, on the Publishing tab, select the options 
you want. 

8. Click OK to connect to the remote site.  

The Remote Web site view will show files that you have in your local and remote sites. 

9. Click the Publish Web site button in the lower-right corner of the window. 
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Adding FrontPage Accounts 

If you are using Microsoft FrontPage for collaborating on website content with other users, 
then you need to create additional Microsoft FrontPage accounts. 

ü To create an additional Microsoft FrontPage account: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Click the Websites & Domains tab. 

3. In the Advanced Operations group, click FrontPage.  

4. Click Add New FrontPage Account. 

5. Specify the following: 

Á Username and password for the account. 

Á Limit on disk space. If you wish to limit the amount of disk space that can be used by 
this account, clear the Unlimited check box and type the desired value in megabytes 
into the Hard disk quota box. 

When the specified limit is exceeded, the user will not be able to upload more files to 
the webspace. 

6. Click OK. 

ü To change settings for an additional Microsoft FrontPage account: 

1. Go to the Websites & Domains tab > FrontPage. 

2. Click the required account name in the list. 

3. Adjust the settings as necessary and click OK to save changes. 

ü To remove an additional Microsoft FrontPage account: 

1. Go to the Websites & Domains tab > FrontPage. 

2. Select the checkbox corresponding to the account you want to remove. 

3. Click Remove. 

4. Confirm the removal and click OK. 
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Using Virtual Directories (Windows) 

A virtual directory is a link to an existing physical directory that is present on the server's hard 
disk. Virtual directories can have a number of specific settings like custom ASP.NET 
configuration, access permissions, and protection with a password. 

Because any virtual directory can have its own settings, including customized ASP.NET 
configuration, virtual directories are very useful in setting up your web applications, especially 
those written in ASP.NET. For example, if you have three web applications that use 
ASP.NET version 1.1, and you need to install one web application that uses ASP.NET 
version 2.0, you can create a virtual directory for the ASP.NET 2.0 application, configure 
ASP.NET settings for this directory so as to enable support for version 2.0, and then 
successfully install the required application. 

Virtual directories can also be used as aliases. For example, you have a web application 
installed on your domain "example.com" in the physical directory 

"/my_data/web_apps/forum" . To access this web application, users need to type 

"example.com/my_data/web_apps/forum" , which is hard to remember and too long to 

type. You can create virtual directory called forum  in the root of your virtual host, and link 

this virtual directory to "/my_data/web_apps/forum" , so the users who want to access 

the web application will need to type "example.com/forum" , which is much shorter and 

easier to remember. 

In this section: 

Creating Virtual Directories ................................................................................ 132 
Configuring ASP.NET for Virtual Directories ...................................................... 134 
Configuring PHP for Virtual Directories .............................................................. 136 
Setting Up Access to Virtual Directories ............................................................ 137 
Changing Virtual Directory Settings ................................................................... 139 
Adding and Removing MIME Types .................................................................. 141 
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Creating Virtual Directories 

ü To create a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). You are in your web site root now. 

3. Navigate to the directory in which you want to create a new virtual directory.  

4. Click Create Virtual Directory. 

Note:  To create a physical directory instead of virtual directory, click Create Directory, 
specify the name of the directory and click OK. 

5. Specify the required parameters: 

Á Name - specify the virtual directory name. 

Á Path - specify the virtual directory path: 

Á Select the Create physical directory with the same name as virtual directory checkbox to 
automatically create a physical directory with the same name as the virtual 
directory you are creating. 

Á Clear the Create physical directory with the same name as virtual directory checkbox and 
specify the path in the field to select a  physical directory that already exists. 

Á Script source access - select this checkbox to allow users to access source code if 
either Read or Write permissions are set. Source code includes scripts in ASP 
applications. 

Á Read permission - select this checkbox to allow users to read files or directories and 
their associated properties. 

Á Write permission - select this checkbox to allow users to upload files and their 
associated properties to the virtual directory or to change content in a write-enabled 
file. Write access is allowed only if browser supports the PUT feature of the HTTP 1.1 
protocol. 

Á Directory browsing - select this checkbox to allow users to see a hypertext listing of the 
files and subdirectories in the virtual directory.  

Á Log visits - select this checkbox if you want to store the information about visits of the 
virtual directory. 

Á Create application - select this checkbox to make the directory an IIS application. The 
directory becomes logically independent from the rest of the website. 

Á Execute permissions - select the appropriate program execution level allowed for the 
virtual directory. 

Á None - allow access only to static files such as HTML or image files. 

Á Scripts only - allow running scripts only, not executables. 
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Á Scripts and Executables - remove all restrictions so that all file types can be 
executed. 

Á ASP Settings - set specific settings for ASP-based web applications. 

Á If you are using ASP-based applications that cannot operate correctly under data 
transfer restrictions currently set by IIS, clear the Defined by parent directory 
checkbox corresponding to the field you want to change and type in the required 
number. 

Á If you want to enable debugging of ASP applications on the server side, clear the 
corresponding Defined by parent directory checkbox and select the Enable ASP server-
side script debugging checkbox.  

Á If you want to enable debugging of ASP applications on the client side, clear the 
corresponding Defined by parent directory checkbox and select the Enable ASP client-
side script debugging checkbox.  

Note that if you are trying to change ASP Settings for the root virtual directory, the 
default checkbox names will be Defined by IIS instead of Defined by parent directory. 

6. Click OK. 

  

ü To remove a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Select the checkbox corresponding to the directory you want to remove. 

4. Click Remove. 

5. Confirm the removal and click OK. 
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Configuring ASP.NET for Virtual Directories 

ü To configure ASP.NET settings for a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Browse to the required directory and click a link with its name.  

4. Click ASP.NET Settings. 

5. Set up the strings that determine database connection data for ASP.NET 
applications that use databases. This option is available only for ASP.NET 
2.0.x. 

When you open the ASP.NET configuration page for the first time, sample connection 
parameters with common constructions are displayed. You can delete them and 
specify your own strings. 

Á To add a string, enter the required data into the Name and Connection Parameters input 

fields and click  next to them. 

Á To remove a string, click  next to it. 

6. Set up custom error messages that will be returned by ASP.NET 
applications: 

Á To set the custom error messages mode, select an appropriate option from the Custom 
error mode menu: 

Á On - custom error messages are enabled. 

Á Off - custom error messages are disabled and detailed errors are to be shown. 

Á RemoteOnly - custom error messages are displayed only to remote clients, and 
ASP.NET errors are shown to the local host. 

Á To add a new custom error message (which will be applied unless the Off mode was 

selected), enter the values in the Status Code and Redirect URL fields, and click . 

Á Status Code defines the HTTP status code resulting in redirection to the error page. 

Á Redirect URL defines the web address of the error page presenting information 
about the error to the client. 

Due to possible conflicts, you cannot add a new custom error message with an error 
code that already exists, but you can redefine the URL for the existing code. 

Á To remove a custom error message from the list, click  next to it. 

7. Configure compilation settings in the Compilation and Debugging field: 

Á To determine the programming language to be used as default in dynamic compilation 
files, choose an entry from the Default web page language menu. 

Á To enable compiling of retail binaries, leave the Switch on debugging checkbox empty. 
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Á To enable compiling of debug binaries, select the Switch on debugging checkbox. In this 
case, the source code fragments containing error will be shown in a diagnostic 
message. 

Note:  When running applications in debug mode, a memory and performance overhead 
occurs. We recommended that you use debugging when testing an application, and 
disable it before deploying the application into production scenario. 

8. Configure encoding settings for ASP.NET applications in the Globalization 
Settings section: 

Á To set an adopted encoding of all incoming requests, enter an encoding value into the 
Request encoding field (default is utf-8). 

Á To set an adopted encoding of all responses, enter an encoding value into the 
Response encoding field (default is utf-8). 

Á To set an encoding which must be used by default for parsing of .aspx , .asmx , and 

.asax  files, enter an encoding value into the File encoding field (default is Windows-

1252). 

Á To set a culture which must be used by default for processing incoming web requests, 
select an appropriate item from the Culture list. 

Á To set a culture which must be used by default when processing searches for a 
locale-dependent resource, select an appropriate item from the UI Culture list. 

9. Set a code access security trust level for ASP.NET applications in the Code 
Access Security field. 

CAS trust level is a security zone to which applications execution is assigned, defining 
what server resources the applications will have access to. 

Important:  When an assembly is assigned a trust level that is too low, it does not 
function correctly. For more information on the permission levels, see 
http://msdn.microsoft.com/library/en-
us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010. 

10. If you are using ASP.NET 1.1.x, then you can enable the usage of the 
auxiliary scripts in the Script Library Settings field. Specifying the script library 
settings is necessary if the validation web controls are used on your web 
site.  

Á If you need to use auxiliary scripts (specifically, scripts implementing objects for 
validating input data), provide the settings for .NET framework script library. To do so, 
enter the path beginning with the domain root directory preceded by the forward slash 
into the Path to Microsoft script library field, or click the folder icon next to the Path to 
Microsoft script library field and browse for the required location. 

Á To initiate installation of files containing the scripts to the specified location, select the 
Install checkbox. If the files already exist there, they will be rewritten. 

11. Set client session parameters in the Session Settings field: 

Á To set up the default authentication mode for applications, select an appropriate item 
from the Authentication mode list. Windows authentication mode should be selected if 
any form of IIS authentication is used. 

Á To set up the allowed session idle time, enter appropriate number minutes into the 
Session timeout field. 

http://msdn.microsoft.com/library/en-us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010
http://msdn.microsoft.com/library/en-us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010
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12. Click OK to apply all changes. 
 

Configuring PHP for Virtual Directories 

To be able to use web applications that require PHP4 or PHP5, you can select the required 
PHP version for individual virtual directories. 

ü To select PHP version for a virtual directory:  

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Browse to the required directory and click a link with its name.  

4. In the Tools group, click PHP Settings. 

5. Select the required version of PHP and click OK. 
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Setting Up Access to Virtual Directories 

ü To set access permissions for a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. To set access permissions for the current virtual directory, in the Tools group, 
click Directory Access Permissions. If you want to set permissions for a 
subdirectory located within the current directory, click the corresponding icon 

. 

4. Do the following: 

Á To make the file/folder inherit permissions from a parent folder (if it does not), select 
the checkbox Allow inheritable permissions from the parent to propagate to this object and all 
child objects. Include these with entries explicitly defined here. 

Á To make the files and folders, which are contained in this folder, inherit the folder 
permissions you define, select the checkbox Replace permission entries on all child objects 
with entries shown here that apply to child objects. 

Á To change or remove permissions from a group or a user, click the required name in 
the Group or user names list. If the group or user is not listed in the Group or user names 
list, select the required user or group name from the menu located above the list and 

click : the user/group appears in the list. Select it. 

To allow or deny permissions to a selected group/user, select the Allow or Deny 
checkboxes corresponding to permissions listed under Permissions for <user/group 
name>. If the checkboxes in Allow or Deny columns are shown in grey, it means that the 
corresponding permissions are inherited from a parent folder. 

Á To deny the permissions, which are inherited from a parent object as allowed, select 
the required checkboxes under Deny. This will override inherited permissions for this 
file/folder. 

Á To allow the permissions, which are inherited from a parent object as denied, clear the 
Allow inheritable permissions from the parent to propagate to this object and all child objects. 
Include these with entries explicitly defined here checkbox: this removes the inherited 
permissions. Then select the required checkboxes under Allow and Deny. 

Á To remove access permissions from a group or user, select the required name in the 

Group or user names list and click the icon  next to it. 

5. If you need advanced fine-tuning of permissions, click the Advanced button, 
and do the following: 

Á To create a permission entry for a group or user, select the required name from the 

Group or user names list and click . 

Á To set or change file/folder permissions for a group or user, select the required name 
from the Group or user names list, select the required Allow and Deny checkboxes 
corresponding to permissions listed under Permissions for <user/group name>. 
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Á To remove a permission entry for a group or user, select the required name from the 

Group or user names list and click . 

Á To make child objects of a folder inherit its permissions defined under Permissions for 
<user/group name>, select the Replace permission entries on all child objects with entries 
shown here that apply to child objects checkbox, and select checkboxes in the Apply to list 
which correspond to the objects that must inherit the permissions. 

6. Click OK. 

 

ü To restrict access to files and directories located within a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace. 

2. Go to the Websites & Domains tab > Virtual Directories. 

3. Navigate to the directory you want to protect and click the Protection tab. 

4. Click Protect. 

5. To specify users who will be able to access the directory, click Add User, 
specify username and password, and click OK. 

6. If you want to specify a title for the protected area that will be shown to users 
when they attempt to access the directory, click Settings, specify a title, and 
click OK. 

ü To revoke a permission to access a directory from a user: 

1. Go to the Websites & Domains tab > Virtual Directories > the Protection tab. 

2. Select the checkbox corresponding to the user's name and click Remove.  

ü To remove protection from a directory and allow the general public to see the 
directory contents without restrictions: 

1. Go to the Websites & Domains tab > Virtual Directories > the Protection tab. 

2. Click Remove Protection. 

3. Click OK to confirm removal. 
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Changing Virtual Directory Settings 

ü To change settings of a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Browse to the directory whose preferences you want to change, and click the 

corresponding icon , or click Directory Properties when inside the required 
directory. 

4. Change the settings as required: 

Á Name - specify virtual directory name. 

Á Path - specify the path to the physical directory to which the virtual directory is linked. 

Á Script source access - select this checkbox to allow users to access source code if 
either Read or Write permissions are set. Source code includes scripts in ASP 
applications. 

Á Read permission - select this checkbox to allow users to read files or directories and 
their associated properties. 

Á Write permission - select this checkbox to allow users to upload files and their 
associated properties to the virtual directory or to change content in a write-enabled 
file. Write access is allowed only if browser supports the PUT feature of the HTTP 1.1 
protocol. 

Á Directory browsing - select this checkbox to allow users to see a hypertext listing of the 
files and subdirectories in the virtual directory.  

Á Log visits - select this checkbox if you want to store the information about visits to the 
virtual directory. 

Á Create application - select this checkbox to make the web directory an IIS application. 
The directory becomes logically independent from the rest of the website. 

Á Execute permissions - select the appropriate program execution level allowed for the 
virtual directory. 

Á None - allow access only to static files such as HTML or image files. 

Á Scripts only - allow running scripts only, not executables. 

Á Scripts and Executables - remove all restrictions so that all file types can be 
executed. 

Á Allow to use parent paths - select this checkbox to allow using double period in the path 
name when referring to a folder above the current directory. This enables users to 
move up the folder tree without knowing the folder name or the whereabouts in the 
hierarchy. If the option is selected, parent path directories should not have the Execute 
permission checkbox selected in their properties, so that applications do not have the 
ability of unauthorized running of programs in the parent paths. 
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Á Allow application execution in MTA (multi-threaded apartment) mode - select this checkbox to 
allow the application execution in multi-threaded apartment (MTA) mode. Otherwise, 
the application will run in a single-threaded apartment (STA) mode. Using STA, each 
application pool is executed in a dedicated process. With MTA, several concurrent 
application pools are executed in one thread which can increase performance in some 
cases. 

Á Use default documents - select this checkbox to allow the use of default documents for 
the current directory. The default document is sent when users access the directory 
on the web without a specific file name (for example, using http://www.example.com 
as opposed to http://www.example.com/index.html). If this checkbox is cleared and 
the Directory browsing checkbox is selected, the web server returns a folder listing. If 
this checkbox is cleared and the Directory browsing checkbox is cleared as well, the 
web server returns an "Access Forbidden" error message. 

Á Default documents search order - specifies the order in which IIS searches for the default 
document, sending user the first available file it finds. If no match is found, IIS 
behaves as in the cases when the default content page is disabled. 

Á Allow anonymous access - select this checkbox if you want to make the directory public 
so that the Internet users could access it without authentication. 

Á Require SSL - select this checkbox to enable access to the folder only via SSL-
encrypted connections. 

Á ASP Settings - set specific settings for ASP-based web applications. 

Á If you are using ASP-based applications that cannot operate correctly under data 
transfer restrictions set by IIS, clear the Defined by parent directory checkbox 
corresponding to the field you want to change and type in the required number. 

Á If you want to enable debugging of ASP applications on the server side, clear the 
corresponding Defined by parent directory checkbox and select the Enable ASP server-
side script debugging checkbox.  

Á If you want to enable debugging of ASP applications on the client side, clear the 
corresponding Defined by parent directory checkbox and select the Enable ASP client-
side script debugging checkbox.  

Note that if you are trying to change ASP Settings for the root directory, the default 
checkbox names will be Defined by IIS instead of Defined by parent directory. 

5. Click OK to save changes. 
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Adding and Removing MIME Types 

Multipurpose Internet Mail Exchange (MIME) types instruct a web browser or mail application 
how to handle files received from a server. For example, when a web browser requests an 
item on a server, it also requests the MIME type of the object. Some MIME types, like 
graphics, can be displayed inside the browser. Others, such as word processing documents, 
require an external application to be displayed. 

When a web server delivers a web page to a client web browser, it also sends the MIME type 
of the data it is sending. If there is an attached or embedded file in a specific format, IIS also 
tells the client application the MIME type of the embedded or attached file. The client 
application then knows how to process or display the data being received from IIS. 

IIS can only operate files of registered MIME types. These types could be defined both on 
the global IIS level and on the website or virtual directory level. Globally-defined MIME types 
are inherited by all websites and virtual directories while ones defined on the website main or 
virtual directory level are used only for the area where they are defined. Otherwise, if the web 
server receives request for a file with unregistered MIME type, it returns the 404.3 (Not 
Found) error. 

ü To add a new MIME type for a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Navigate to the required virtual directory and click the corresponding link 
with its name. 

4. Click the MIME Types tab. 

5. Click Add MIME Type. 

6. Specify the following: 

Á Type the file name extension in the Extension field. File name extension should begin 
with a dot (.), or a wildcard (*) to serve all files regardless of file name extension. 

Á Specify the file content type in the Content field.  

Á You can either select the appropriate value from the list or define a new content type. 
To do this, select Custom and enter the content type in the input box provided. 

7. Click OK to finish the creation. 

ü To edit a MIME type for a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     
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2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Navigate to the required virtual directory and click the corresponding link 
with its name. 

4. Select the MIME Types tab. 

5. Select the required MIME type in the list. 

Á Type the file name extension in the Extension field. File name extension should begin 
with a dot (.), or a wildcard (*) to serve all files regardless of file name extension. 

Á Specify the file content type in the Content field.  

Á You can either select the appropriate value from the list or define a new content type. 
To do this, select Custom and enter the content type in the input box provided. 

6. Click OK to save changes. 

ü To remove a MIME type for a virtual directory: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations 
group). 

3. Navigate to the required virtual directory and click the corresponding link 
with its name. 

4. Select the MIME Types tab. 

5. Select the checkbox corresponding to the MIME type you want to remove.  

6. Click Remove. 

7. Confirm removal and click OK. 
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Setting Up IIS Application Pool (Windows) 

IIS Application Pool contains all web applications installed on your sites. If your service 
provider allocated a dedicated IIS application pool for your sites, then you can have a level of 
isolation between web applications used by your sites and web applications used by other 
hosting users who host their websites on the same server. Because each application pool 
runs independently, errors in one application pool will not affect the applications running in 
other application pools. 

Once you switch on the application pool, all web applications on your websites will be using 
it. 

ü To switch on dedicated IIS application pool for your websites: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription menu at 
the top of the screen, select the required webspace.     

2. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites 
(in the Advanced Operations group). 

3. Click Switch On. 

4. To limit the amount of CPU resources that this application pool can use, 
select the Switch on CPU monitoring checkbox and type a number in percents 
into the Maximum CPU use (%) box. 

5. Click OK. 

ü To stop all applications running in the application pool: 

1. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites 
(in the Advanced Operations group). 

2. Click Stop. 

ü To start all applications in the application pool: 

1. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites 
(in the Advanced Operations group). 

2. Click Start. 

If you run applications that are known to have memory leaks or become unstable after 
working for a long time, then you might need to restart them from time to time. 

ü To restart all applications running in the application pool: 

1. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites 
(in the Advanced Operations group). 

2. Click Recycle. 
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ü To switch off the dedicated IIS application pool for your websites: 

1. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites 
(in the Advanced Operations group). 

2. Click Switch Off. 
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Web Publishing with Web Deploy (Windows) 

Web Deploy (Web Deployment Tool) is a Microsoft tool that significantly simplifies the 
migration, management, and deployment of your websites and web applications. More 
precisely, you can write a code in your local environment, for example, in Visual Studio® 
(IDE) or WebMatrix® (development tool), and then periodically publish the updates to your 
production server by means of Web Deploy.  

Differences Between Visual Studio® an d WebMatrix®  

If you are looking for an environment that lets you seamlessly publish code updates to your 
account, it is likely you will choose between Visual Studio® and WebMatrix®.  

Á Visual Studio® is a classic integrated development environment (IDE) for writing .NET 
applications and sites of any scale. It has a variety of plugins that extend its basic 
functionality. However, to run and debug your applications in Visual Studio®, you should 
perform extra configuration (such as preparing a database and environment settings). 
Thus, this tool is more suitable for advanced users. 

Á With WebMatrix® you have a built-in set of application templates and even working 
applications (WordPress, Joomla) right out of the box. If you wish to instantly add an app 
to your customer account or run it, you just need to select the app from the list and 
WebMatrix® will transparently configure it for you. Moreover, you can promptly find and 
subscribe to a hosting plan for your project without leaving WebMatrix®. Summing up, 
this tool is suitable even for novice users and encourages fast development by using 
ready-to-run applications and templates. The details on how to install and use 
WebMatrix® are available at http://www.microsoft.com/web/webmatrix/. 

It is up to you to decide which is better for your project. 

How to Configure Web Publishing in Visual Studio® and WebMatrix®  

Generally, to set up web publishing in your environment, you should open the publishing 
settings and specify the IP address of your customer account and the username and 
password you use to log in to the Control Panel. 

In WebMatrix®, the publishing settings are found in Home > Publish. You can provide these 
settings either manually or as an XML file; Panel automatically generates it. To download the 
file for a certain website, click on a corresponding Download link in Websites & Domains > 
Advanced Operations > Web Deploy Publishing Settings. The settings are only available if Web 
Deploy is installed on the Panel server and is running. If you do not see these settings, 
contact your hosting provider. 

For a step-by-step instruction on how to set up web publishing in WebMatrix®, see 
http://www.microsoft.com/web/post/how-to-publish-a-web-application-using-webmatrix. 

To learn more about publication settings in Visual Studio®, see 
http://msdn.microsoft.com/en-us/library/7z83t16a.aspx. 

http://www.microsoft.com/web/webmatrix/
http://www.microsoft.com/web/post/how-to-publish-a-web-application-using-webmatrix
http://msdn.microsoft.com/en-us/library/7z83t16a.aspx
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Note : You can decide whether to transfer updates securely to your customer account by 
selecting the corresponding option in the publication settings. If your hosting provider does 
not have a valid SSL certificate, you will receive an error message on attempting publication. 
To resolve the problem, contact your hosting provider for assistance or avoid using the 
secure connection. 

Securing WebMatrix® Publishing Settings  

An XML file which keeps WebMatrix® publishing settings may include the password to a 
customer's account. Administrators have the option to configure Panel so that it excludes 
these passwords from the XML files. If the administrators wish to improve the security of the 
system and prevent stealing the passwords, they can specify to exclude the password from 
the XML file. The customers then will have to enter the password directly in WebMatrix®. 
The option is available on the Tools & Settings > Server Settings page. 



 

  
 

Parallels Web Presence Builder (also referred to as editor) is a visual editor that lets 
small business owners and individuals create their websites quickly and easily. With 
Web Presence Builder, you do not have to write code or configure servers to start a 
blog, open an online store, or set up any other form of website. You just add the 
content blocks that comprise your site (text, image gallery, online store) by dragging 
them to pages, fill these blocks with your content, and publish the result. Thatôs it! 

Start Creating a Website  

When you start working on your website, you do not have to write text, search for the 
images, and adjust the site look. Just choose a topic that best suits your website, and 
Web Presence Builder will generate a site template that already contains a set of 
pages, pictures, and text relevant to the selected topic. Each time Web Presence 
Builder generates a website, it uses a random set of element designs, so you can be 
sure that your website design is never repeated.  

Once you have selected the topic, you will be prompted to enter some additional 
information that Web Presence Builder will add to the website's pages, for example, 
your phone number, which will appear on the Contact Us page. 

For more details on how to start creating your website, see the section Creating a 
Website (on page 151). 

Import Websites Created in SiteBuilder 4.5  

If you already have a website created with SiteBuilder 4.5 and hosted elsewhere, you 
can import your website to your new customer account. Learn how to move your 
SiteBuilder 4.5 website to Web Presence Builder in the section Importing Sites from 
SiteBuilder 4.5 (on page 152). 

Fill the Site with Content  

As soon as Web Presence Builder creates your website, you can fill it with your 
content. Your main editing tool is the Web Presence Builder's main menu. You can do 
the following by using the menu: 

Á Change the structure of your site: Add or remove pages. 

Á Edit the website design: Change colors and layout. 

Á Fill the site with your content: Remove unused predefined content and add your 
own elements: 

Á Text 

Á Images and image galleries 
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Á Videos 

Á Scripts 

Á Blogs 

Á Search boxes  

Á Other elements 

Á Let your visitors share the information in your website in social media such as 
Facebook or Twitter: Add the corresponding buttons to the pages of your site. 

To learn more about actions available to you in the editor, refer to the section Getting 
Familiar With the Web Presence Builder Editor (on page 149). 

Find instructions on managing website look and content in the section Editing a Website 
(on page 154). 

Make the Site Available on the Internet  

After you finish editing the website, make it available on the Internet. To let people see 
your site at your domain name, publish the website by clicking the corresponding 
button in the main menu. When you click this link, Web Presence Builder generates the 
static pages and scripts that comprise your website and places them in the appropriate 
locations on the server so that people see them when they enter your domain name in 
their browsers. Learn more about publishing websites in the section Publishing a Website 
to the Internet (on page 185). 

You can also attract more visitors to your sites by placing a site copy on Facebook - a 
popular social network. Refer to the section Publishing a Website Copy to Facebook (on 
page 186) for detailed instructions on how to do this. 

In this chapter: 

Getting Familiar With Web Presence Builder ..................................................... 149 
Creating a Website ............................................................................................ 151 
Importing Sites from SiteBuilder 4.5 .................................................................. 152 
Editing Websites ............................................................................................... 154 
Saving and Loading Copies of a Website .......................................................... 183 
Publishing a Website to the Internet .................................................................. 185 
Publishing a Website Copy to Facebook ........................................................... 186 
Viewing Site Visits Statistics, Comments, and New Orders on the Dashboard .. 188 
Deleting Websites ............................................................................................. 190 
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Getting Familiar With Web Presence Builder 

The interface of the Web Presence Builder editor has two main parts: your website and the 
main menu. 

A website consists of a number of elements, or modules. Each module can be edited 
separately. Here we will familiarize you with the basic principles of website module editing. 
These are similar for all modules. 

When adding a module to a page, you can choose whether it should be shown only on the 
current page (page-specific module) or on all pages of the site (site-wide module). The only 
exceptions are the Search, Advertisement, Site Logo, Navigation, and Breadcrumbs modules: 
when you add them, they are placed on all pages of the website. 

To place a module only on the current page, select the module under the Modules tab, and 
drag it to any of the areas marked with the text PAGE-SPECIFIC AREA. Such areas are located 
within the main content block and near the top of each sidebar. 

To place a module on all pages of the website, select the module under the Modules tab, and 
drag it to any of the areas marked with the text SITE-WIDE AREA. Such areas are located 
above and below the main content block, in sidebars, header, and footer. 

To locate or edit a website module, hover the mouse pointer over the part of the website you 
want to change. A dotted frame will appear around the module. A control panel prompting 
you to move, edit, or remove the module will appear next to the dotted frame. 

The dotted frame around page-specific modules is green, but around site-wide modules it is 
blue. 

The editor's main menu offers website editing options grouped under five tabs: 

Á Modules. Here you can choose necessary modules and drag them to any place on the 
page to fill your website with content.  

Á Design. Here you can select the layout and general color scheme for your website, 
change colors of different elements, and select fonts and border style. 

Á Pages. Here you can add and delete pages, rename them, edit page meta information 
such as descriptions and keywords for use by search engines, or mark a page as hidden 
so that your visitors cannot access it from the site menu. 

Á Documents. Here you can upload documents, images, and other files in various formats to 
your hosting account. You can then easily insert links to these documents into your 
website pages. Or, you can just keep the files on the hosting account for your own needs. 

Á Settings. Here you can edit your website name, description and keywords for search 
engines, upload a site icon (favicon), optimize the ranking of your website in search 
engine results, connect your site to Google Analytics, and add a copy of your site to a 
Facebook page. 
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From the main menu, you can also do the following: 

Á Access the Dashboard to perform the following operations: 

Á View statistics on website visits. The statistics are provided by Google Analytics. 

Á View new comments left by site visitors on your website pages. The commenting 
functionality is provided by Disqus. 

Á View new orders from customers visiting your online stores. The online store 
functionality is provided by Ecwid. 

Á Save and load copies of your website by using the Save and Revert options. 

Á Access Web Presence Builder Getting Started video tutorial, view Userõs Guide, or send us your 
feedback. To do this, select the corresponding option from the Help menu. 

Á Publish your website by using the Publish button. 

Á Discard any changes made to a site and start creating the site anew by selecting More > 
Start Over. This does not delete your already published site copy. 

Á Delete a current website draft from the editor by selecting More > Remove Site. This does 
not delete your already published site copy. 

You can drag the main menu to any place on the page for your convenience, or minimize it. 

You can also access all options of the main menu in the context menu at any place on the 
page. To open the context menu, click the right mouse button. 
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Creating a Website 

To minimize your efforts when creating a website, Web Presence Builder offers you a set of 
predefined website topics. When you start creating a website, choose a topic that is most 
appropriate for you, and Web Presence Builder will generate a website with the content 
relevant to this topic. For example, it will include a price list template for a retail store or an 
image gallery for an artist's site. If you cannot find a suitable topic, you can contact your 
service provider to ask them to create the corresponding template and add it to the list of 
available topics. 

When you start creating a website, Web Presence Builder also prompts you to provide 
information about yourself or your company. Web Presence Builder will automatically add 
this information to certain pages as appropriate, for example, to the About Us and Contact 
Us pages. 

Note:  Web Presence Builder will not store or use the information you provide anywhere 
except for your website pages. You can change or remove this information later. 

ü To start creating a website in Web Presence Builder: 

1. Launch Web Presence Builder by clicking the corresponding link: 

Á If you have only one domain name in the subscription, click Launch Web Presence 
Builder on the Home tab or the Websites & Domains tab. 

Á If you have several domain names, click the corresponding link Edit in Web Presence 
Builder in the list of available domain names. 

2. Select a website topic.  

3. Type the website name and select website language. 

4. Provide the information to pre-fill your website. 

5. Click Submit and Create Site. 
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Importing Sites from SiteBuilder 4.5 

If you have a site created with SiteBuilder 4.5, you can import it to Web Presence Builder. 

Note:  The import of sites from earlier versions of SiteBuilder or other content management 
systems is not supported. 

If your site was created with an earlier version of SiteBuilder (4.4 or earlier), and you would 
like to transfer your site, you can do the following: 

Á Contact your hosting provider and ask them to upgrade your account to the latest version 
of Web Presence Builder. 

Á Transfer your site manually by copying and pasting the content. 

During site import, most parts of the site structure and content can be transferred 
successfully. However, we cannot guarantee that all content will be transferred. 

In most cases, the following elements are imported successfully: 

Á Site map. 

Á Static pages, including links and images in text modules. Note that text blocks exceeding 
30 kilobytes may be cut; therefore, some parts of the text may be missing.   

Á Banner (if it is not a custom image). 

Á Slogan, site title. 

Á Logo (if it is not a custom image). 

Á Footer text. 

Á Meta info (keywords, description). 

The other modules can be imported only as text widgets with static content, links and 
images. Buttons will not work. The image gallery structure can be imported without images. 

ü To import a site from SiteBuilder 4.5: 

1. Open the Web Presence Builder editor, and on the topic selection screen, 
click Import Site from SiteBuilder 4.5. 

2. Type the Internet address (domain name) of the site that you want to import. 

For example: http://example.com . 

3. Select the checkbox to confirm that you are aware of possible import issues, 
and click Import Site. 

4. After the site is imported, review and edit it as required (on page 154). You 
can compare the imported site version with your original site and add the 
missing information manually. 

5. When finished with editing, publish the site to your customer account (on 
page 185).  



 

 Building Websites with Web Presence Builder 153 

 

If you are publishing your new site to the same webspace on which your site created with 
SiteBuilder 4.5 was hosted, the old site will be overwritten. 
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Editing Websites 

In Web Presence Builder, you can change almost any element of your website. Most of the 
elements are changed in place - you open a page where the element is used, edit it and see 
the result right away. Site-wide elements, such as Search block and Advertisement block are 
changed in one place but the changes are applied to each page of your website. 

Note:  If you are using Internet Explorer, we strongly recommend that you avoid using 
browser zoom to change the size of text displayed in your browser window. Please note that 
websites in Web Presence Builder will perform and look best at normal zoom (100%). 

In this section: 

Structure: Pages and Navigation ....................................................................... 154 
Design: Layout, Styles, Color Scheme, and Header .......................................... 157 
Content: Text, Tables, Images, Video, Forms, and Scripts ................................ 163 
Settings and Tools for Webmasters ................................................................... 180 
 
 

Structure: Pages and Navigation 

This section describes how to add pages to a site, set their location in the site structure, and 
add navigation links. 

In this section: 

Adding and Removing Pages ............................................................................ 155 
Adding and Removing Navigation Links ............................................................ 156 
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Adding and Removing Pages 

Your site can have two levels of nested pages. 

ü To add a new page to your website: 

1. Go to the Pages tab. 

2. Click Add page. The new page appears highlighted in green. 

3. Position the new page by dragging it to the right place or by clicking the 
arrows. 

4. Specify the page title. 

5. Give a concise description of the page content that will be displayed on 
search engine results pages and the keywords by which the page will be 
found by search engines. 

Note:  Page name and Page link name are required fields. Description and Keywords are 
optional fields. If you specify keywords for a page, they should be separated by commas 
without white spaces. 

6. If you want to make the page invisible to your website visitors, select the 
Hidden page checkbox. 

7. If you want to restrict access to the page with password authentication, 
select the Protected page checkbox and specify a username and a password. 

8. Click OK to save changes. 

ü To change the location or properties of a page: 

1. Go to the Pages tab. 

2. Select the page you want to edit. 

3. Change the page position by dragging it to the right place or by clicking the 
arrows. 

4. Edit the page title. 

5. Edit or remove the concise description of the page content that will be 
displayed on search engine results pages and the keywords by which the 
page will be found by search engines. 

Note:  Page name and Page link name are required fields. Description and Keywords are 
optional fields. If you specify keywords for a page, they should be separated by commas 
without white spaces. 

6. If you want to make the page invisible to your website visitors, select the 
Hidden page checkbox. 
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7. If you want to restrict access to the page with password authentication, 
select the Protected page checkbox and specify a username and a password. 

8. Click OK to save changes. 

ü To delete a page from your website: 

1. Go to the Pages tab. 

2. Select the page you want to delete. 

3. Click Delete page. 

4. Click OK to save changes. 

 
 

Adding and Removing Navigation Links 

By default, a horizontal navigation bar with links to site pages is inserted below or above the 
header of your site. It is automatically updated every time you add, change, move, or remove 
pages from the site. 

If you use sidebars on the site, then the horizontal bar under the header includes only links to 
the first level pages, and the sidebars show the links of the second and third levels. 

You can move navigation blocks by dragging them to other areas of the site. 

For each navigation block, you can specify what levels of pages should be included in the 
menu, change menu alignment (for example, show it in the middle of the page instead of the 
default alignment to the left), and change the color, style, and size of the font used for the 
links. To change any of these settings, place the mouse pointer over a navigation block and 
click Edit. 

If you occasionally remove a navigation block, you can re-insert it. To do this, go to the 
Modules tab, select Navigation, and drag the block to the area on the page where you want to 
add it. The navigation block will be inserted into all pages of the website. 

For the convenience of your site visitors, you might also want to add breadcrumb navigation 
blocks. Breadcrumb navigation is a chain of links that represents the user's path from the 
site's main page to a current page. To add a breadcrumb navigation block, go to the Modules 
tab, select Breadcrumbs, and drag the module to the area on the page where you want to add 
it. The navigation block will be inserted into all pages of the website. 
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Design: Layout, Styles, Color Scheme, and Header 

This section describes how to change the layout, color scheme, and header elements of the 
site. 

In this section: 

Changing Your Website Layout ......................................................................... 158 
Selecting Website Colors, Fonts, and Styles for Borders and Corners .............. 160 
Changing the Website Header Elements ........................................................... 162 
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Changing Your Website Layout 

The layout of your site can consist of the following elements: 

Á Header. This is the topmost area where a banner image and a company logo are usually 
placed. You can do the following to the header: 

Á Move the banner image and logo from the header area to any place on the page. 

Á Reduce the header height to 25 pixels by removing all elements from it. 

Á Change the header width from the default size to 100 percent, so that it is expanded 
to fit the page width. 

Á Content area. This is the main part of a webpage where most of the content is placed. You 
can do the following to the content area: 

Á Adjust the height of the content area. 

Á Divide the content area into several columns. You can do this by dragging new 
modules to the left or right edge of the content area and inserting them. 

Á Change location of the columns in the content area by moving the content to the left 
or to the right.  

Á Sidebars. These are vertical columns that can be used for placing all kinds of modules, 
site-wide and page-specific. You can do the following to sidebars: 

Á Add one sidebar and place it to the left or to the right of the content area. 

Á Add two sidebars. They will be placed to the left and to the right of the content area. 

Á Adjust the height and width of the sidebars. 

Á Move the sidebars to the top of the page and place them to the left or to the right of 
the header area.  

Á Switch places of the sidebars. 

Á Footer. This is the lowest area where the company name, contact information, or a 
copyright notice are usually placed. You can do the following to the footer: 

Á Reduce the footer height to 25 pixels by removing all elements from it. 

Á Change the footer width from the default size to 100 percent, so that it is expanded to 
fit the page width. 

ü To change the layout of your site: 

1. Go to the Design tab > Layout tab. 

2. Select the number of sidebars: Under Sidebars, select No, One, or Two. 

3. Select the locations of sidebars: 

Á To move a sidebar to another side of your website, or to switch places of sidebars (if 
you have two sidebars on your site), click Switch sidebars. 

Á To move the sidebars to the top of the page, click them in the layout model. 
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4. Set the size of page elements: 

Á To set the total width of the website pages, under Website width, select either of the 
following: 

Á Fixed layout: your website will be of a specific size regardless of the size of the 
browser window viewing the page. In this case, specify your website width in 
pixels. 

Á Liquid layout: based on percentages of the current browser window's size. In this 
case, specify your website width as a percentage of the browser window's size.  

Á To change the width of the header and footer areas to fit the page width, click the 
corresponding elements in the layout model. 

Á Under Minimal column height in pixels, specify the height of the main content area and 
each sidebar, if you have chosen to use them. 

This value shows the height of your website elements without content. When you add 
content to the main content area and to the sidebars, they will stretch in height to fit 
the content. 

Á To ensure that the sidebars and the content area are vertically aligned, select the 
checkbox Stretch the sidebars and the content area down to the footer. 

Á If you use one or two sidebars, under Sidebar width in pixels, specify the width of each 
sidebar. The size of the main content area will be determined automatically. 

Á Under Margin sizes in pixels, specify the size of vertical and horizontal margins. A 
margin is the space between the edges of neighboring elements. 

5. Click OK to save changes. 
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Selecting Website Colors, Fonts, and Styles for Borders and 
Corners 

The general color scheme, or styleset, of your website comprises four colors. Each color is 
used for several website elements at once. You can adjust colors of individual elements on 
the Design tab > Colors tab. 

ü To select the general color scheme for your website: 

1. Go to the Design tab > Scheme tab. 

2. Select the color scheme, or styleset, of your website in the menu. 

You will see the four colors used in the color scheme of your website. 

3. To adjust one of the colors of your website color scheme, click the respective 
color field and change the hexadecimal color code value or select a color 
with the color picker. 

Note:  These changes will override any previous changes of individual elements' colors 

made on the Colors tab. 

4. Click OK to save changes. 

ü To select colors of individual website elements: 

1. Go to the Design tab > Colors tab. 

2. Select the website element in the menu. 

3. Adjust the element's background color by clicking the background color field 
and editing the hexadecimal color code value or by selecting a color with the 
color picker. 

4. If you want to use gradient filling, select the Gradient option, and then select 
the pattern from the menu.  

5. For an element with text, adjust font colors by clicking the respective color 
field and editing the hexadecimal color code value or by selecting a color 
with the color picker. 

Note:  Modifying the styleset on the Scheme tab will override the changes made on the 

Color tab. 

6. Click OK to save changes. 

ü To select fonts for headings and body text of your website: 

1. Go to the Design tab > Fonts tab. 

2. For each font type, select the font face and size in the menus. 
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3. For headings, select the font decoration. You can use bold (the B icon) and 
italics (the I icon).  

Note:  The settings made here define only general rules for your website fonts. You can 
always adjust fonts of individual elements in place. 

4. Click OK to save changes. 

ü To select the shape of corners (square or rounded) for website elements: 

1. Go to the Design tab > Corners tab. 

2. In the Page area menu, select the element whose corners you want to change. 

3. Do any of the following: 

Á To make rounded corners, select the corresponding checkboxes. 

Á To make square corners, clear the corresponding checkboxes. 

4. Click OK to save changes.  

ü To select borders for website elements: 

1. Go to the Design tab > Borders tab. 

2. Select the border type for elements inside your website from the Internal 
containers border menu. 

3. Select the elements that will have the border. 

Note:  You can select only one internal border type for all elements on your website, but 

you can select whether this border will be used for certain elements. 

4. Select the external border for your website from the External site border menu.  

5. Click OK to save changes. 
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Changing the Website Header Elements 

The site header consists of the following elements: 

Á Banner. You can do the following to the banner: 

Á Upload your own banner image. 

Á Select and apply a banner from the Web Presence Builder library. 

Á Remove the banner and use a background filled with a color or images. 

Á Remove the banner and all other elements from the header area to reduce its height 
to 25 pixels. 

Á Move the banner to the content area and insert it into a specific page or into all pages 
of the website. 

Note:  You can use only one banner per site. If you choose to insert it into a specific 
page, you will not be able to add it to other pages of the website. For this reason, 
we recommend that you place it into the site-wide areas. 

Á Logo image. You can do the following to the logo: 

Á Upload your own logo image. 

Á Move the logo from the header area to other parts of webpages, such as sidebars and 
content area.  

Á Insert any number of logo images into the site-wide areas. 

Á Remove the logo. 

Á Site name. This usually contains a company name or a brief site description like, for 
example, "John Doe's Recipes". 

Á Site slogan. This usually includes a description of your site or a company slogan. 

ü To change the banner image or other elements of the header (logo, site name, 
or slogan): 

1. Click the banner image. 

2. Do any of the following: 

Á To use an image from the Web Presence Builder's library, select the option Selection 
from our library, and then select an image from the Image list menu. To help you find an 
appropriate image, select the Recommended option or type a keyword in the input box. 

Á To use your own image, select the option Selection from own file, click Browse, and 
select the image you want to use. You should use only images in the GIF, JPEG, and 
PNG formats, preferably not wider than 900 pixels. 

Á To remove an image, select the option no image and specify the height of the header 
block in pixels. 

3. If you want to scale a banner to fit the header area, select the Fit image size 
checkbox. 

4. Under Show banner elements, select the checkboxes corresponding to the 
elements that you want to show in the header. 
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5. If you want to remove a logo image or upload your own logo, click the logo 
image. 

6. If you want to change the site name or slogan, click the corresponding fields 
on the header and change them as you want. 

To make it easier to see the site name or slogan, select the Outline checkbox. This adds a 
black or white outline around text, one pixel in width. If the font color in site title or slogan 
is black, then the outline is white, and vice versa. 

Note that you can freely move the blocks with website name, description, and logo within 
the header area. 

If you occasionally remove the banner, you can re-insert it. 

ü To insert a banner: 

Go to the Modules tab, select Banner, and drag the module to any of the site-wide areas on the 
page where you want to add it. 

ü To insert a logo image: 

Go to the Modules tab, select Site Logo, and drag the module to any of the site-wide areas on 
the page where you want to add it. You can upload a new logo image and align it to the left, 
center, or right. 

Content: Text, Tables, Images, Video, Forms, and Scripts 

This section describes how to fill your site with content and enhance it with useful functions 
provided by the editor's modules. 

When adding a module to a page, you can choose whether it should be shown only on the 
current page (page-specific module) or on all pages of the site (site-wide module). The only 
exceptions are the Search, Advertisement, Site Logo, Navigation, and Breadcrumbs modules: 
when you add them, they are placed on all pages of the website. 

Á To place a module only on the current page, select the module under the Modules tab, 
and drag it to any of the areas marked with the text PAGE-SPECIFIC AREA. Such areas are 
located within the main content block and near the top of each sidebar. 

To divide the content area into columns and insert a module into one of them, drag the 
module to the left or right edge of the content area and then insert it. Note that sidebar 
areas cannot be divided into columns. 

Á To place a module on all pages of the website, select the module under the Modules tab, 
and drag it to any of the areas marked with the text SITE-WIDE AREA. Such areas are 
located above and below the main content block, in sidebars, header, and footer. 
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Text, Tables, Hyperlinks, and Images 

Before you start working on website content, we suggest that you select the appropriate 
website language in Settings tab > Languages > Website language menu. 

The website language is a site-wide setting that defines the language in which you will be 
adding content to your website. It affects the following: 

Á The language in which certain website elements (in particular those provided by third-
party services), such as Google Search and navigation buttons in image galleries, will be 
shown. Note that not all third-party services and modules provided by the editor support 
all available languages. 

Á The direction in which you will type text in the editor (from left to right or from right to left). 
If you select a right-to-left language, your website content and design will be RTL-
enabled. 

Note:  Changing a website language does not reload the currently selected website topic in a 
different language. The topic language will remain unchanged, however, the text orientation 
will change. 

ü To add text, lists, tables, or images to a page: 

1. Go to the Modules tab, select Text & Images, and drag the module to the page: 

Á To add a block with text and images to the current page, drag the module to any of 
the areas marked with the text PAGE-SPECIFIC AREA. Such areas are located within the 
main content block and near the top of each sidebar. 

To divide the content area into columns and insert a block into one of them, drag the 
module to the left or right edge of the content area and then insert it. Note that sidebar 
areas cannot be divided into columns. 

Á To add a block with text and images to all pages of the site, drag the module to any of 
the areas marked with the text SITE-WIDE AREA. Such areas are located above and 
below the main content block, in sidebars, header, and footer. 

2. Type the text on the screen and use the icons on the module's toolbar to 
format the text, add tables, hyperlinks, and images. 

The toolbar of the Text & Images module provides access to the following tools and functions. 
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1. Move the text and image block within the webpage. 

2. Remove the block with its contents. 

3. Save changes. 

4. Cancel the changes made. 

5. Move the toolbar. 

6. Select the paragraph style and font face. 

7. Select the font size. 

8. Select the font style: bold, italics, underlined, and strikethrough. 

9. Select the text and background colors. 

10. Select text alignment: left, center, right, or justified (aligned to both the left and right 
margins with added extra spaces between words). 

11. Increase and decrease the indent level of the paragraph. 

12. Start a numbered or bulleted list. 

13. Insert a table and specify the number of rows and columns. 

After you insert a table, a number of additional icons become accessible from the toolbar. 
Use them to change the properties of the table rows and cells, to insert and remove rows 
and columns, or to split and merge table cells. 

14. Insert symbols that are not on your keyboard, such as copyright and trade mark signs, 
and other Unicode symbols. 

15. Insert a horizontal line. 

16. Edit the HTML source code of the page. 

17. Undo and redo changes. 

18. Add and remove hyperlinks to the pages of your website or external resources. Insert 
HTML anchors into particular sections of webpages so that you can link to them from 
other pages of your site. 

19. Insert an image, adjust its size, specify an alternative text, and text wrapping. In browsers 
that do not support or are configured to not show images, the alternative text is shown 
instead of images.    

If you want to insert many pictures into a single page, consider using the Image Gallery module 
instead of the Text & Images module. With Image Gallery, you can upload pictures from your 
local computer or use pictures published to the Picasa Web Albums photo sharing service. 

ü To add an image gallery to your site and upload pictures: 

1. Go to the Modules tab, select Image Gallery, and drag the module to the page. 

2. In module settings, on the Image Storage tab, select where you want to keep 
pictures: 

Á If you do not have a Picasa Web Albums account that you would like to use, leave the 
Web Presence Builder option selected. All images you use on your site will be kept on 
your customer account. 
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Á If you have an account in Picasa Web Albums and want to use pictures that you store 
there on your site, do the following: 

a. Select the Picasa option, click the link on the Image Storage tab to sign 
in to Google, and grant access to your albums from Web Presence 
Builder. 

b. Select the album whose pictures you want to use or click Create Album 
to create a new album. 

c. If you want Web Presence Builder to remove images from Picasa 
Web Albums when you remove them from the gallery, select the 
checkbox Delete images when I remove them from gallery. 

When you upload images to an image gallery through the Web Presence Builder 
editor, they are automatically copied to your Picasa Web Albums account. When you 
remove images from the gallery, they are removed from Picasa Web Albums only if 
you have selected the option Delete images when I remove them from gallery. 

3. (Optional step.) If you want to select the size of image thumbnails to be 
shown in the image gallery, click the Gallery Properties tab and select the size 
of thumbnails: 

Á Small (95 x 75 pixels). 

Á Normal (140 x 130 pixels). This is the default setting. 

Á Large (170 x 170 pixels). 

4. To add images to the gallery, click the text Click here to upload your images, 
select the images that you want to upload, and click OK. 

You can select and upload multiple images at once. Only images in GIF, JPEG, and PNG 
formats are supported. 

We recommend that you use resized images that do not exceed 1024 x 768 pixels. 

5. To change image title and description, click the corresponding thumbnail, 
click the title or description, and edit the text. 

If you delete the default text entirely, it will not be shown on your published site; however, 
it will still be shown when you edit the site in the Web Presence Builder editor. 

ü To remove an image from the gallery: 

Place the mouse pointer over the image thumbnail and click the icon [x]. 

ü To remove an image gallery with all pictures: 

Place the mouse pointer over the image gallery block and click Remove. 

ü To insert a hyperlink or a link to an e-mail address into text: 

1. Select the text that you want to make a link. 

2. On the toolbar of the Text & Images module, click the icon . 
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3. Do any of the following: 

Á To add a link to another webpage on your site, select the option A page of this site. In 
the Select page menu, select the target webpage. 

Á To add a link to a webpage or a file located on another site, select the option A 
webpage or file on the Internet, and type the address. For example, 

http://example.com . 

Á To add a link to a document or another downloadable file that you have previously 
uploaded through the Document Manager (as described in Documents and Other 
Downloadable Files (on page 175)), select the option A document on this site, and select 
the target file. 

Á To add a link that will open a new e-mail message with a pre-filled destination e-mail 
address, select the option A webpage or file on the Internet, and type 

mailto:<address >. For example, mailto:postma ster@example.com . 

You can also: 

Á Predefine the message subject line. For example: 

mailto:postmaster@example.com?subject=My%20Subject . 

Á Add recipients to CC and BCC lists. For example: 
mailto:postmaster@example.com?subject=My%20Subject&cc=addres

s1@example.com &bcc=address2@example.com . 

Á Predefine text to put in the message body. For example: 
mailto:postmaster@example.com?subject=My%20Subject&body=This

%20is%20sent%20from%20your%20site !  

Note:  You should replace white spaces with %20. 

4. In the Open link in menu, select where you want to open the target page. You 
can choose to open it in the same or in a new browser window or tab. 

5. In the Title box, type the description that should appear when users place the 
mouse pointer over the link. 

6. Click OK. 

  
 

mailto:%3Caddress
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Embedded Video 

You can embed into website pages video clips located on popular video sharing sites, such 
as YouTube (youtube.com), Vimeo (vimeo.com), MySpace (myspace.com), and Dailymotion 
(dailymotion.com). 

ü To insert a video into a webpage: 

1. Go to the Modules tab, select Embedded Video, and drag the module to the 
page. 

2. Insert a link to the video or select the option Embed code if you have obtained 
a code from a file sharing site, and then paste the code. 

3. Click OK. 

ü To remove a video: 

Place the mouse pointer over the video and click Remove. 

Contact Form 

If you want your site visitors to be able to send you messages from your site, you can add a 
contact form. 

ü To add a contact form: 

1. Go to the Modules tab, select Contact Form, and drag the module to the page. 

2. On the Settings tab, specify the following: 

Á Recipient's e-mail address. You can specify only one e-mail address. 

Á Message subject. 

Á Text to be shown on the button that sends the message.  

3. If you want to add, move, or remove input fields from the form, or change 
their labels, click the Fields tab, and make the required changes. 

4. If you want to change the default message "Your message was sent. Thank 
you." which is shown when a message is sent, click the Reply tab and type 
the new text. 

5. Click OK. 

ü To remove a contact form: 

Place the mouse pointer over the form and click Remove. 
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Blog 

If you want to maintain an online diary on your site, or regularly publish articles on a subject 
and automatically present them in a chronological order, then you need a blog. 

A blog module can be added only to the first-level pages that do not have subpages. Within 
blog posts, you can use text, images, embedded videos and scripts. Each blog post can 
have its distinctive page description and meta information to be used by search engines. 
Note that blog posts are not listed on the Pages tab (on page 155). 

To let your visitors comment on your blog posts, you need to register with Disqus, a free 
third-party service that provides commenting functions for your sites and keeps all 
comments. 

ü To add a blog to your webpage: 

1. Go to the Modules tab, select Blog, and drag the module to the page. 

2. In the module properties, specify the following: 

Á Number of blog posts to show on the page. 

Á Specify whether the site visitors will be able to leave their comments. 

3. Click OK. 

4. To enable commenting, click the link Click here to add a new blog post. 

5. Click within the gray information box at the bottom of the blank blog post.  

6. To register with Disqus, click the Register button. A registration form will open 
in a new browser window or tab. 

7. Specify the following: 

Á Your site's URL, desired name and shortname (unique ID). You will need to specify 
this site ID (shortname) later in the Blog module settings to enable commenting. 

Á Comment moderator's username, password, and e-mail address. A confirmation 
message will be sent to this e-mail address, so be sure that it is valid. 

8. Click Continue. 

9. Specify your language and other settings, and click Continue.  

10. On the last step of the registration form, no further action is required. Just 
log out of the Disqus site. 

11. Check your e-mail inbox for the confirmation message from Disqus. In this 
message, click the link to verify your address. 

12. Return to the browser window where you have the Web Presence Builder 
editor with the Blog module properties opened. 

13. In the box titled Apply here the website ID (shortname) received during registration, type 
or paste the site ID that you specified during registration with Disqus in step 
7. 
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14. Click Apply. 

15. Click OK. 

Now your blog can accept comments from visitors, and you can make the first post. 

ü To add a blog post: 

1. Go to the website page containing a blog module. 

2. Click the link Click here to add a new blog post (might also appear as New Post 
Title). 

3. Type the post title and content. 

If you want to change the date of posting, click within the field Posted dd.mm.yy and then 
select a date from the calendar. 

If your post is lengthy and contains numerous text blocks, images, and embedded videos, 
you might want to show only a portion (beginning of the post) to site visitors in your blog's 
main page. To do this, while editing a blog post, move the divider element (containing the 
line -------- Drag this above modules that should not appear in the list of posts --------) to the desired 
area.  

4. Click OK. 

5. If you want to view, edit, or remove a concise description of the page that will 
be displayed on search engines results pages and the keywords by which 
the page will be found by search engines, click in a blank area to the right of 
the post title, and then click the SEO Settings tab. 

Note:  Post link name is a required field. Meta description and Meta keywords are optional 
fields. If you specify keywords for a page, they should be separated by commas without 
white spaces. 

6. To return to the blog's main page, click the Back link below the post you have 
just created.  

ü To remove a blog post: 

1. Go to the website page containing a blog module. 

2. Place the mouse pointer over the post title and click Remove. 

3. Click Yes to confirm removal. 

ü To edit a blog post: 

1. Go to the website page containing a blog module. 

2. Click the post title. 

3. Make the required changes and click OK. 
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ü To remove a blog with all posted content: 

1. Go to the website page containing a blog module. 

2. Place the mouse pointer over the link Click here to add a new blog post and click 
Remove. 

3. Click Yes to confirm removal. 
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Commenting 

If you want to let your site visitors leave comments on webpages, you need to insert the 
Commenting module into those webpages. 

The commenting functionality is powered by Disqus, a third-party service that stores and 
processes all comments. Before your visitors can leave comments, you need to register an 
account with Disqus and then specify a site ID in the Commenting module settings. 

You can insert several Commenting modules into a single website. Because all Commenting 
modules on the site will use the same site ID, you will only need to specify the site ID once in 
the module settings, when inserting the first Commenting module. 

ü To add commenting functions to a webpage: 

1. Go to the Modules tab, select Commenting, and drag the module to the page. 

2. If you have not registered an account with Disqus yet, click the Register 
button. A registration form will open in a new browser window or tab. 

3. Specify the following: 

Á Your site's URL, desired name and shortname (unique ID). You will need to specify 
this site ID (shortname) later in the Commenting module settings to enable 
commenting. 

Á Comment moderator's username, password, and e-mail address. A confirmation 
message will be sent to this e-mail address, so be sure that it is valid. 

4. Click Continue. 

5. Specify your language and other settings, and click Continue.  

6. On the last step of the registration form, no further action is required. Just 
log out of the Disqus site. 

7. Check your e-mail inbox for the confirmation message from Disqus. In this 
message, click the link to verify your address. 

8. Return to the browser window where you have the Web Presence Builder 
editor with the Commenting module properties opened. 

9. In the box titled Apply here the website ID (shortname) received during registration, type 
or paste the site ID that you specified during registration with Disqus in step 
3. 

10. Click Apply. 

11. Click OK. 

Now you can publish your website to the customer account and start receiving comments 
from your visitors. 
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In addition to adding and viewing comments, you can do the following: 

Á Edit comments. 

Á Delete comments. 

Á Mark comments as spam. 

Á Ban users (by e-mail or IP address) from posting comments on your site. 

Á Change the settings, such as appearance of comments, and remove the trackback URL. 
You can do this by logging in to your account at www.disqus.com, and going to the 
Settings tab.    

ü To moderate comments: 

1. Log in to Disqus as the site administrator. You can do this in either of the 
following ways: 

Á Visit the Disqus site at www.disqus.com and log in there. 

Á In the Web Presence Builder editor, go to the page where you have the Commenting 
module and click inside the Add New Comment field. Click the Post as button, click the 
Disqus link in the left navigation pane, type your username and password, and click 
Login. 

2. After you are logged in to Disqus, you can moderate comments in either of 
the following ways: 

Á On the Disqus site, use the items in the Dashboard and Admin areas. 

Á In the Web Presence Builder editor or on the published site, go to the page where you 
have the Commenting module, place the mouse pointer over the comment you want 
to moderate, and use the Moderate link that will appear next to the comment. 

Alternately, you can moderate comments by using links in the notification messages that 
Disqus sends you when someone leaves a comment on your site. 

ü To remove commenting functions from a webpage: 

1. In the Web Presence Builder editor, go to the website page containing the 
Commenting module. 

2. Place the mouse pointer over the Add New Comment field and click Remove. 

3. Click Yes to confirm removal. 
 

http://www.disqus.com/
http://www.disqus.com/
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Documents and Other Downloadable Files 

The editor now provides a convenient control panel for working with files in your customer 
account. You can upload your documents, images, and other files in various formats to the 
editor (on the Documents tab), and then insert links to them in your website pages. 
Alternatively, you can just keep them in your customer account for your own needs. 

ü To upload a file to the customer account: 

1. Go to the Documents tab. 

2. Click Upload. 

3. Select the file and click Open. 

Now, to let your site visitors download this file, you can insert a link to it in a webpage. 

ü To insert a link to file: 

1. Select the text that you want to make into a link. 

2. On the Text & Images module's toolbar, click the icon . 

3. Select the option A document on this site. 

4. Select your file and click OK. 

ü To remove a file from the customer account: 

1. Go to the Documents tab. 

2. Select the file and click Remove. 

3. Confirm removal and click OK. 
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Buttons for Sharing on Social Networks 

If you want to let your visitors easily share your content on social networks or online 
bookmarking services, you can insert a toolbar with buttons for sharing on Facebook, Twitter, 
Myspace, and other popular services. 

ü To add the Share on Social Media toolbar to a webpage: 

1. Go to the Modules tab, select Social Sharing, and drag the module to the page. 

2. Select the appearance of the toolbar. 

3. If you want to modify the list of social networks and sharing services shown 
on the toolbar, place the mouse pointer over the icon [+] and click the Settings 

link. 

The changes you make to the list of services will be visible after you publish the site. 

4. Click OK. 

Note:  When someone shares your content on Twitter by using the Tweet button, the counter 
of tweets is not increased immediately. It can take several hours for the counter to update. 

ü To remove the Social Media toolbar: 

Place the mouse pointer over the toolbar and click Remove. 

Site Search 

If you want to let your visitors search for information on your website, you can add a search 
bar to the site. After inserting the search bar into a webpage, it is automatically added to all 
pages of the site. 

By default, the search bar is configured to use the Google search engine. If you want to use 
another search engine, you can obtain the search script code and insert it into the Search 
module. 

ü To add a search bar to the site: 

1. Go to the Modules tab, select Search, and drag the module to the page. 

2. Do any of the following: 

Á If you want to use the search service provided by Google, leave the Google option 
selected. 

Á If you want to use another search engine, select Other and paste the code that you 
have obtained from that service. 

Make sure that the code you insert is correct, as Web Presence Builder does not 
validate it.  

3. Click OK. 
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The search bar will appear on your site after publishing. 

ü To remove a search bar: 

Place the mouse pointer over the search bar and click Remove. 

Online Store 

If you want to sell products or services through your site, you can use the Online Store and 
Shopping Cart modules to add a fully functional online store to the site. You can add only one 
store per site. 

The store functionality is provided by Ecwid - a third-party SaaS solutions provider that 
securely stores and processes all your data, including product catalogs, images, orders, and 
customers' payments. 

ü To add an online store to your site: 

1. Go to the Modules tab, select Online Store, and drag the module to the page. 

2. Create an account with Ecwid if you do not have one yet, or specify the ID of 
an existing store if you have previously created a store at Ecwid through 
Web Presence Builder and want to show it on your site. 

If you do not have an account with Ecwid yet, do the following: 

a. In module settings, on the General tab, select the option Register with 
Ecwid. 

b. Type your name, e-mail address, and password. You will use the e-
mail address and password to sign in to Ecwid and manage your 
store. 

c. Click Send. A confirmation message from Ecwid will be sent to your e-
mail address. You will need to confirm that you own this e-mail 
address within three days, otherwise the online store will be 
deactivated. 

If you already have an account with Ecwid, select the option Enter an ID of an existing shop, 
specify the store ID and e-mail address that you specified during account registration, 
and click Apply. 

Note:  If the online store was created directly at the Ecwid website without using Web 
Presence Builder, you can do the following: Create a new Ecwid account through WPB, 
log in to the previously existing Ecwid account, export all the goods to a CSV file. After 
that, log in to the new account and import the file.  

3. (Optional step.) If you want to let your customers add items to the cart by 
dragging them to a shopping bag icon, go to the Modules tab, select the 
Shopping Cart module, and drag it to the page. 

Note that the shopping bag icon will be inserted into all pages of your site. If you do not 
want that, do not use the Shopping Cart module. Your customers will still be able to add 
items to the cart and proceed to checkout by using the Shopping Bag link that appears at 
the top of the product catalog area. 
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4. (Optional step.) If you want to change the appearance of the product catalog, 
in module settings, go to the View tab. 

5. To set up your store, fill the product catalog with items, and remove the 
default fruit and vegetable items added by Ecwid, click the Manage link on the 
module's toolbar. 

The Ecwid control panel will open in a new browser window or tab. 

6. After you have finished setting up the store in the Ecwid control panel, return 
to the Web Presence Builder editor and click the Reload link on the Online Store 
module's toolbar. 

You must use the Reload link to synchronize the content of your online store with online 
store at Ecwid. 

7. Click OK to finish setting up the store. 

ü To manage a store: 

Place the mouse pointer over the product catalog and click Manage. The Ecwid control panel 
will open in a new browser window or tab. 

Note:  After publishing your site, you can also view information about new orders on the 
Dashboard (on page 188). 

ü To remove a store: 

Place the mouse pointer over the product catalog and click Remove. 

Custom Scripts 

You can insert custom scripts written in PHP, JavaScript, or VBScript in any page of your 
website. 

ü To insert a script in a webpage: 

1. Go to the Modules tab, select Script, and drag the module to the page. 

2. Paste the code into the input field. 

For PHP, use the opening tag <?php . Make sure the code you insert into this field is 

correct, as Web Presence Builder does not validate it. 

3. Click OK. 

Your code will be active only on the published website. 

ü To remove a script: 

Place the mouse pointer over the script block and click Remove. 

 



 

 Building Websites with Web Presence Builder 179 

 

Advertisements 

If you are participating in a banner exchange or other online advertising programs, you might 
want to add an advertisement block to your site. After inserting the block in a webpage, it will 
be automatically added to all pages of your site. 

ü To add an advertisement block: 

1. Go to the Modules tab, select Advertisement, and drag the module to the page. 

2. Paste the code provided by your advertising vendor into the input field.  

Make sure that the code you insert into this field is correct, as Web Presence Builder 
does not validate it. With some advertising vendors, you will need to validate your 
account first. 

3. Click OK. 

Advertisements will appear on your website after publishing. 

ü To remove an advertising block: 

Place the mouse pointer over the block and click Remove. 
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Settings and Tools for Webmasters 

This section describes how to do the following: 

Á Change website name, description, and keywords. 

Á Upload a site icon (favicon) for your website. 

Á Make your website more visible in search results, and embed various search engine 
services. 

Á Prevent certain pages or areas of your website from being indexed by search engines 
and shown in search results. 

ü To edit your website name, description, and keywords: 

1. Go to the Settings tab > Basic tab. 

2. Specify the website name that your visitors will see as the title of their 
browser window when they visit your website. 

3. To show both your website name and the current page name in the browser 
title window and to increase your website recognition in search engine 
results, select the Add website name to page titles checkbox. 

4. Add short description (up to 255 symbols) of your website. 

This will be used as the default description for new pages. It will be shown by search 
engines when people see your website in search results. 

5. Provide a list of keywords that describe your website (10-15 keywords are 
recommended). 

These keywords will be used as default keywords for new pages. Keywords are analyzed 
by search engines and are used for displaying your website when people search for 
these keywords. 

6. Click OK to save changes. 

A favicon is a small icon displayed in the browserôs address bar when you visit a website, 
and also appears next to the website name in the list of favorite bookmarks. You can create 
a favicon using a variety of online tools and then upload your favicon through the Web 
Presence Builder editor. All your website visitors will see this favicon. 

ü To upload a favicon for your website: 

1. Go to the Settings tab > Basic tab. 

2. Click Browse and select the location of the favicon to upload. The favicon will 
be uploaded. 

3. Click OK to save changes. 
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ü To remove a favicon from your website: 

1. Go to the Settings tab > Basic tab. 

2. Click Remove in the Favicon section. The favicon will be removed. 

3. Click OK to save changes. 

Most search engines require you to verify website ownership when you register your website 
or sign up for webmaster assistance services. Verification is typically done by uploading or 
creating a file with a specific file name. 

ü To verify website ownership: 

1. Go to the Settings tab > Advanced tab. 

2. Provide the verification file: 

Á If you know the name of the verification file requested by a search engine, provide the 
verification file name in the Create verification file field and click OK. Web Presence 
Builder will create it in the correct place.  

Á If you have already downloaded your verification file from a search engine, upload the 
verification file to the Upload verification file field and click OK.  

3. After the verification file is created or uploaded and your website is 
published, confirm your ownership on the search engine website. 

4. Click OK to save changes. 

ü To edit the HTML <head>  section of your website (for example, to add 

ownership verification meta code): 

1. Go to the Settings tab of the Web Presence Builder's main menu, then go to 
the Advanced subtab. 

2. Click Edit Metadata. 

3. Insert the code into the provided field and click Add.  

Note:  Only valid HTML tags permitted for <head>  section by HTML standards are 

supported. Metadata changes will be available only after you publish your website. 

4. Click OK to save changes. 

Google Analytics is a tool that allows you to obtain information about your visitors. After you 
register with Google Analytics and acquire the required code, you can embed Google 
Analytics on your website. 

ü To embed Google Analytics: 

1. Register with the Google Analytics service and acquire the code. 

2. Go to the Settings tab > Advanced tab. 
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3. Click Embed Google Analytics. 

4. Insert the code you have received from Google Analytics into the provided 
field and click Add.  

Note:  Google Analytics will start working only after you publish your website. 

5. Click OK to save changes. 

Some search engines will ask you to provide your sitemap for analysis and optimization 
purposes. You can download your sitemap from the Web Presence Builder editor. 

ü To download your website sitemap: 

1. Go to the Settings tab > Advanced tab. 

2. Click Download Sitemap. 

3. Click OK to start downloading the sitemap.xml  file. 

To prevent search engines from indexing certain pages of your website, you can add the 

appropriate directives into the robots.txt  file. This file is stored on the customer account 

to which your site is published.   

ü To prevent search engines from indexing certain areas of your website: 

1. Go to the Settings tab > Advanced tab. 

2. Click the link Edit robots.txt. 

3. Type your directives into the input field. Place each directive on a new line. 

For example, to prevent all search engine robots and crawlers from indexing the contents 

of the directory /private  and the file /my_secret.html  on your customer account, 

add the following lines: 

User - agent: *  

Disallow: /private/  

Disallow: /my_secret.html  

For more information about the robots.txt  file and directives you can use, refer to 

http://www.robotstxt.org/robotstxt.html. 

http://www.robotstxt.org/robotstxt.html
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Saving and Loading Copies of a Website 

While working on the content and design of a website, you can save several copies of each 
site to the server and restore sites from the saved copies (also referred to as snapshots). 
Saving site copies can be useful in the following cases: 

Á You want to prepare several versions of the same website, so that you can later load 
them for review, choose the best designed or the most appropriate version, and publish it 
to the Internet. 

Á You want to make significant changes or experiment on the site design or content, but be 
sure that you can safely undo the changes should anything go wrong. 

Note:  Pictures from the Image Gallery modules are not saved in snapshots. Images are stored 

on your customer account or Picasa Web Albums (if you use that option). 

ü To save the current design and content of a site: 

1. In the Web Presence Builder editor's main menu, click the icon  next to the 
Save option. 

Note:  If you click Save, a quick-save site copy will be saved under the name auto-saved 
snapshot. You will be able to restore a site from this copy later, by clicking Revert in the 
main menu. 

2. In the list that opens, select a free saving slot, type a name for the backup 
copy, and click Save. 

ü To restore a site from a saved copy: 

1. In the Web Presence Builder editor's main menu, click the icon  next to the 
Revert option. 

Note:  If you click Revert, a site will be restored from the quick-save copy that was made 
the last time you clicked Save. 

2. In the list that opens, select a site copy and click Load. 

3. Click Yes to confirm you want to restore. 

ü To download a site copy: 

1. In the Web Presence Builder editor's main menu, click the icon  next to the 
Save option. 

2. Locate the copy that you want to download and click the (Download) icon. 

3. Select the directory on your computer where you want to save the file and 
click OK. 
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ü To upload a site copy: 

1. In the Web Presence Builder editor's main menu, click the icon  next to the 
Revert option. 

2. Click the (Upload) icon next to the slot to which you want to upload the 
copy. 

3. Browse to the site snapshot file in the SSB format and select it.  

4. If you want to restore a site from the uploaded snapshot, select it and click 
Load. 

ü To remove a site copy: 

1. In the Web Presence Builder editor's main menu, click the icon  next to the 
Save option. 

2. Locate the site copy that you want to remove and click the corresponding
(Remove) icon. 
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Publishing a Website to the Internet 

When your website design and content are ready to be published to the Internet, click Publish 
in the top right corner of the main menu. Web Presence Builder will publish your website 
automatically to the location specified by your hosting provider. 
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Publishing a Website Copy to Facebook 

After publishing a site on the Internet, you can drive more visitors to it by publishing a site 
copy to the popular social network site - Facebook (www.facebook.com). 

A site copy on Facebook will show most of the content from your site; however, the following 
changes will be applied to its design and layout: 

Á Headers, sidebars, and footers will not be shown. 

Á The navigation menu will be shown only at the top of the site pages. 

Á Page width will be limited to 520 pixels. For pages wider than 520 pixels, a horizontal 
scrollbar will be shown. 

Á The font face, size, and color will be changed to comply with the Facebook design, 
unless these font properties were specifically selected by the site owner in the Web 
Presence Builder editor. 

Á Image galleries, online store, and links for sharing on social media sites will not be 
shown. 

ü If you want to add a site copy to Facebook, do the following: 

1. In the main menu, click the Settings tab > Social Media tab. 

2. Leave the checkbox Show a copy of my site on Facebook selected. 

3. Click the link Add your site copy to Facebook. The Facebook home page opens in 
a new browser window or tab. 

4. To log in to your Facebook account, type your e-mail address and password, 
and click Log In. 

5. If you do not have a Facebook page where you want to show a site copy, 
create one. To do this, click Create It Now, and follow the onscreen guidelines. 
After your page is created, return to the Parallels Web Presence Builder at Facebook 
page, which is shown in another browser window or tab. 

6. Click Add Parallels Web Presence Builder Application. This application provides 
synchronization between the website on your hosting account and its copy 
on Facebook. 

7. To confirm that you want to add the application to your page, click Add 
Parallels Web Presence Builder. 

Now your site copy is added. To see it, click the Website link in the Facebook navigation pane 
on your left. 

Whenever you make changes to your site and republish it through the Web Presence Builder 
editor, your site copy on Facebook will be updated accordingly. 

 

http://www.facebook.com/
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ü To remove a site copy from Facebook, do the following: 

1. In the Web Presence Builder editor's main menu, click the Settings tab > Social 
Media tab. 

2. Clear the checkbox Show a copy of my site on Facebook. 

3. Click Yes to confirm. 

4. Go to your Facebook page and remove the Web Presence Builder 
application from there. 
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Viewing Site Visits Statistics, Comments, 
and New Orders on the Dashboard 

After publishing a site, you can access the Dashboard from the Web Presence Builder's main 
menu to perform the following tasks: 

Á View statistics on website visits. The statistics are provided by Google Analytics and are 
available after you specify the code for Google Analytics in website settings, as described 
in the section Settings and Tools for Webmasters (on page 180). 

Á View new comments left by site visitors on your website pages. The comments are visible 
on the Dashboard after you set up the commenting functionality, as described in the 
sections Blog (on page 169) and Commenting (on page 173).  

Á View new orders from customers visiting your online stores. The new orders are visible 
on the Dashboard after you set up an online store, as described in the section Online 
Store (on page 177). 

ü To view website visits statistics: 

1. On the main menu, click Dashboard. 

2. If you access the dashboard for the first time, confirm association of your site 
with your Google Account: 

a. Click Log In to Google Analytics. 

b. Log in to your Google Account. 

c. Confirm that you want to allow access to your account. 

3. Under the Website Visits Statistics chart, click the link See more charts, or click the 

 icon. 

The Overview section shows the following statistics for the past 30 days: 

Á A detailed chart for the metric currently selected under Profile report. 

Á The total number of visits during the past 30 days. 

Á The number of new visits. 

Á Average time spent on a site by users. 

Á The total number of page views. 

Á The number of page views per each visit. 

Á The percentage of new visits. 

The Traffic sources overview section shows the addresses of websites from which your 
visitors were coming during the past 30 days. The (direct) item shows the percentage of 
visitors who accessed your site by typing its address directly in their browsers. 

The Visitors' locations section shows the geographic locations of the visitors for the past 30 
days. 



 

 Building Websites with Web Presence Builder 189 

 

ü To view comments from your site visitors: 

1. On the main menu, click Dashboard. 

2. Under Comments, click the link See them, or click the  icon. 

3. To go to the webpage where the comment was left, click Link to the comment. 

4. To go to the Disqus site for moderating the comments, click Manage Comments. 

ü To view orders submitted by the customers visiting your online stores: 

1. On the main menu, click Dashboard. 

2. Under Orders, click the link See them, or click the  icon, and then click the 
Orders tab. 

3. To go to the Ecwid site for processing the orders, click Manage Orders. 
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Deleting Websites 

When you delete a site from the Web Presence Builder editor, only the current site draft 
opened in the editor and saved site copies (snapshots) are removed. The site copy published 
to your hosting account is not removed. 

ü To delete a current site copy from the editor: 

In the Web Presence Builder editor's main menu, select More > Remove Site. 

 



 

  
 

One of the most convenient ways to update your website content is to upload it through 
FTP. FTP (File Transfer Protocol) is a standard network protocol that allows 
transferring files between two hosts (say, your computer and a Panel server). Panel 
acts as an FTP server, while users should use some FTP client to access the 
directories on the server. Panel provides all main FTP features: 

Á Authorized access to the server. Learn more in the section Changing FTP Access 
Credentials (on page 191). 

Á Multiple user accounts for collaborative work. Learn more in the section Adding FTP 
Accounts (on page 192). 

Á Anonymous FTP access: The access without authorization that may be used, for 
example, to share software updates. Learn more in the section Setting Up Anonymous 
FTP Access (on page 194). 

In this chapter: 

Changing FTP Access Credentials ....................................................................191 
Adding FTP Accounts ........................................................................................192 
Setting Up Anonymous FTP Access ..................................................................194 

 
 

Changing FTP Access Credentials 

ü To change FTP account username or password: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription 
menu at the top of the screen, select the webspace where the website 
is hosted.     

2. Click the Websites & Domains tab. 

3. Click Web Hosting Settings. 

4. Type a new username or password. 

5. Click OK. 
 

C H A P T E R  6  

FTP Access to Your Websites 
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Adding FTP Accounts 

If you are working on your website together with someone else or host subdomains for 
other users, you might want to create separate FTP accounts for them. 

ü To create an additional FTP account: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription 
menu at the top of the screen, select the required webspace.     

2. Click the Websites & Domains tab. 

3. Click FTP Access. 

4. On the Additional FTP Accounts tab, click Create Additional FTP Account. 

5. Specify the following: 

Á FTP account name. Type an arbitrary name. 

Á Home directory. Select the directory to which the user will be taken when he or 
she connects to the FTP account. 

Á FTP password. 

Á Hard disk quota (on Windows hosting). To limit the amount of disk space on the 
server that the FTP user can occupy, clear the Unlimited checkbox next to the 
Hard disk quota box, and type the amount of disk space in megabytes. 

Á Read permission (on Windows hosting). To allow the FTP user to view the 
contents of the home directory and download files from it, select the Read 
permission checkbox. 

Á Write permission (on Windows hosting). To allow the FTP user to create, view, 
rename and delete directories in the home directory, select the Write permission 
checkbox. 

On Window hosting, if you do not grant any permissions, a connection to the 
FTP account will be made, but the contents of the home directory will not be 
shown to the user. 

6. Click OK. 

ü To change the properties of an additional FTP account: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription 
menu at the top of the screen, select the required webspace.     

2. Click the Websites & Domains tab. 

3. Click FTP Access. 
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4. On the Additional FTP Accounts tab, click the required FTP account name 
in the list. 

5. Make the required changes and click OK. 

ü To remove an additional FTP account: 

1. If you are subscribed to several hosting packages and have access to 
several webspaces associated with your account, in the Subscription 
menu at the top of the screen, select the required webspace.     

2. Click the Websites & Domains tab. 

3. Click FTP Access. 

4. On the Additional FTP Accounts tab, select the checkbox corresponding to 
the FTP account you want to remove and click Remove. 

5. Confirm removal and click OK. 
 














































































